WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore 6.0 Beta1  (Read 3426 times)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
piCore 6.0 Beta1
« on: November 20, 2014, 03:54:24 AM »
Team Tiny Core is pleased to announce that piCore 6.0 Beta1 is available for public testing:

http://repo.tinycorelinux.net/6.x/armv6/release_candidates/

This is a beta level cut. If you decide to help test, then please test carefully. We don't want anyone to lose data.

Since this is an beta cut, although the team has worked through several preview cuts, we ask that only experienced users test. This cut is not for production use. The features in any beta may change before a public release candidate is available.

Note that the fltk library has been updated to 1.3.3 to enable unicode. fltk-1.1 and 1.3 can be installed at the same time, and old apps using 1.1 will continue to work.

We appreciate testing and feedback.

Changelog for 6.0 Beta1:

* kernel updated to 3.17.3
* glibc updated to 2.20
* gcc updated to 4.9.2
* e2fsprogs base libs/apps updated to 1.42.12
* util-linux base libs/apps updated to 2.25.2
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 178
Re: piCore 6.0 Beta1
« Reply #1 on: November 22, 2014, 01:56:17 AM »
Hi Béla,

I've installed this version just like I always install my Radio Raspberry, with the exception that I now have to install this extension:

Code: [Select]
tce-load -wi firmware-rtlwifi.tcz
To make my WiFi adapter work.

But now I encounter the problem that I only have a WiFi connection when ethernet is plugged in. Once I remove the ethernet cable, the WiFi connection is lost.
If I restart with the ethernet cable disconnected, it does not make a WiFi connection.

It was all working fine when I used the 6.0 Alpha  501 version.

Any idea?

Greetings,
    Gerrelt.
my Raspberry Pi page: http://raspberry.gerrelt.nl

Offline lykkedk

  • Full Member
  • ***
  • Posts: 156
Re: piCore 6.0 Beta1
« Reply #2 on: November 23, 2014, 01:25:36 AM »
Hi Bela'

I have a strange problem... looks like /opt/bootlocal.sh, isen't executed, besides the first line ofcause.

Look here :

Quote
tc@box:~$ cat /opt/bootlocal.sh
#!/bin/sh
# put other system startup commands here

/usr/local/etc/init.d/openssh start
/usr/local/etc/init.d/squeezelite start
amixer sset 'DIYINHK Clock Selector' 123 unmute
amixer sset 'DIYINHK Clock Selector' on

Then normally my squeezelite should be executed at boot; But dosent, manual start after boot works flawlessly :

Quote
tc@box:~$ sudo /usr/local/etc/init.d/squeezelite status
[OK!] --> squeezelite Is not started
tc@box:~$ sudo /usr/local/etc/init.d/squeezelite start
[OK!] --> squeezelite Start

At my piCore with 3.16.3 kernel, the script is working as it's supposed to.

i have the right entrys (Also my squeezelite.tcz is located in optional directory) :

Quote
tc@box:~$ cat /mnt/*p2/tce/onboot.lst
mc.tcz
openssh.tcz
alsa-config.tcz
libmad.tcz
flac.tcz
nano.tcz
squeezelite.tcz

Regards;
   Jesper.

EDIT ::

I tried to reboot again, looks like squeezelite.tcz is "loaded", but lines in /opt/bootlocal.sh not executed.

jesper@jlp:~$ ssh tc@192.168.1.132
tc@192.168.1.132's password:
 (�-
 //\   Core is distributed with ABSOLUTELY NO WARRANTY.
 v_/_           www.tinycorelinux.com

tc@box:~$ tce-load -i squeezelite.tcz
squeezelite is already installed!
tc@box:~$ sudo /usr/local/etc/init.d/squeezelite status
[OK!] --> squeezelite Is not started
tc@box:~$




« Last Edit: November 23, 2014, 02:10:16 AM by lykkedk »

Offline lykkedk

  • Full Member
  • ***
  • Posts: 156
Re: piCore 6.0 Beta1 - Tmp. Solution found
« Reply #3 on: November 23, 2014, 08:31:30 AM »
 :) Hi...

There must be a little bug...

I fixed my problem, pasting a little pause into /opt/bootlocal.sh, then all work's

How is the bootsync.sh / bootlocal.sh executed - From where is it executed (bootloader/Kernel etc... ?)

Btw: bugtracking is fun  8)

Quote
#!/bin/sh
# put other system startup commands here

/usr/local/etc/init.d/openssh start

sleep 4

amixer sset 'DIYINHK Clock Selector' 123 unmute
amixer sset 'DIYINHK Clock Selector' on
/usr/local/etc/init.d/squeezelite start


Regards;
   Jesper.

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore 6.0 Beta1
« Reply #4 on: November 24, 2014, 10:11:28 AM »
Hi bm!

Tried the X version. Failed installing the mega package compile* and then the app manager kind of froze. If I marked a package it wouldn't show anything and the "GO" button didn't respond. Haven't had much time to try it out since I'm playing with multiple operating systems running VNC that I use in Plan 9 OS on the Raspberry Pi. Will try more later on in the week. Keep up the good work!

Have fun developing the RPi version of TC,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: piCore 6.0 Beta1
« Reply #5 on: November 24, 2014, 11:10:10 AM »
Tested, it works fine.

Did you expand /dev/mmcblk0p2 to an appropriate size?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore 6.0 Beta1
« Reply #6 on: November 25, 2014, 10:18:44 AM »
Hi bm!

My bad! Didn't know I had to. I'd better read up a little on the subject. Thanks!

Keep up the good work,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: piCore 6.0 Beta1
« Reply #7 on: November 25, 2014, 11:01:37 AM »
There is a README in the zip.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore 6.0 Beta1
« Reply #8 on: November 27, 2014, 02:37:27 AM »
Hi bm!

Yes, I know. The funny thing is that I had it formatted to fit on the two sides of an A4 paper but didn't print it out. Now I have and the setup was made late last night. Checked it out now and found that tcWbarConf doesn't respond. Otherwise it seems OK. Good Work!!!

Have fun developing a bleeding edge distro for the Raspberry Pi,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: piCore 6.0 Beta1
« Reply #9 on: December 01, 2014, 10:15:34 AM »
Hi BM, really good work on the new 6.0.  :)

During evaluation I've hit some issues. One is the wireless network failure. First, the wireless_tools package need to install additional firmware. For example rtl8192cu driver need to install firmware "rtlwifi". Previous version supported this chipset without additional firmware. Only the core driver was enough.
Than the connection need some time (5-15 sec.) after the dhcp gets the address to established the connection. Than the connection is lost after several minutes and only system reboot reconnects it.
 When installed additionally Ralink firmware to the rtlwifi, the "BCM" core like a USB hub bcm2807 and sound bcm2835 starts to fail during startup - waitusb=5 is not enough. Sometimes it need several restarts to start working correctly.
 Another issue, probably with the same root cause is failing of USB devices, for example USB Flash Drive need several times longer time to start working and sometimes the file-system is corrupted and need to be repaired with checkdisk. The transfer speed is too slow.

 Good improvements were done for USB sound which doesn't need the "sound" group creation and chown setup any more.
Another good and working improvement is simpler ALSA setup. May be that the "top" package may be only simple "alsa" instead of "alsa-config". Alsa is one step below now. But it is only my feeling.

Offline gavinmc42

  • Sr. Member
  • ****
  • Posts: 301
Re: piCore 6.0 Beta1
« Reply #10 on: December 01, 2014, 10:25:55 PM »
Serial console mode not working fully, see Model A+ post

Just checked hardware by running Raspbian, serial console working, can login etc

Tried 5.3 no console output at all.
Tried 6.0 beta, basic and ssh versions, only Uncompressing Linux message

Offline gavinmc42

  • Sr. Member
  • ****
  • Posts: 301
Re: piCore 6.0 Beta1
« Reply #11 on: December 01, 2014, 10:41:09 PM »
Ok, not just A+ serial console problem

Tested on old B model.
Only get
Uncompressing Linux... done, booting the Kernel.

Not serial program either, tested it on Putty, SuperPutty, Realcom and Hercules terminal programs.

Has anyone had serial console working on any Pi and TC revision?