WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Almost to the finish line with TC Remaster - one obstacle left!  (Read 1239 times)

Offline centralware

  • Full Member
  • ***
  • Posts: 234
Almost to the finish line with TC Remaster - one obstacle left!
« on: November 11, 2014, 04:08:17 AM »
I've done a good deal of rewriting tc-config to handle tasks needed for my own project, but there's one that's eluding me.

In the case-loop for command-line options, everything is listed there except the one left on my list...  tce=[type]=[value]
At the start of the script, it sets up a variable TCEDIR which initially points to /tmp/tce.  If the system has no tce= variable, this continues on to being the install location for temporary TCZ files.

I moved the call to devadm to ABOVE this loop (necessary for USB devices) and directly after I have a script running which checks for a new boot code called TCC which uses the same format at tce.  TCC's (which for me stands for TCE Compare) job is to detect a hot-swap media device such as tcc=LABEL=myusbstick or tcc=UUID=12345 where if a partition with that name or ID is found, it's job is to REPLACE tce=, opt= and other persistent areas with the one noted by tcc=.  The problem is, I don't know where tce= takes place...  though something tells me it's likely going to be found in the kernel patches, but I figured I'd ask before I venture into that direction.

I've tried everything I know of thus far to circumvent tce= but nothing's getting though as of yet.
I've tried to replace $TCEDIR with the new location of (example) /mnt/sdc1/tce...  it goes basically ignored.
I've overwritten $CMDLINE and replaced cat /proc/cmdline in the loop.
I can't overwrite /proc/cmdline directly (not that I know of at least) so if the area running tce= is using something I either do not know exists, or is too far past tc-config to matter.

Any thoughts on this would be greatly appreciated!

Offline centralware

  • Full Member
  • ***
  • Posts: 234
Re: Almost to the finish line with TC Remaster - one obstacle left!
« Reply #1 on: November 11, 2014, 04:21:17 AM »
EDIT: Please forgive the question...  no sooner did I hit POST did the answer dawn on me.

/usr/bin/tc-* files...  some of these are called from tc-config...

/usr/bin/tc-setup in particular.
Changed cat /proc/cmdline to $CMDLINE and...  viola!  All those hours hunting...  but at least successful!

Thanks & take care!