WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problem using it from a pendrive  (Read 3269 times)

olihd

  • Guest
Problem using it from a pendrive
« on: October 10, 2014, 12:30:04 AM »
Hi All,

i'm new to this distro and run in a problem now. Have installed coreplus (latest version) with unetbootin (linux and windows version tested) to a pendrive. Works perfect and i can boot (default option) without any problems. When i now starts apps to installed apps he allways tells me that this is the first run.... I use set to set a folder on the pendrive. The folder and subfolder is created. I select the app (firefox.tcz) and download it (selecting on boot) i can see the app in /tce/optional - even after rebooting - but i never get a desktop icon....... I tried to specify the folder with tce on boot but this gives my a cli only - no graphical desktop.
Any help welcome.....

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
Re: Problem using it from a pendrive
« Reply #1 on: October 10, 2014, 01:50:55 AM »
We do not support third-party installers. Please install using a supported installer first.
The only barriers that can stop you are the ones you create yourself.

Offline bapon

  • WikiUser
  • *
  • Posts: 11
Re: Problem using it from a pendrive
« Reply #2 on: October 26, 2014, 01:48:15 AM »
Hi curaga,

i am having similar problems.
I used the universal usb installer.

Can you please give me some hints what the supported installers are, if I want to install to a usb stick?

Thanks.

Bapon

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: Problem using it from a pendrive
« Reply #3 on: October 26, 2014, 01:57:47 AM »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
Re: Problem using it from a pendrive
« Reply #4 on: October 26, 2014, 02:01:21 AM »
core2usb from Windows, or the builtin installer of coreplus.
The only barriers that can stop you are the ones you create yourself.

Offline bapon

  • WikiUser
  • *
  • Posts: 11
Re: Problem using it from a pendrive
« Reply #5 on: October 26, 2014, 03:25:18 AM »
Hi,

thanks for replying so quickly. I immediately tried core2usb.
The result so far is worse:

At the boot menu I select "...WiFi + Firmware", just as I did, when I had the Universal USB Installer installed it onto my USB.

But unlike with UUI all I get now is a prompt. No desktop. Even so, when I tab the boot entry and change desktop to e. g. hackedbox.

Thanks for being patient with me.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Problem using it from a pendrive
« Reply #6 on: October 26, 2014, 07:12:42 PM »
coreplus comes with an installer I believe " tce-install " otherwise install it from the repo.   check for or add the boot code  " waitusb=5 "  to help with slow USB stick's then you'll be able to load the desktop required extensions, if 5 seconds is not enough then try 10

Also check here  http://wiki.tinycorelinux.net/wiki:start#installing
« Last Edit: October 26, 2014, 07:17:25 PM by coreplayer2 »

Offline bapon

  • WikiUser
  • *
  • Posts: 11
Re: Problem using it from a pendrive
« Reply #7 on: October 27, 2014, 01:15:49 AM »
Hi,

thanks again for your replies.
I played around with waitusb quite lot. It didn't make any difference.

The desktop showed up only if I renamed the tce directory to cde. Then again the system wouldn't remember anything.

I found out one solution that seems to work.

First I changed the file system on my pendrive from fat32 to ext2, as the home=... boot codes wouldn't be accepted saying "Microsoft file system bla bla".

Plus:

As I said earlier, in the boot menu I select WiFi+Firmware.

There I edit the initrd line by removing
cde, (removing cde alone didn't work)
showapps ...,
base

All I keep is desktop=...
and I add waitusb=5, tce=... home=... etc.

That brings up the desktop alright and it keeps the tce and e. g. my wifi password.
Also no "first run" after every boot.
 
I've persisted the initrd... changes in the boot menu file.

I haven't tried yet which of the omissions did the trick.
And I'm far from understanding, why.

Any ideas?
« Last Edit: October 27, 2014, 01:20:19 AM by bapon »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
Re: Problem using it from a pendrive
« Reply #8 on: October 27, 2014, 01:53:04 AM »
The CorePlus menu items are for CD use - they expect a CD, so using them as-is on an usb stick is not expected to work.
The only barriers that can stop you are the ones you create yourself.

Offline bapon

  • WikiUser
  • *
  • Posts: 11
Re: Problem using it from a pendrive
« Reply #9 on: October 27, 2014, 02:58:57 AM »
Thanks.
Though I had hoped to get some explanations in order to somewhat understand what is happening, I'm happy it works now.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
The only barriers that can stop you are the ones you create yourself.

Offline anuj

  • WikiUser
  • *
  • Posts: 3
Re: Problem using it from a pendrive
« Reply #11 on: October 27, 2014, 10:56:08 AM »
try rufus or disable usb controller 2.0 into bios