WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: minitube - no icons in menues, problem with phonon-backend and no icon in wbar  (Read 5333 times)

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
hi jason,

with the command "DESKTOP_SESSION=gnome minitube" everything works fine:
the buttons show icons and the volume bar works, too.

wrapped in an one-line-script it's a quick and dirty solution, that should be o.k.

thank you for your help.
« Last Edit: October 06, 2014, 03:13:11 AM by netnomad »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9659
Put "export DESKTOP_SESSION=gnome" in your ~/.ashrc and back it up and that variable will be set for all your apps, whether launched from the menu or terminal.   Makes VLC look like gtk2 as well.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Put "export DESKTOP_SESSION=gnome" in your ~/.ashrc and back it up and that variable will be set for all your apps, whether launched from the menu or terminal.   Makes VLC look like gtk2 as well.

hi jason,

works smooth and fine.
now only the menue-entry of fluxbox doesn't start properly and has an odd entry:

[exec](StopAfterThisVideo){minitube --stop-after-this}

the option --stop-after-this prevents minitube from a correct start.
would you mind to change the name to minitube and remove --stop-after-this?

thank you for your kind support and help.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9659
The the .desktop files in /usr/share/applications/ are from Debian, and I don't really want to start providing custom ones.  But for packages that are basically broken in their menu items I will consider it.  I will make one for minitube.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
The the .desktop files in /usr/share/applications/ are from Debian, and I don't really want to start providing custom ones.  But for packages that are basically broken in their menu items I will consider it.  I will make one for minitube.

hi jason,

i guess that the .desktop files in /usr/share/applications/ are o.k.,
but the menue-file /usr/local/tce.fluxbox provided for fluxbox is malformed :(

tc@box:/usr/local$ cat tce.fluxbox
[submenu] (Applications)
...
exec](StopAfterThisVideo){minitube --stop-after-this}
...
[end] TCE

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9659
Ok, will look into it tonight.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9659
Added a more small WM compatible .desktop entry for minitube, simply runs minitube.  Works with fluxbox.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
hi jason,

thanks a lot, now it works fine :)

such a great, clean program, now so easy to use :)

thank you for your help and commitment.