WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: FLWM Minimize behavior  (Read 2573 times)

Offline duane

  • WikiUser
  • *
  • Posts: 16
FLWM Minimize behavior
« on: September 17, 2014, 11:54:38 AM »
I want to raise() an application that is minimized.  I'm using Qt and calling activateWindow(); raise(); works on most operating systems.  On Tiny core it doesn't.  Is there a way to configure FLWM's behavior with respect to minimized applications as I can with other Linux distros?  Alternatively, is there a way to configure which window icon are shown so I can remove the minimize button?

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: FLWM Minimize behavior
« Reply #1 on: September 17, 2014, 12:03:06 PM »
Click on the desktop.  Then click on the minimized application.

Offline duane

  • WikiUser
  • *
  • Posts: 16
Re: FLWM Minimize behavior
« Reply #2 on: September 17, 2014, 12:11:10 PM »
Thanks.  I guess you mean right click on the desktop.  But this is a controller with a touch screen.  I don't want this behavior.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10703
Re: FLWM Minimize behavior
« Reply #3 on: September 17, 2014, 12:12:27 PM »
Try another WM? FLWM is not very configurable.
The only barriers that can stop you are the ones you create yourself.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: FLWM Minimize behavior
« Reply #4 on: September 17, 2014, 12:42:40 PM »
Right and left click do the same thing on the FLWM desktop.

Offline duane

  • WikiUser
  • *
  • Posts: 16
Re: FLWM Minimize behavior
« Reply #5 on: September 17, 2014, 12:50:07 PM »
Right and left click do the same thing on the FLWM desktop.

Thanks, I didn't realize that.  But I still don't want this behavior.  I would prefer to remove the minimize button.  I see in the source that there is a setting to hide this.  I guess it's not configurable except to rebuild the source.

Offline duane

  • WikiUser
  • *
  • Posts: 16
Re: FLWM Minimize behavior
« Reply #6 on: September 17, 2014, 12:51:14 PM »
Right and left click do the same thing on the FLWM desktop.

In the process of trying XFCE but this looks fairly large.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10703
Re: FLWM Minimize behavior
« Reply #7 on: September 18, 2014, 12:37:19 AM »
There are a lot of small WMs, fluxbox, openbox, etc. CorePlus includes many of those.
The only barriers that can stop you are the ones you create yourself.