WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Longhaul problems - how to deactivate?  (Read 7264 times)

Offline YuT666

  • WikiUser
  • *
  • Posts: 5
Longhaul problems - how to deactivate?
« on: July 28, 2014, 04:34:48 PM »
Hi,

well, i use CorePlus and this one is amazing. I nearly solved all my "beginner problems" on my own with a few little hints ... i only have one problem now ... this #?)&ยง longhaul thing!

I installed CorePlus on a Neoware client and i know, that this machines have some problems with longhaul/cpufreq ... i always get "longhaul not enable" errors or something like that at the bootup.

I found a thread here in this forum with the hint "longhaul.disable=1" ... but where i've to put this line? In the bootlocal.sh file?

Thanks in advance.

Regards

YuT666
« Last Edit: July 28, 2014, 04:37:38 PM by YuT666 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7758
Re: Longhaul problems - how to deactivate?
« Reply #1 on: July 28, 2014, 04:50:09 PM »
Hi YuT666
It goes in the config file for your bootloader.

Offline YuT666

  • WikiUser
  • *
  • Posts: 5
Re: Longhaul problems - how to deactivate?
« Reply #2 on: July 28, 2014, 05:48:58 PM »
Thanks.

I inserted the line in the extlinux.conf but now i get the error ...

Quote
Missing parameter in configuration file - Keyword: longhaul.disable=1

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Longhaul problems - how to deactivate?
« Reply #3 on: July 28, 2014, 05:51:03 PM »
It goes on the line with the other boot options.

Offline YuT666

  • WikiUser
  • *
  • Posts: 5
Re: Longhaul problems - how to deactivate?
« Reply #4 on: July 28, 2014, 05:52:20 PM »
Which boot options?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7758
Re: Longhaul problems - how to deactivate?
« Reply #5 on: July 28, 2014, 05:55:02 PM »
Hi YuT666
It goes on the line that contains  core.gz

Offline YuT666

  • WikiUser
  • *
  • Posts: 5
Re: Longhaul problems - how to deactivate?
« Reply #6 on: July 28, 2014, 06:03:31 PM »
Ok,  we'll go further ...

The error message now:

Quote
Longhaul: "1" invalid for parameter "disable"
« Last Edit: July 28, 2014, 06:05:20 PM by YuT666 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7758
Re: Longhaul problems - how to deactivate?
« Reply #7 on: July 28, 2014, 09:10:16 PM »
Hi YuT666
I just looked through the source code for longhorn. The parameter is  enable , not  disable. Try:
Code: [Select]
longhaul.enable=0and see if that works.

Offline YuT666

  • WikiUser
  • *
  • Posts: 5
Re: Longhaul problems - how to deactivate?
« Reply #8 on: July 29, 2014, 01:17:06 AM »
Strange, no chance ...

Quote
Longhaul: Option "enable" not set. Aborting

When i type ...

Quote
longhaul.enable=1

... i get no error messages at all and it works fine ...

Strange ...


Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7758
Re: Longhaul problems - how to deactivate?
« Reply #9 on: July 29, 2014, 06:41:41 AM »
Hi YuT666
Quote
Longhaul: Option "enable" not set. Aborting
That's not really an error, from the source code found here:
http://lxr.free-electrons.com/source/drivers/cpufreq/longhaul.c?v=3.8#L968
is the following code:
Code: [Select]
968         if (!enable) {
969                 printk(KERN_ERR PFX "Option \"enable\" not set. Aborting.\n");
970                 return -ENODEV;
971         }
If enable is set to zero, that message is printed and longhaul is disabled.