WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: No ethernet even w/ ethernet cable attached on TinyCore Linux  (Read 3789 times)

Offline jwmollman

  • WikiUser
  • *
  • Posts: 8
I am trying to install Tiny Core Linux as the operating system on my ASUS Eee PC 1000HA. When I booted the operating system, I wanted to test everything out to see if I could be comfortable with the switch. I have experimented with Tiny Core a bit and I know how to install files and whatnot, but here is my problem:

If I wanted to begin installing applications to see how they run on the Eee, I would have to hook up an ethernet cord, and then download the wifi drivers. When I hook up the ethernet cord, it doesn't automatically connect to the network. I went into the control panel and enabled the DHCP Client, and then I went to the appsbrowser and tried to search for a package, but it told me there was no connection, and that I should try later. I tried restarting the Eee and boot up again, this time with the ethernet cable plugged in, but I still get no connection. I tried the DHCP Client again, but noticed that everytime I close out of the window, the DHCP Client resets itself to off.

Anybody have any clue what I should do?

Offline junan

  • Jr. Member
  • **
  • Posts: 88
Re: No ethernet even w/ ethernet cable attached on TinyCore Linux
« Reply #1 on: May 28, 2009, 08:32:43 PM »
try to look information at Panel (cpanel) -> System Stats , look at column net or pci.
check if ethernet controller is available. if not available then ur ethernet still not recognize.

need more information , was 'no connection' only for appbrowser? r u already try to ping ?
open the Aterm and "sudo ping ibiblio.org". and what version your tinycorelinux ?
fun and fearless ...

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10221
Re: No ethernet even w/ ethernet cable attached on TinyCore Linux
« Reply #2 on: May 29, 2009, 01:02:26 AM »
If you tried TC 1.x, also try 2.x: there are more ethernet drivers available in 2.x base
The only barriers that can stop you are the ones you create yourself.

Offline jwmollman

  • WikiUser
  • *
  • Posts: 8
Re: No ethernet even w/ ethernet cable attached on TinyCore Linux
« Reply #3 on: May 29, 2009, 09:45:15 AM »
I'll try to burn an .iso of the 2.x version of Tiny Core, and see if that fixes my ethernet issues. I was running 1.4 at the time of this.

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 503
  • Good software needn't be big!
Re: No ethernet even w/ ethernet cable attached on TinyCore Linux
« Reply #4 on: May 29, 2009, 09:56:08 AM »
I tried TC 1.3 on an ASUS eeePC 1000 (pretty similar to the 1000HE, I think) and also found the built-in ethernet port was not supported.  I tried to build the kernel module device driver myself, but it did not work.  I plan to try the 2.0 version on the ASUS sometime.  In the meantime, I'm using another, much heavier, flavor of linux.
--
Mike L.