WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: XAMPP 1.8.3+ on 5.x/x86_64  (Read 1590 times)

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
XAMPP 1.8.3+ on 5.x/x86_64
« on: May 26, 2014, 04:57:45 AM »
Anyone tried this on pure64, and/or had luck? I can't get the xampp installer to run - it chokes at startup and returns 127.

It's a static executable, so I don't see how it could be missing a lib/dep.

Other ideas for figuring out why this doesn't work? There have to be some other tests I can run. I'm searching the apachfriends forums, too ...

FWIW, the 32bit installer seems to run/work on TC 5.x/32.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11115
Re: XAMPP 1.8.3+ on 5.x/x86_64
« Reply #1 on: May 26, 2014, 05:16:57 AM »
Does it expect things to be in /lib64, /usr/lib64, /usr/local/lib64?

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: XAMPP 1.8.3+ on 5.x/x86_64
« Reply #2 on: May 26, 2014, 05:31:03 AM »
Good question. Providing symlinks doesn't help, though. =/

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6966
Re: XAMPP 1.8.3+ on 5.x/x86_64
« Reply #3 on: May 26, 2014, 05:37:41 AM »
Hi dentonlt
If 127 is all the information it provides for an error message, you could try running  strace  on it to see what it's choking on.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10070
Re: XAMPP 1.8.3+ on 5.x/x86_64
« Reply #4 on: May 26, 2014, 05:52:05 AM »
It's a statically linked binary, but against glibc, and it tries to dynamically open the nss libs. This fails because it expects the linker in /lib64, ie it was built on a multilib system. Confirmed by strace.

sudo ln -s /lib /lib64

edit: Could also be produced via some weird method, such that it's really dynamic, not static.
« Last Edit: May 26, 2014, 05:53:58 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: XAMPP 1.8.3+ on 5.x/x86_64
« Reply #5 on: May 26, 2014, 02:29:12 PM »
Thanks curaga, Rich, juanito. I clearly must have done something wrong when I tried creating the symlinks, above. All working now!

EDIT: If you're going to go down this path, you'll also need:
bash.tcz
create a system group called 'daemon'
create a 2 system users: 'mysql' and 'daemon'
create the link suggested above (/lib64 -> /lib)

Then run the installer with sudo. As an alternative to manually creating the users, create a couple of scripts (useradd & groupadd) that pass their args to busybox. You'll need to change '-r' parameter to '-S' for the busybox utils, though.

« Last Edit: May 26, 2014, 11:20:46 PM by dentonlt »