WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Logitech Media Server  (Read 26331 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: Logitech Media Server
« Reply #15 on: March 26, 2014, 04:48:13 PM »
With VMware and a  custom kernel, those are 2 variables that may affect the outcome.  I am using neither.  And for testing purposes, the release candidate dCore.gz is the one to use though I am not sure there are any changes that would affect operation in this case.

What is your file in /opt/debextra/?  It is not supposed to be the Packages file, but a file with the entry like below

http://debian.slimdevices.com stable main

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: Logitech Media Server
« Reply #16 on: March 26, 2014, 05:02:32 PM »
What vmware are you using, give a download link and I can test with it.

Offline LDS

  • WikiUser
  • *
  • Posts: 11
Re: Logitech Media Server
« Reply #17 on: March 26, 2014, 06:05:59 PM »
Jason,
First to answer your 2 questions:
Two variables, true. But... a diff of the config the custom kernel and the TC (3.8.13 both) shows nothing suspicious to me (you can check my attachment) and I know I might be wrong... ;)
 
My /opt/debextra/repo1 is identical to yours.... for the "stable" release (LMS 7.7.3), but I also tried "testing" and "unstable" releases too (7.74, and 7.8.x nightly build respectively). At the moment (lack of more time...) I got to sce for 2: stable and unstable but only on the VM (dCore5.14.03.09 is the latest iso I found). In the release candidate there is the newer dCore.gz of 14.03.22, but no iso. I saw at git and your changes seem minimal (sceconfig). But as said, the older version (iso) gave more errors (might be because it was a live system?... I run it straight of the virtual CD: no special options at the boot screen, just return.
The sces created in that VM were copied to the thin client's tcedir and they were loaded OK. I also compared one of the releases (diff with Winmerge). I think it was the unstable release. The two files compared were same release and deps (perl), just created in the two enviroments. The diffs were "minimal" (I know I know....1 single bit...), i.e., only  in the first and last blocks of the squashfs. Anyway, as said, the realhost digested the sces built in the VM without complaining or panicking.
I think it would be more productive to see what it takes to get it running (instead of trying to find our mistakes), so please tell us your experience and we try to copycat you :).

BTW. Voyage 0.92 (debian linux) runs the LMS (stable I guess, i.e., v7.7.3) so this should be possible.

---
Then I would like to comment about your previous post with a list of additional packages (that was the reply I was writing before your post arrived :-)
---
I just tried on the real box (aka realhost from now on) by importing your list saving them to a file, one package per line:
 echo $files > extra-packages-for-LMS
 importsce -f extra-packages-for-LMS
 loadsce -d -r -b extra-packages-for-LMS
 sudo /etc/init.d/logitechmediaserver start

:-(   

I also imported on the realhost all the packages mentioned in the page (Packages) at slimdevices.debian.com in the P.S. of my previous post. loadsced them and tried again. All this in the realhost. ....to no avail. the server does not start.

It would help to see your logs. For me 'loadsce -d' did not help. In the VM running from the ISO (live) I could not generate logs (got errors).

So...I am intringued...
Does anybody else get the "cannot read /opt/debextra/Packages " errors when importing logitechmediaserver?
If you have time, could you post your /tmp/.debinstalled on a system running the server? (you mentioned seeing the webUI at port 9000 on 127.0.0.1) or your /var/log/squeezeboxserver?
I'll can try on another laptop tomorrow.

The more I see the code (git) , the more I like your work :) (...it brings me memories)

Sorry for the long post and thanks again,
LDS
« Last Edit: March 26, 2014, 06:21:43 PM by LDS »

Offline LDS

  • WikiUser
  • *
  • Posts: 11
Re: Logitech Media Server
« Reply #18 on: March 26, 2014, 06:09:57 PM »
What vmware are you using, give a download link and I can test with it.

Oracle's Virtualbox, latest for MS-Win v. 4.3.8 r92456 on Windows Vista Ultimate.
« Last Edit: March 26, 2014, 06:12:29 PM by LDS »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: Logitech Media Server
« Reply #19 on: March 26, 2014, 08:42:47 PM »
Ok, here is my /tmp/.debinstalled and /var/log/squeezeboxserver/server.log




Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: Logitech Media Server
« Reply #20 on: March 27, 2014, 01:17:01 AM »
Thanks for your help - I think you are right that I/we are missing more dependencies.

Unfortunately only some of those are available as tzc packages for the raspberry - I tried to install those that I could find (only two) but logitechmediaserver will not still not start.

I will need some time to figure out how to make the missing packages for piCore - but anyway thank you for looking into this.

Steen

Edit - As you know, the apt-get install does not work in piCore

Which pacakages are you missing in piCore?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server
« Reply #21 on: March 27, 2014, 09:54:02 AM »
The PiCore packages for those debs for those who may not know are:

libjpeg-turbo.tcz
libpng.tcz
giflib.tcz
libexif.tcz
ffmpeg2.tcz

Some fo their related factored tcz's may be needed too.

Thanks for the info - I installed these packages, however logitechmediaserver is still not running - and no logs written?

Everything seems fine - but it is not.
Code: [Select]
tc@box:~$ sudo /etc/init.d/logitechmediaserver start
Making sure that Logitech Media Server is not running first: start-stop-daemon:                                          warning: killing process 4428: No such process
Starting Logitech Media Server.


I next thought that I would try to start it manually (maybe I got this wrong but anyway, there might be important info here) 
I did:
 
Code: [Select]
tc@box:~$ sudo /usr/sbin/squeezeboxserver
And this is the result:
Code: [Select]
Can't locate Slim/bootstrap.pm in @INC (you may need to install the Slim::bootstrap module) (@INC contains: /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at /usr/sbin/squeezeboxserver line 137.
BEGIN failed--compilation aborted at /usr/sbin/squeezeboxserver line 137.


Does this give a clue?

Steen

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: Logitech Media Server
« Reply #22 on: March 27, 2014, 10:13:19 AM »
Missing Slim/bootstrap.pm :

Quote
Can't locate Slim/bootstrap.pm in @INC (you may need to install the Slim::bootstrap module)
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server
« Reply #23 on: March 28, 2014, 04:04:04 AM »
hi bmarkus

I have been reading about this error, and most often it is popping up if the path to the perl is different from what LMS (logitechmediaserver) "thinks".

There is some info here: http://forums.slimdevices.com/showthread.php?93797-Centos-can-t-locate-bootstrap-pm

I will try to follow some of the suggestions from there - but good advice is always highly welcome.

Steen

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server
« Reply #24 on: March 31, 2014, 11:05:24 AM »
OK this error is often found when Perl is the cause,  either because the version is wrong or used on a wrong distro.

It can often be solved by linking the location of the bootstrap file to a path present in the @INC.
So I found the bootstrap file in: /usr/share/perl5/Slim  and linked to something present in the @INC like:
Code: [Select]
tc@box:/mnt/mmcblk0p1$ sudo ln -sf /usr/share/perl5/Slim  /usr/local/lib/perl5/site_perl/5.18.1

Next I tried to start the LMS - and it got further:

Code: [Select]
tc@box:/mnt/mmcblk0p1$ sudo /usr/sbin/squeezeboxserver
The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name


*******

NOTE:

If you're running some unsupported Linux/Unix platform, please use the buildme.sh
script located here:

https://github.com/Logitech/slimserver-vendor/tree/public/7.8/CPAN

If 7.8 is outdated by the time you read this, Replace "7.8" with the major version
You should never need to do this if you're on Windows or Mac OSX. If the installers
don't work for you, ask for help and/or report a bug.

*******


Exiting..
tc@box:/mnt/mmcblk0p1$


So we are a bit closer. Somehow the bootstrap file is placed the wrong place - this can be fixed as described above.

But now it is complaining on some modules that fails to load (I think they are Perl stuff )

bmarkus are they included in the perl package in piCore?

Steen

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server
« Reply #25 on: March 31, 2014, 11:18:40 AM »
Here is a page where the original poster started with the same errors that I get (he was using Gentoo linux) and it was solved by doing some Perl module update (as far as I understand!!)

http://forums.gentoo.org/viewtopic-t-844720-start-0.html

But unfortunately I don't think this method will work in piCore

Steen

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server
« Reply #26 on: March 31, 2014, 12:01:56 PM »
Ok Found out how to get a log when LMS tries to start.
Sorry for the long output - I have marked some interesting areas:
Code: [Select]
tc@box:/mnt/mmcblk0p1$ /usr/sbin/squeezeboxserver --d_startup
Got @INC containing:
/usr/sbin
/usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.18.1
/usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi
/usr/local/lib/perl5/5.18.1
/usr/local/lib/perl5/site_perl
.

Extended @INC to contain:
/usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi
/usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto
/usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi
/usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto
/usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi
/usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto
/usr/sbin/CPAN/arch/armv6l-linux-thread-multi
/usr/sbin/lib
/usr/sbin/CPAN
/usr/sbin
/usr/sbin
/usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.18.1
/usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi
/usr/local/lib/perl5/5.18.1
/usr/local/lib/perl5/site_perl
.

Loaded module: [version] ok!
Loaded module: [Time::HiRes] ok!
Module [DBI] failed to load:
[color=red][b]Can't locate DBI.pm in @INC (you may need to install the DBI module)[/b][/color] (@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 8) line 1.
BEGIN failed--compilation aborted at (eval 8) line 1.

Module [EV] failed to load:
[b][color=red]Can't locate EV.pm in @INC (you may need to install the EV module) [/color][/b](@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 9) line 1.
BEGIN failed--compilation aborted at (eval 9) line 1.

Module [XML::Parser::Expat] failed to load:
[color=red][b]Can't locate XML/Parser/Expat.pm in @INC (you may need to install the XML::Parser::Expat module)[/b][/color] (@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 10) line 1.
BEGIN failed--compilation aborted at (eval 10) line 1.

Module [HTML::Parser] failed to load:
[b][color=red]Can't locate HTML/Parser.pm in @INC (you may need to install the HTML::Parser module) [/color][/b](@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 11) line 1.
BEGIN failed--compilation aborted at (eval 11) line 1.

Module [JSON::XS] failed to load:
[b][color=red]Can't locate JSON/XS.pm in @INC (you may need to install the JSON::XS module)[/color][/b] (@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 12) line 1.
BEGIN failed--compilation aborted at (eval 12) line 1.

Module [Digest::SHA1] failed to load:
[b][color=red]Can't locate Digest/SHA1.pm in @INC (you may need to install the Digest::SHA1 module)[/color][/b] (@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 13) line 1.
BEGIN failed--compilation aborted at (eval 13) line 1.

Module [YAML::XS] failed to load:
[b][color=red]Can't locate YAML/XS.pm in @INC (you may need to install the YAML::XS module)[/color][/b] (@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 14) line 1.
BEGIN failed--compilation aborted at (eval 14) line 1.

Module [Sub::Name] failed to load:
[b][color=red]Can't locate Sub/Name.pm in @INC (you may need to install the Sub::Name module) [/color][/b](@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 15) line 1.
BEGIN failed--compilation aborted at (eval 15) line 1.

The following modules are loaded after the first attempt:
        overload.pm => /usr/local/lib/perl5/5.18.1/overload.pm
        constant.pm => /usr/local/lib/perl5/5.18.1/constant.pm
        Config_git.pl => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Config_git.pl
        Config.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Config.pm
        base.pm => /usr/local/lib/perl5/5.18.1/base.pm
        DynaLoader.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/DynaLoader.pm
        Tie/Hash.pm => /usr/local/lib/perl5/5.18.1/Tie/Hash.pm
        vars.pm => /usr/local/lib/perl5/5.18.1/vars.pm
        File/Basename.pm => /usr/local/lib/perl5/5.18.1/File/Basename.pm
        File/Spec/Functions.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/File/Spec/Functions.pm
        overloading.pm => /usr/local/lib/perl5/5.18.1/overloading.pm
        warnings.pm => /usr/local/lib/perl5/5.18.1/warnings.pm
        File/Spec.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/File/Spec.pm
        Cwd.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Cwd.pm
        Getopt/Long.pm => /usr/local/lib/perl5/5.18.1/Getopt/Long.pm
        Slim/Utils/OSDetect.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OSDetect.pm
        Exporter/Heavy.pm => /usr/local/lib/perl5/5.18.1/Exporter/Heavy.pm
        strict.pm => /usr/local/lib/perl5/5.18.1/strict.pm
        Slim/Utils/OS/Unix.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OS/Unix.pm
        POSIX.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/POSIX.pm
        lib.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/lib.pm
        Config_heavy.pl => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Config_heavy.pl
        Exporter.pm => /usr/local/lib/perl5/5.18.1/Exporter.pm
        Time/HiRes.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Time/HiRes.pm
        Slim/Utils/OS.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OS.pm
        version.pm => /usr/local/lib/perl5/5.18.1/version.pm
        Slim/bootstrap.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/bootstrap.pm
        FindBin.pm => /usr/local/lib/perl5/5.18.1/FindBin.pm
        warnings/register.pm => /usr/local/lib/perl5/5.18.1/warnings/register.pm
        Slim/Utils/OS/Linux.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OS/Linux.pm
        Fcntl.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Fcntl.pm
        File/Spec/Unix.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/File/Spec/Unix.pm
        XSLoader.pm => /usr/local/lib/perl5/5.18.1/XSLoader.pm
        Symbol.pm => /usr/local/lib/perl5/5.18.1/Symbol.pm
        Carp.pm => /usr/local/lib/perl5/5.18.1/Carp.pm
        File/Path.pm => /usr/local/lib/perl5/5.18.1/File/Path.pm

The following modules failed to load on the first attempt: [DBI, EV, XML::Parser::Expat, HTML::Parser, JSON::XS, Digest::SHA1, YAML::XS, Sub::Name] - will try again.


The following modules are loaded after the second attempt:
        overload.pm => /usr/local/lib/perl5/5.18.1/overload.pm
        constant.pm => /usr/local/lib/perl5/5.18.1/constant.pm
        Config_git.pl => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Config_git.pl
        Config.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Config.pm
        base.pm => /usr/local/lib/perl5/5.18.1/base.pm
        DynaLoader.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/DynaLoader.pm
        Tie/Hash.pm => /usr/local/lib/perl5/5.18.1/Tie/Hash.pm
        vars.pm => /usr/local/lib/perl5/5.18.1/vars.pm
        File/Basename.pm => /usr/local/lib/perl5/5.18.1/File/Basename.pm
        File/Spec/Functions.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/File/Spec/Functions.pm
        overloading.pm => /usr/local/lib/perl5/5.18.1/overloading.pm
        warnings.pm => /usr/local/lib/perl5/5.18.1/warnings.pm
        File/Spec.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/File/Spec.pm
        Cwd.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Cwd.pm
        Getopt/Long.pm => /usr/local/lib/perl5/5.18.1/Getopt/Long.pm
        Slim/Utils/OSDetect.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OSDetect.pm
        Exporter/Heavy.pm => /usr/local/lib/perl5/5.18.1/Exporter/Heavy.pm
        strict.pm => /usr/local/lib/perl5/5.18.1/strict.pm
        Slim/Utils/OS/Unix.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OS/Unix.pm
        POSIX.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/POSIX.pm
        lib.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/lib.pm
        Config_heavy.pl => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Config_heavy.pl
        Exporter.pm => /usr/local/lib/perl5/5.18.1/Exporter.pm
        Time/HiRes.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Time/HiRes.pm
        Slim/Utils/OS.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OS.pm
        version.pm => /usr/local/lib/perl5/5.18.1/version.pm
        Slim/bootstrap.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/bootstrap.pm
        FindBin.pm => /usr/local/lib/perl5/5.18.1/FindBin.pm
        warnings/register.pm => /usr/local/lib/perl5/5.18.1/warnings/register.pm
        Slim/Utils/OS/Linux.pm => /usr/local/lib/perl5/site_perl/5.18.1/Slim/Utils/OS/Linux.pm
        Fcntl.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/Fcntl.pm
        File/Spec/Unix.pm => /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi/File/Spec/Unix.pm
        XSLoader.pm => /usr/local/lib/perl5/5.18.1/XSLoader.pm
        Symbol.pm => /usr/local/lib/perl5/5.18.1/Symbol.pm
        Carp.pm => /usr/local/lib/perl5/5.18.1/Carp.pm
        File/Path.pm => /usr/local/lib/perl5/5.18.1/File/Path.pm

The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name


*******

NOTE:

If you're running some unsupported Linux/Unix platform, please use the buildme.sh
script located here:

https://github.com/Logitech/slimserver-vendor/tree/public/7.8/CPAN

If 7.8 is outdated by the time you read this, Replace "7.8" with the major version
You should never need to do this if you're on Windows or Mac OSX. If the installers
don't work for you, ask for help and/or report a bug.

*******


Exiting..



This is cut from the sectio above - contains info on the problems:
Module [DBI] failed to load:
Can't locate DBI.pm in @INC (you may need to install the DBI module) (@INC contains: /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi /usr/sbin/CPAN/arch/5.18/arm-linux-gnueabi-thread-multi/auto /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18.1/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi /usr/sbin/CPAN/arch/5.18/armv6l-linux-thread-multi/auto /usr/sbin/CPAN/arch/armv6l-linux-thread-multi /usr/sbin/lib /usr/sbin/CPAN /usr/sbin /usr/sbin /usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/site_perl/5.18.1 /usr/local/lib/perl5/5.18.1/armv6l-linux-thread-multi /usr/local/lib/perl5/5.18.1 /usr/local/lib/perl5/site_perl .) at (eval 8) line 1.
BEGIN failed--compilation aborted at (eval 8) line 1.

Module [EV] failed to load:
Can't locate EV.pm in @INC (you may need to install the EV module)

Module [XML::Parser::Expat] failed to load:
Can't locate XML/Parser/Expat.pm in @INC (you may need to install the XML::Parser::Expat module)

Module [HTML::Parser] failed to load:
Can't locate HTML/Parser.pm in @INC (you may need to install the HTML::Parser module)


Module [JSON::XS] failed to load:
Can't locate JSON/XS.pm in @INC (you may need to install the JSON::XS module)

Module [Digest::SHA1] failed to load:
Can't locate Digest/SHA1.pm in @INC (you may need to install the Digest::SHA1 module)

Module [YAML::XS] failed to load:
Can't locate YAML/XS.pm in @INC (you may need to install the YAML::XS module)


Module [Sub::Name] failed to load:
Can't locate Sub/Name.pm in @INC (you may need to install the Sub::Name module)

So the marked modules seems to be missing from Perl???
Steen
« Last Edit: March 31, 2014, 12:14:06 PM by sbp »

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: Logitech Media Server
« Reply #27 on: March 31, 2014, 01:15:15 PM »
XML::Parser::Expat is already in the repo, install perl_xml_parser.tcz I will add others, but in the eman time you can install them manually. Start CPAN:
Code: [Select]
tc@box:~$ sudo perl -MCPAN -e shell
accept defaults and install modules:

Code: [Select]
cpan[1]> install JSON::XS
Be patient, installation takes some time. Modules installed in

/usr/local/lib/perl5/site_perl/5.18.1/armv6l-linux-thread-multi

You can make a tcz or add to backup.


Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline LDS

  • WikiUser
  • *
  • Posts: 11
Bingo! LMS 7.7.3 (stable) on x86 debian Core Linux sytem now working
« Reply #28 on: March 31, 2014, 11:52:19 PM »

After some hours during the weekend, I tried today and ... Bingo! :) I am listening through my squeezebox radio and see all the other players. I will let it run for a while and report. The logs are spitting useful info.

The box a very low power (less than 4 W) x86 class AMD CPU, 300 MHz w 512MB RAM.
Started with a clean base system: dCore 22.03.2014 + (custom for my buggy BIOS) kernel3.8.13. Resulting in a CLI only system. I am boot from (USB) flash memory with Syslinux.

Ok, here is my /tmp/.debinstalled and /var/log/squeezeboxserver/server.log
Thanks Jason. Your deb deps are a much larger subset of what I can afford compiling in this little box. I am glad to know what your desktop looks like :).
I  just installed dropbear + perl + LMS stable (7.7.3) + some extra deps (not sure about the minimal list) on top of the clean system described above.
I am not sure what got fixed with the extras and what with the manual tweaks, due to diffs between debian and TCL pure systems). After all, it was done during the weekend, 160 km away from the box through a ssh on my iPad to my Mac connected through dropbear to the little box running DCL :) :)

Please let me know what else you would like me to test/post.

Again you have done a great job Jason!
I am glad and thankful you took this project at once after my private mail and started this thread!
This is wonderful! a real breakthrough: debian on TCL!!! ...the sky is the limit! :)

Lazaro


Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: Logitech Media Server
« Reply #29 on: April 01, 2014, 03:34:53 AM »
Lazaro-

Glad to hear it is working!

Json