WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: git extension dated:19.03.14 (v1.9.1) error  (Read 858 times)

Offline jncl

  • WikiUser
  • *
  • Posts: 38
git extension dated:19.03.14 (v1.9.1) error
« on: March 20, 2014, 03:22:08 PM »
I'm trying to build some extensions which require source held in git repositories. I installed the latest git extension and get the following error when I try to clone a repo:
Code: [Select]
warning: templates not found /root/share/git-core/templates
fatal: Unable to find remote helper for 'https'

I successfully used the previous version of the git extension last week, so I presume something has changed in the latest version.

I also noticed, when using the previous version, that there are two missing dependencies:
Code: [Select]
curl.tcz
expat2.tcz

Please let me know if you require any further information.

Jon

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6909
    • My Community Forum
Re: git extension dated:19.03.14 (v1.9.1) error
« Reply #1 on: March 20, 2014, 11:14:59 PM »
Jon, thanks for the feedback. Rolled back to previous version, fixed missing .dep

Bela
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline jncl

  • WikiUser
  • *
  • Posts: 38
Re: git extension dated:19.03.14 (v1.9.1) error
« Reply #2 on: March 21, 2014, 04:05:08 AM »
Bela,

    Thanks for the fast response, just installed git extension and all now works.

Jon

Offline cochon

  • WikiUser
  • *
  • Posts: 15
Re: git extension dated:19.03.14 (v1.9.1) error
« Reply #3 on: September 17, 2017, 06:13:51 AM »
Hi, as a newbie round here I'm not sure how appropriate it is to resurrect such an old thread, but as I found it by searching for the problem text it seems more appropriate to update here than open a separate thread. In a nutshell the current 9.x arm6 release of git.tcz seems to have a re-occurence of this helper problem. In fact it seems to be linked against far fewer libraries generally than the previous versions of the program. See screen dump for details.

All is far from lost for me personally, SourceForge also support the git: protocol which seems to work fine, I just got blinkered into using https: for a scripted build and tripped over this. Let me know if you need any supplementary information or tests.

Cheers,
Phil.

Code: [Select]
philg@picore:/tmp$ uname -a
Linux picore 4.9.22-piCore #1 Sat Apr 15 15:30:03 UTC 2017 armv6l GNU/Linux
philg@picore:/tmp$ tce-load -i curl
curl is already installed!
philg@picore:/tmp$ tce-load -i expat2
expat2 is already installed!
philg@picore:/tmp$ git clone https://git.code.sf.net/p/avra/code dummy-folder
Cloning into 'dummy-folder'...
fatal: Unable to find remote helper for 'https'

philg@picore:/tmp$ ldd /mnt/nfs/tmp/git-9.x
        libz.so.1 => /usr/lib/libz.so.1 (0xb6f8d000)
        librt.so.1 => /lib/librt.so.1 (0xb6f76000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb6f4c000)
        libc.so.6 => /lib/libc.so.6 (0xb6e0e000)
        /lib/ld-linux-armhf.so.3 (0x7f640000)
philg@picore:/tmp$ ldd /mnt/nfs/tmp/git-8.x
        libpcre.so.1 => /usr/local/lib/libpcre.so.1 (0xb6eac000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6e89000)
        libcrypto.so.1.0.0 => /usr/local/lib/libcrypto.so.1.0.0 (0xb6d12000)
        librt.so.1 => /lib/librt.so.1 (0xb6cfb000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb6cd1000)
        libc.so.6 => /lib/libc.so.6 (0xb6b93000)
        libdl.so.2 => /lib/libdl.so.2 (0xb6b80000)
        /lib/ld-linux-armhf.so.3 (0x7f58f000)
philg@picore:/tmp$ ldd /mnt/nfs/tmp/git-7.x
        libpcre.so.1 => /usr/local/lib/libpcre.so.1 (0xb6f4f000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6f2c000)
        libcrypto.so.1.0.0 => /usr/local/lib/libcrypto.so.1.0.0 (0xb6db5000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb6d8b000)
        libc.so.6 => /lib/libc.so.6 (0xb6c4d000)
        libdl.so.2 => /lib/libdl.so.2 (0xb6c3a000)
        /lib/ld-linux-armhf.so.3 (0x7f583000)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9550
Re: git extension dated:19.03.14 (v1.9.1) error
« Reply #4 on: September 17, 2017, 08:18:31 AM »
I see that git-2.9.x will link with openssl to use https, but git 2.13.x does not and perhaps uses curl for this, but curl is not compiled against openssl?
« Last Edit: September 17, 2017, 08:23:56 AM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9550
Re: git extension dated:19.03.14 (v1.9.1) error
« Reply #5 on: September 17, 2017, 08:42:08 AM »
updated - it seems to work with your example

Offline cochon

  • WikiUser
  • *
  • Posts: 15
Re: git extension dated:19.03.14 (v1.9.1) error
« Reply #6 on: September 17, 2017, 08:51:17 AM »
Confirmed, many thanks,

Phil.