WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: ffmpeg needs jack-libs : md5sum: jack-lib.tcz.md5.txt: No such file or directory  (Read 3656 times)

Offline ian57

  • WikiUser
  • *
  • Posts: 21
Hi,

I try to install ffmpeg on picore 5.2 but i get this error :

$ tce-load -wi ffmpeg
Downloading: jack-lib.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 404 Not Found
md5sum: jack-lib.tcz.md5.txt: No such file or directory
Error on jack-lib.tcz


An idea?

Yann

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 458
looks like it is missing from the repo.

Offline ian57

  • WikiUser
  • *
  • Posts: 21
Ok, but it can be dependency problem too. Perhaps it is replaced by the jack2 package ?

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
gstreamer/ffmpeg under rebuild, please waite a bit for the new pack. In the mean time you can remove jack-lib from the .dep
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline ian57

  • WikiUser
  • *
  • Posts: 21
Ok thanks for the informations

I tried to remove the lib-jack line in .dep file, but it is re downloaded when i run tce-load -wi again.

I will try without w ;-)

Yann

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
Ok thanks for the informations

I tried to remove the lib-jack line in .dep file, but it is re downloaded when i run tce-load -wi again.

I will try without w ;-)

Yann

In the repo no change, so -iw will use the old .dep
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
Please try ffmpeg2.tcz
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline ian57

  • WikiUser
  • *
  • Posts: 21
Ok I'll try this today, and come back to give feedback. Thanks a lot

Offline ian57

  • WikiUser
  • *
  • Posts: 21
everything is ok for installation, all dependancies are here, downloaded and installed... need now how to make ffplay work  with frame buffer :-)
tc@tinytux:~$ tce-load -wi ffmpeg2
celt.tcz.dep OK
gnutls.tcz.dep OK
p11-kit.tcz.dep OK
jack2.tcz.dep OK
libavcodec2.tcz.dep OK
libtheora.tcz.dep OK
schroedinger.tcz.dep OK
twolame.tcz.dep OK
libavdevice2.tcz.dep OK
libavfilter2.tcz.dep OK
fontconfig.tcz.dep OK
harfbuzz.tcz.dep OK
cairo.tcz.dep OK
libass.tcz.dep OK
libavformat2.tcz.dep OK
libpostproc2.tcz.dep OK
libswresample2.tcz.dep OK
libswscale2.tcz.dep OK
libcaca.tcz.dep OK
Downloading: xvid.tcz


Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
everything is ok for installation, all dependancies are here, downloaded and installed... need now how to make ffplay work  with frame buffer :-)


What is the problem? ffplay is using SDL/Xorg/fbturbo out of box. Of course it is slow for movie playback in most cases, but there are slow resolution videos can be played, depending on codec.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline ian57

  • WikiUser
  • *
  • Posts: 21
In console i can't play video. :
$ ffplay test_video_cycles0001-0850.mp4
ffplay version 2.1.4 Copyright (c) 2003-2014 the FFmpeg developers
  built on Mar  4 2014 00:33:56 with gcc 4.8.3 (piCore) 20131202 (prerelease)
  configuration: --prefix=/usr/local --enable-static --enable-shared --enable-gpl --enable-nonfree --enable-version3 --enable-fontconfig --enable-gnutls --enable-libmp3lame --enable-libass --enable-libcaca --enable-libcelt --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libwavpack --enable-libxvid --enable-openssl --enable-x11grab
  libavutil      52. 48.101 / 52. 48.101
  libavcodec     55. 39.101 / 55. 39.101
  libavformat    55. 19.104 / 55. 19.104
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 90.100 /  3. 90.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Could not initialize SDL - Unable to open a console terminal
(Did you set the DISPLAY variable?)

Under X11 it's working but very slow.
With debian I use omxplayer which runs well in console mode (see https://www.youtube.com/watch?v=Ji912xM5OY0 the starting video ie played by omxplayer while the system is started)
« Last Edit: March 06, 2014, 12:46:03 AM by ian57 »

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
Yes, it is slow but not on piCore but on other distros as well. omxplayer is an exception, it is not using the Linux video stack but deals hardware directly. So if you need video playback on the Rpi, use omxplayer.

Latest SDL2 can play hw accelerated video too, but ffmpeg works with SDL only, not SDL2.

SItuation will change only when hw accelerated video driver will be available for Xorg. Hopefully it will happen, as Broadcom announced to make the currently closed driver open source:

http://www.raspberrypi.org/archives/6299
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline ian57

  • WikiUser
  • *
  • Posts: 21
ok thanks for all the informations. It explains everything. I need to compile omxplayer on picore to use it. I think there is no extension for now?


Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
omxplayer is not in the repo.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline ian57

  • WikiUser
  • *
  • Posts: 21
Yes I checked that. No problem. I will try to build it.