WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wifi not working in version 5.x  (Read 1921 times)

Offline Rensie

  • WikiUser
  • *
  • Posts: 5
wifi not working in version 5.x
« on: February 20, 2014, 01:54:03 PM »
My wireless adapter is no longer working in version 5.x. I had no trouble with 4.7.5.
Adapter is RTL8187 (rosewill rnx-g1)
When I try to do anything with the wireless I get: SIOCGIFFLAGS: no such device

dmesg:
[ 3.283403] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8187
[ 3.283436] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.283458] usb 1-1.3: Product: RTL8187_Wireless_LAN_Adapter
[ 3.283504] usb 1-1.3: Manufacturer: Manufacturer_Realtek_RTL8187_
[ 3.283522] usb 1-1.3: SerialNumber: 001AEF1B286B
.......
[ 29.979510] rtl8187: Unknown symbol eeprom_93cx6_multiread (err 0)
[ 29.979691] rtl8187: Unknown symbol eeprom_93cx6_read (err 0)

I am primarily using Steen's piCorePlayer, but the problem is also present in regular Tiny Core.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2756
Re: wifi not working in version 5.x
« Reply #1 on: February 20, 2014, 02:29:47 PM »
Hi

 This driver used to be provided in 3.0.21 kernel modules, then was in staging with 3.2.10, but has now been included with 3.8.13.  Loading " wireless-3.8.13-tinycore " extension should provide the needed rtl8187 driver.  You might also need firmware-rtlwifi extension to provide the firmware.

To summarize,  load both

wireless-3.8.13-tinycore.tcz
firmware-rtlwifi.tcz

good luck

Note: I found some confusion in the location of this device driver, however in tc-5.x is found in wireless-3.8.13-tinycore.tcz
« Last Edit: February 20, 2014, 03:25:01 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2756
Re: wifi not working in version 5.x
« Reply #2 on: February 20, 2014, 03:19:59 PM »
Also try unplug the device and reinstall to a new USB port

Also recheck the device name for example wlan0

Failing that we need more info.  Start with last 50 lines of dmesg

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6985
    • My Community Forum
Re: wifi not working in version 5.x
« Reply #3 on: February 20, 2014, 10:07:09 PM »
It is about Raspberry Pi, therefore reference to x86 release is irrelevant.

RTL8187 driver is in the wireless-3.13.3-piCore+.tcz but depends on a modul eeprom_93cx6.ko which is missing in base. I will add it in rc2.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2756
wifi not working in version 5.x
« Reply #4 on: February 20, 2014, 10:42:52 PM »
That's great,  the op did also mention the problem exists in regular core 

Glad you were able to resolve the problem
« Last Edit: February 20, 2014, 10:44:24 PM by coreplayer2 »

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6985
    • My Community Forum
Re: wifi not working in version 5.x
« Reply #5 on: February 20, 2014, 10:50:34 PM »
That's great,  the op did also mention the problem exists in    regular core 

He is referring to Steen's piCorePlayer, so regular TC means probably piCore and not x86:

Quote
I am primarily using Steen's piCorePlayer, but the problem is also present in regular Tiny Core.

Kindly ask do not mix Raspberry Pi's piCore issues with x86 where the processor architecture, kernel version and possible packaging is different, it is misleading and most likely false.
« Last Edit: February 20, 2014, 10:52:38 PM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6985
    • My Community Forum
Re: wifi not working in version 5.x
« Reply #6 on: February 21, 2014, 05:13:07 AM »
5.2rc2 posted, please try.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Rensie

  • WikiUser
  • *
  • Posts: 5
Re: wifi not working in version 5.x
« Reply #7 on: February 21, 2014, 09:48:27 AM »
It works! Thanks for taking care of it so quickly. Apologies for any confusion, I will try to be more specific in the future.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6985
    • My Community Forum
Re: wifi not working in version 5.x
« Reply #8 on: February 21, 2014, 09:51:36 AM »
It works! Thanks for taking care of it so quickly. Apologies for any confusion, I will try to be more specific in the future.

Glad to hear it works. No need to apologies, you posted it in the regight topic and for me it was clear. Confusion was not caused by you :)
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."