WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore-5.2alpha1  (Read 7249 times)

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 492
Re: piCore-5.2alpha1
« Reply #15 on: February 06, 2014, 07:03:06 PM »
Driver is not fixed in 3.12.9 either.   

Currently running the 5.2 alpha core /w 3.12.9 kernel.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: piCore-5.2alpha1
« Reply #16 on: February 07, 2014, 12:49:11 AM »
Driver updated in repo, please try

http://distro.ibiblio.org/tinycorelinux/5.x/armv6/tcz/wireless-3.12.7-piCore+.tcz.md5.txt

is a zero length file.   I downloaded manually and generated a md5sum for the file.

The tcz looks intact, but when I try to load the module, I get an invalid module format error.   That is what happens when I try to match modules that I compile with kernels that I didn't compile.

Fixed, please retry

Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 492
Re: piCore-5.2alpha1
« Reply #17 on: February 07, 2014, 04:41:50 AM »
Fixed, please retry

I'll give it a try tonight.....  What do you think the problem with the module was?

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: piCore-5.2alpha1
« Reply #18 on: February 07, 2014, 04:47:23 AM »
I'll give it a try tonight.....  What do you think the problem with the module was?

Our kernel version is 3.12.7-piCore+ but if you are compiling kernel in a clean source, it will be 3.12.7-piCore without trailing + which indicates 'dirty' or modified source which is the case of git cloned RPi kernel.

« Last Edit: February 07, 2014, 04:49:12 AM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: piCore-5.2alpha1
« Reply #19 on: February 07, 2014, 07:50:33 AM »
I'll give it a try tonight.....  What do you think the problem with the module was?

Our kernel version is 3.12.7-piCore+ but if you are compiling kernel in a clean source, it will be 3.12.7-piCore without trailing + which indicates 'dirty' or modified source which is the case of git cloned RPi kernel.

Hi bmarkus, how do you solve this naming problem?
If I define the name in the config file before compiling, is that the correct way to solve it?

Steen

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: piCore-5.2alpha1
« Reply #20 on: February 07, 2014, 08:02:06 AM »
Our kernel version is 3.12.7-piCore+ but if you are compiling kernel in a clean source, it will be 3.12.7-piCore without trailing + which indicates 'dirty' or modified source which is the case of git cloned RPi kernel.

Hi bmarkus, how do you solve this naming problem?
If I define the name in the config file before compiling, is that the correct way to solve it?

Steen

I'm using the git cloned version. There is a script in the source tree which evaluates wether + is needed or not. It my help:

http://stackoverflow.com/questions/19333918/dont-add-to-linux-kernel-version

Note exactly for this case, but can be useful:

http://tjworld.net/wiki/Linux/Kernel/Build/CustomiseVersionString
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 492
Re: piCore-5.2alpha1
« Reply #21 on: February 07, 2014, 08:27:48 AM »
I understand the '+' or no '+'.   But how would the driver that you recompiled not matched your version of the kernel?

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: piCore-5.2alpha1
« Reply #22 on: February 07, 2014, 09:00:22 AM »
By accident built a wrong tree. Late evening.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 492
Re: piCore-5.2alpha1
« Reply #23 on: February 07, 2014, 12:42:44 PM »
By accident built a wrong tree. Late evening.

Ok, I completely understand.   

Offline Paul_123

  • Sr. Member
  • ****
  • Posts: 492
Re: piCore-5.2alpha1
« Reply #24 on: February 07, 2014, 05:32:03 PM »
when running tce-update, since I had extensions that were not on the repo, there were errors,  but the  error log /tmp/upgrade_errors.lst is empty.

The wireless kernel drivers updated appropriately.


rtl8192cu Wifi driver is fine now.