WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Alwinner A20  (Read 18203 times)

Offline herschel

  • WikiUser
  • *
  • Posts: 8
Re: Alwinner A20
« Reply #45 on: December 05, 2015, 05:29:59 AM »
Hi Gents
Finally I got my Marsboard A20 to boot with dCore. Manage to import packages and when I try to do sce-load<package> I get the following error;
mount: mounting /dev/loop0 on /tmp/tcloop/<package> failed: no such device

any suggestions?

Offline Sebster

  • WikiUser
  • *
  • Posts: 17
Re: Alwinner A20
« Reply #46 on: November 09, 2016, 07:04:05 AM »
Hallo Guys!
And first a big THANKS to vdelf! You are awesome!
My Banan Pi is working with dCore.
But I have one question:

Is this version of dCore Jessie or a Wheezy?
I'm a newbie to that so sorry if this question seems dumb, but its important for me !

Thanks!

Sebster 

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Alwinner A20
« Reply #47 on: November 09, 2016, 09:36:38 AM »
I am not familiar with your hardware or that dCore port, hopefully the outputs of the version command:
Code: [Select]
version

...and uname help:
Code: [Select]
uname -a

Offline Sebster

  • WikiUser
  • *
  • Posts: 17
Re: Alwinner A20
« Reply #48 on: November 21, 2016, 04:48:19 AM »
Hello again!

Thank you for the tips!

Can someone please provide an updated uCore?
Or can someone tell me how to build one myself I would do so as well...

Basic functions (like wget etc) don't work anymore because of outdated versions of the corresponding repos/installed programs.

Thanks a lot!

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9330
Re: Alwinner A20
« Reply #49 on: November 21, 2016, 11:01:30 AM »
I plan on getting back involved in the dCore Arm ports, by the first of the year I should have some new hardware as there was an issue with my old. 

But any help I can get with the Arm ports is appreciated and I will be happy to host contributed files.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9330
Re: Alwinner A20
« Reply #50 on: February 11, 2017, 01:14:56 PM »
I have uploaded an updated uCore via a Raspberry Pi 3 I recieved as a gift which allows me to access, update, and test the image.  dCore specific files being outdated were the apparent issue.  Hopefully all works as expected now. 

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9330
Re: Alwinner A20
« Reply #51 on: August 18, 2017, 07:44:18 AM »
Updated uCore to the current dCore release.

Offline sm8ps

  • Sr. Member
  • ****
  • Posts: 290
Re: Alwinner A20
« Reply #52 on: September 19, 2017, 11:46:56 AM »
Forgive my jumping into this thread but it sounds like something I have been wondering for a long time. Is it possible to run dCore on some Raspberry Pi? The thought of running regular dCore on these models is absolutely striking. I have tried in vain with a model 2B but I must admit that I do not have any real idea about the differences in hardware among the models.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9330
Re: Alwinner A20
« Reply #53 on: September 19, 2017, 07:05:57 PM »
I use a Raspberry Pi 3 to create the uCore image for the Allwinner now as it is armv7 compatible, but the uCore image format is different than in piCore.  But since Raspberry Pi is already covered as a Tinycore port, I don't offer it here in the dCore form.  And since the Allwinner dCore is only available now for Debian Wheezy it is kind of deprecated anyway.

Offline sm8ps

  • Sr. Member
  • ****
  • Posts: 290
Re: Alwinner A20
« Reply #54 on: September 20, 2017, 01:44:57 AM »
Sorry to bother with my ignorance but what exactly is uCore? I have not found any specific information.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9330
Re: Alwinner A20
« Reply #55 on: September 20, 2017, 06:50:04 AM »