WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Another remaster problem  (Read 1193 times)

Offline srekrap

  • WikiUser
  • *
  • Posts: 20
Another remaster problem
« on: January 08, 2014, 12:55:49 PM »
Hello -

  I'm trying to mod core.gz with some trivial changes to prove I can do it so that modified LiveCD has some custom changes - I've trying to follow the process here: http://forum.tinycorelinux.net/index.php?topic=157.0 (zcat...cpio|gzip, etc), and I've tried various other things in other posts/web-pages.

  However, when booting I get
  " Loading /boot/vmlinuz....
    Could not find ramdisk image: /boot/<my file>.gz"

    though the file is obviously there, has stuff, and the new/old isolinux.cfg files vary only in the name of the initrd file.

  Here's how my script is generating my initrd file:

  (let's say RAMDISK_DIR=/tmp/myinitrd, and DIST_TARGET_DIR=/mnt/sr0)

Quote
   mkdir -p ${RAMDISK_DIR}
   cd ${RAMDISK_DIR}
   zcat ${DIST_TARGET_DIR}/root/boot/core.gz | cpio -H newc -i -d

   # Modify boot prompt
   echo "    SOME MESSAGE OF MINE" >> etc/motd

   # Copy scripts to usr/local dir
   cp -Rf ${EVS_DIR}/target/development/scripts/* usr/local

   # Make new ramdisk file
   find | cpio -o -H newc | gzip -2 > ../${RAMDISK_BASENAME}.gz

  Then I make an iso that seems to be fine otherwise - I get the isolinux menu with 4 items, etc.

  Seems pretty easy - Thanks for any help
    Cheers
       Sean

UPDATE: I was burning the CD using CDBurnerXP on Windows, and for some reason the CD wasn't completely kosher (Though Windows could read it fine) - on RH writing iso to CD using wodim directly worked fine. I added some troubleshooting text to http://wiki.tinycorelinux.net/wiki:remastering.
« Last Edit: January 09, 2014, 07:21:40 AM by srekrap »