WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Tiny Core v5.1  (Read 19237 times)

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: Tiny Core v5.1
« Reply #15 on: December 26, 2013, 06:07:53 AM »
In core 5.x the flag copy2fs.flg still works? Yesterday I wanted to try the new core but once the distro was started I could not unmount the sd memory.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9074
Re: Tiny Core v5.1
« Reply #16 on: December 26, 2013, 06:23:24 AM »
it worked the last time I tried it, which I believe was with tc-5.1

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: Tiny Core v5.1
« Reply #17 on: December 28, 2013, 02:09:14 AM »
You're right, it works, I must have put the flag in a wrong place.
Today I tried to install Xorg and flwm and the touchpad is not recognized (I can not move the cursor but only press the buttons).


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9074
Re: Tiny Core v5.1
« Reply #18 on: December 28, 2013, 03:07:18 AM »
if you have the xf86-input-evdev extension loaded it should work, but you could also try the xf86-input-synaptics extension

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: Tiny Core v5.1
« Reply #19 on: December 28, 2013, 06:39:21 AM »
with xf86-input-synaptics touchpad works fine and also touchscreen works out of the box! (but unfortunately it was ruined over time  >:( )

I have two other problems:
1. there is no longer standard terminal included (like xterm or aterm?)
2. I can not install applications from the GUI (in the status bar I get a "Failed packname.tcz") but only by tce tce-load or tce-ab
« Last Edit: December 28, 2013, 07:19:06 AM by vinnie »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9074
Re: Tiny Core v5.1
« Reply #20 on: December 28, 2013, 07:04:57 AM »
It would be good to read the tc-5.x release notes - aterm is a separate extension and at least one terminal extension needs to be loaded for the fltk gui applets to work.
« Last Edit: December 28, 2013, 07:32:27 AM by Juanito »

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: Tiny Core v5.1
« Reply #21 on: December 28, 2013, 08:07:35 AM »
Ok, thanks. you should write in the info file of xprogs.tcz or try to generate an pertinent error.
which terminals you can choose from? apps with urxvt not seem to work.

I noticed that all my packages are missing (except geany), what criteria did you choose to reintegrate or not  the packages?

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4199
Re: Tiny Core v5.1
« Reply #22 on: December 28, 2013, 08:23:42 AM »
Some have to be recompiled, some need to be tested.

http://forum.tinycorelinux.net/index.php/topic,15906.0.html

Offline beerstein

  • Hero Member
  • *****
  • Posts: 519
Re: Tiny Core v5.1
« Reply #23 on: December 28, 2013, 08:26:52 AM »
I have the same problem with my piCore 5.1 rc3. It works great so far and seems to be stable also. After the GUI install on the CLI according to the REDME.TXT file and reboot the GUI piCore boots OK. There is no aterm installed and no aterm icon in wbar. So I tried to install aterm from the GUI apps tool. After a while I am getting the error:
"2. I can not install applications from the GUI (in the status bar I get a "Failed packname.tcz") but only by tce tce-load or tce-ab"
This happens for other extensions too.
So I went back to the CLI and see - here I was able to install aterm and some other extensions such as pcmanfm and openssh.
After returning to the GUI things have changed to the better - I now was able to install extensions from the GUI - strange???
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: Tiny Core v5.1
« Reply #24 on: December 28, 2013, 08:50:50 AM »
if you have installed aterm,  apps can work (but I would like to know with such other terminals it work? if it works only with aterm, it would be right to add it as a xprogs dependency)

thanks gerald, i see
« Last Edit: December 28, 2013, 08:58:43 AM by vinnie »

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6853
    • My Community Forum
Re: Tiny Core v5.1
« Reply #25 on: December 28, 2013, 08:55:46 AM »
if you have installed aterm,  apps can work (but I would like to know with such other terminals it work? if it works only with aterm, it would be right to add it as a xprogs dependency)

lxterminal
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6853
    • My Community Forum
Re: Tiny Core v5.1
« Reply #26 on: December 28, 2013, 08:56:29 AM »
I have the same problem with my piCore 5.1 rc3. It works great so far and seems to be stable also. After the GUI install on the CLI according to the REDME.TXT file and reboot the GUI piCore boots OK. There is no aterm installed and no aterm icon in wbar. So I tried to install aterm from the GUI apps tool. After a while I am getting the error:
"2. I can not install applications from the GUI (in the status bar I get a "Failed packname.tcz") but only by tce tce-load or tce-ab"
This happens for other extensions too.
So I went back to the CLI and see - here I was able to install aterm and some other extensions such as pcmanfm and openssh.
After returning to the GUI things have changed to the better - I now was able to install extensions from the GUI - strange???

Will check piCore
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9074
Re: Tiny Core v5.1
« Reply #27 on: December 28, 2013, 09:00:59 AM »
The idea is that any terminal program could work as long as it provides the appropriate symlink. Lxterminal looks like it would work, but urxvt looks like it needs adjusting

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6853
    • My Community Forum
Re: Tiny Core v5.1
« Reply #28 on: December 31, 2013, 04:47:28 PM »
I have the same problem with my piCore 5.1 rc3. It works great so far and seems to be stable also. After the GUI install on the CLI according to the REDME.TXT file and reboot the GUI piCore boots OK. There is no aterm installed and no aterm icon in wbar. So I tried to install aterm from the GUI apps tool. After a while I am getting the error:
"2. I can not install applications from the GUI (in the status bar I get a "Failed packname.tcz") but only by tce tce-load or tce-ab"
This happens for other extensions too.
So I went back to the CLI and see - here I was able to install aterm and some other extensions such as pcmanfm and openssh.
After returning to the GUI things have changed to the better - I now was able to install extensions from the GUI - strange???

Can't reproduce on piCore 5.1.rc3 Running in console

Code: [Select]
tce-load -iw TC.tcz
startx

loads all necessary components correctly and in GUI aterm works as expected.
« Last Edit: December 31, 2013, 04:49:34 PM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."