WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: gthumb and eog - similar problems with GLib-GIO-ERROR  (Read 1652 times)

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
gthumb and eog - similar problems with GLib-GIO-ERROR
« on: November 03, 2013, 05:46:11 AM »
hi friends,

importing gthumb and eog result in a comparable error:

tc@box:~$ loadsce gthumb
/etc/sysconfig/tcedir/sce/gthumb.sce: OK
tc@box:~$ nohup: redirecting stderr to stdout
tc@box:~$ gthumb
(gthumb:7200): GLib-GIO-ERROR **: Settings schema 'org.gnome.gthumb.browser' is not installed
Trace/breakpoint trap

tc@box:~$ loadsce eog
/etc/sysconfig/tcedir/sce/eog.sce: OK
tc@box:~$ nohup: redirecting stderr to stdout
tc@box:~$ eog
** (eog:7436): WARNING **: Error spawning command line `dbus-launch --autolaunch=a5196eb3741ef79eb5f7cd2e52765259 --binary-syntax --close-stderr': Failed to execute child process "dbus-launch" (No such file or directory)
(eog:7436): GLib-GIO-ERROR **: Settings schema 'org.gnome.eog.plugins' is not installed
Trace/breakpoint trap

do you have any ideas to solve this issue?

thank you for all your contributions, ideas and help.
« Last Edit: November 03, 2013, 05:48:25 AM by netnomad »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9643
Re: gthumb and eog - similar problems with GLib-GIO-ERROR
« Reply #1 on: November 03, 2013, 07:23:01 AM »
eog started for me, but gthumb issued the error and did not start

Please re-import, or try the command:

/usr/local/postinst/libglib2.0-0 trigger

I put it in the startup scripts of those packages.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: gthumb and eog - similar problems with GLib-GIO-ERROR
« Reply #2 on: November 03, 2013, 08:59:32 AM »
hi jason w,

great work,
gthumb works fine for me.

thank you for your fast solution.