WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: cups not starting  (Read 6467 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #15 on: October 16, 2013, 07:17:40 AM »
Ok, since the menu came up during import and another deb was chosen for either the main package or it's dependencies I can't know if you have version compatible versions of packages chosen.  I used to see that menu come up when my Debian packages list was not current.  The menu allows us to be able to get a working package when there is an issue fetching the proper one, but it can also be another variable when testing.

What mirror are you using?  I have a hunch your mirror is not in sync with repo.tinycorelinux.net.


Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: cups not starting
« Reply #16 on: October 16, 2013, 02:15:01 PM »
hi jason w,

i didn't change any mirror-settings and actually i'm not aware which mirror i used.
would you give me a hint which mirror you successfully used and how i can check whether my mirror-settings are o.k.?

thank you for your help.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #17 on: October 16, 2013, 05:21:52 PM »
Hi, I use the main http://repo.tinycorelinux.net/.  When re-importing a package that has just been fixed it would be advisable to use that mirror as it is the main server where the files are adjusted in real time.

"cat /opt/tcemirror" will let you know what mirror you are using.

And of course, make sure the sce package you are testing is loaded before any others if you are loading multiple sce's during boot and are not going from a file list.

Thanks.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: cups not starting
« Reply #18 on: October 16, 2013, 11:42:43 PM »
hi jason,

this time everything worked smooth and fine without any questions about versions or platforms.
finally i could start a working cups-environment on my localhost.
soon i will test my printers and give a feedback.

great work!!! i really appreciate this dCore-approach, thank you.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: cups not starting
« Reply #19 on: October 17, 2013, 07:56:35 AM »
hi jason,

cups offers only few printer-drivers and ppds,
so i installed cups-driver-gutenprint, too.

now cups starts, but i cannot print, cause the dbus is not started successfully.
i get an error message that dbus cannot start, cause the user "messagebus" does not exist.
there is only the group "messagebus".
after i added the user messagebus, dbus asked for a working-directory /etc/dbus-1/system.d.
with this dir dbus starts without errors.
afterwards i restarted cups successfully.
now when i print to cups my cups-printer answers with the error message "no profiles specified in PPD".

how could we solve this?
« Last Edit: October 17, 2013, 08:21:41 AM by netnomad »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #20 on: October 17, 2013, 12:36:16 PM »
Ok, I will attempt to fix this tonight with the startup script.

Also, install ghostscript-cups, that may fix the PPD issue.  If so, i will add it to the cups dep list.

libgs9-common may also be needed.
« Last Edit: October 17, 2013, 12:38:03 PM by Jason W »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #21 on: October 17, 2013, 05:41:13 PM »
On my system, dbus adds the user messagebus and starts without error, and that system.d directory exists already.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: cups not starting
« Reply #22 on: October 22, 2013, 10:55:03 PM »
hi jason w,

finally i can successfully print with small adjustments!

first i need to start or restart dbus and cups,
so i added following lines to /opt/bootsync.sh:

sudo /etc/init.d/dbus restart &
sleep 3
sudo /etc/init.d/cups restart &

and
the directory /etc/dbus-1/system.d is still missing

so i added following line to /opt/.filetool.lst
etc/dbus-1/system.d

perhaps you see there a way to improve this settings ;-) !

thank you for your commitment and help.
« Last Edit: October 22, 2013, 10:56:58 PM by netnomad »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #23 on: October 23, 2013, 04:37:56 AM »
Ok, I adjusted the startup script to create that directory, I had done that earlier but there was a typo.

Is there a dbus error when doing "/etc/init.d/cups start", is that making the need to restart dbus?  Or can it work by simply starting dbus?  Cups starts here with no error and no need to start dbus.

Re-import and try again if you would, using the mirror repo.tinycorelinux.net.  Thanks. 

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: cups not starting
« Reply #24 on: October 23, 2013, 10:48:22 PM »
Ok, I adjusted the startup script to create that directory, I had done that earlier but there was a typo.
now i get /etc/dbus-1/system.d, so that works now fine for me :)

Quote
Is there a dbus error when doing "/etc/init.d/cups start", is that making the need to restart dbus?  Or can it work by simply starting dbus?  Cups starts here with no error and no need to start dbus.
i do not notice any error message.
are there any log files i could examine?
both has to be restarted, dbus and cups, then everything works fine.

thank you for your help.
« Last Edit: October 23, 2013, 11:20:02 PM by netnomad »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #25 on: October 24, 2013, 07:47:31 AM »
Ok, I read other places that a running dbus has to be restarted before cups can be started, it is normal and not a dCore specific issue.  However, I am not really wanting to script in a restarting of dbus into cups' init.d script since I read of how restarting dbus during a running X session can cause issues.  Maybe that is why dbus is not restarted with cups is in Debian, I will try on Debian and see how it is handled there and maybe there is a solution to prevent having to restart dbus.

But I can prevent cups from being started when the package is being loaded if that is what is happening, that way cups would not have to be restarted and the user can have control when they want to start it up. 

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: cups not starting
« Reply #26 on: October 24, 2013, 08:43:22 AM »
Take a look at the tc x86 dbus script - I recall there's a reload (or similar) function that doesn't cause the same issues as restart

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #27 on: October 24, 2013, 09:17:40 AM »
Ok, I will.  Thanks.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #28 on: October 24, 2013, 05:47:20 PM »
Thanks Juanito, "force-reload" or "reload" is an option in the Debian one that will reload the config.  I am having cups do that on install.

I have made changes to dbus.deb2sce install start script as wells as to the cups.deb2sce one.  Netnomad, please re-importsce and test.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: cups not starting
« Reply #29 on: October 24, 2013, 08:03:28 PM »
netnomad - hold off for right now, I am still verifying the changes to dbus.  Thanks.