WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore 5.0.alpha3  (Read 17262 times)

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: piCore 5.0.alpha3
« Reply #30 on: September 29, 2013, 11:11:48 AM »
hi bmarkus

I hope you are not tired of all my posts.

I have now come to the ralink wifi issue.

Just as in the 4.7.7 piCore I need to do this in version 5:
sudo ifconfig wlan0 down
and
sudo ifconfig wlan0 up

Otherwise it is not working.
So it seems like the wifi is "up" before the firmware is loaded



2.
In addition I can't connect. It is able to scan my network, but I always get the following result with the ralink wifi adaptor in version 5:

This is from piCore version 5
Code: [Select]
Select Wifi Network

    ESSID                               Enc   Qual    Channel Type
 1. Steens 2.4GHz                         on    49       7     WPA
 2. Djurs5                               on    17       3     WPA

Enter selection ( 1 - 2 ) or (q)uit: 1
Enter password for Steens 2.4GHz (8 to 63 characters): "MY Secret code"
Sending credentials to requested access point Steens 2.4GHz...................
udhcpc (v1.21.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
Failed to connect.


This is from version 4.7.7
Code: [Select]
Select Wifi Network

    ESSID                         Enc   Qual    Channel Type
 1.                                on    41       1     WPA
 2. Steens 2.4GHz                  on    29       7     WPA

Enter selection ( 1 - 2 ) or (q)uit: 2
Enter password for Steens 2.4GHz (8 to 63 characters): My secret code
Sending credentials to requested access point Steens 2.4GHz..
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending select for 192.168.1.12...
Lease of 192.168.1.12 obtained, lease time 604800
deleting routers
adding dns 193.162.153.164
adding dns 194.239.134.83
tc@box:~$

Steen

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: piCore 5.0.alpha3
« Reply #31 on: September 29, 2013, 11:21:27 AM »
Steen,

not tired, at least not because of you. I'm happy if others are testing and using it. I see I must buy a WiFi adapter :)

Can you disable WPA and run AP open to see is it a wpasupplicant issue or not?

Bela
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: piCore 5.0.alpha3
« Reply #32 on: September 29, 2013, 11:59:15 AM »
Steen

these WIFI adapters offered here by the official RPI distributor:

http://malnapc.hu/yis/periferiak/usb-s-wifi-eszkoz

Unfortunately chipset is not mentioned. Is your one of them?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: piCore 5.0.alpha3
« Reply #33 on: September 29, 2013, 12:10:03 PM »
Just as in the 4.7.7 piCore I need to do this in version 5:
sudo ifconfig wlan0 down
and
sudo ifconfig wlan0 up

Otherwise it is not working.
So it seems like the wifi is "up" before the firmware is loaded

Are you referring to loading extensions "onboot"?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: piCore 5.0.alpha3
« Reply #34 on: September 29, 2013, 01:37:18 PM »
wpa_supplicant updated to 2.0
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: piCore 5.0.alpha3
« Reply #35 on: September 30, 2013, 09:22:54 AM »
Hi bmarkus

Just update wpa-supplicant to version 2 - however it did not improve.

However, if I removed protection from my router it can connect fine.

This is piCore v 5 alpha 3 with updated wpa-suppicant, but without protection on the router:
Code: [Select]
Select Wifi Network

    ESSID                         Enc   Qual    Channel Type
 1. Djurs5                         on    25       3
 2. Steens 2.4GHz                 off    21       9

Enter selection ( 1 - 2 ) or (q)uit: 2
udhcpc (v1.21.1) started
Sending discover...
Sending select for 192.168.1.12...
Lease of 192.168.1.12 obtained, lease time 604800
deleting routers
adding dns 193.162.153.164
adding dns 194.239.134.83

So what to try next?

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: piCore 5.0.alpha3
« Reply #36 on: September 30, 2013, 09:26:54 AM »
Steen

these WIFI adapters offered here by the official RPI distributor:

http://malnapc.hu/yis/periferiak/usb-s-wifi-eszkoz

Unfortunately chipset is not mentioned. Is your one of them?

Sorry, no they look different from mine.

I bought this one: http://www.ebay.com/itm/271180617205?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Steen

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: piCore 5.0.alpha3
« Reply #37 on: September 30, 2013, 09:28:08 AM »
As wpa_supplican 1.0 was working in 4.7.7 didn't expect 2.0 update as a fix for 5.0, just a regular update.

I must find a WiFi dongle to test :(
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: piCore 5.0.alpha3
« Reply #38 on: September 30, 2013, 09:30:01 AM »
Steen

these WIFI adapters offered here by the official RPI distributor:

http://malnapc.hu/yis/periferiak/usb-s-wifi-eszkoz

Unfortunately chipset is not mentioned. Is your one of them?

Sorry, no they look different from mine.

I bought this one: http://www.ebay.com/itm/271180617205?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Steen

Good price, big antenna. Looks impressive :)
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 178
Re: piCore 5.0.alpha3
« Reply #39 on: September 30, 2013, 12:51:24 PM »
Steen

these WIFI adapters offered here by the official RPI distributor:

http://malnapc.hu/yis/periferiak/usb-s-wifi-eszkoz

Unfortunately chipset is not mentioned. Is your one of them?

Sorry, no they look different from mine.

I bought this one: http://www.ebay.com/itm/271180617205?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Steen

Good price, big antenna. Looks impressive :)

The first one you posted (this one) looks a lot like mine (this one).
It's got the RT5370 chipset, and I have it working with piCore 5.0.alpha2.

When I find some time, I will re-install my Raspberry with alpha3 and test it again.

« Last Edit: September 30, 2013, 12:53:11 PM by Gerrelt »
my Raspberry Pi page: http://raspberry.gerrelt.nl

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: piCore 5.0.alpha3
« Reply #40 on: September 30, 2013, 01:08:25 PM »
Hi gerrelt.

What kind of protection do you use in your network? I couldn't get it to work using WPA-personnel, whereas it connected fine without any protection of the router.
Probably I should test wap as well.

Steen

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 178
Re: piCore 5.0.alpha3
« Reply #41 on: September 30, 2013, 02:53:41 PM »
I am using WPA, with my own wpa_supplicant.conf file.

The file looks like this:

Code: [Select]
# reading passphrase from stdin
network={
proto=RSN
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
ssid="MyWifiName"
psk="a_very_secret_password"
}

Then I use this script to connect:
Code: [Select]
# ------------------begin script-----------------
echo ----------------------------------- >> /tmp/_wifi.log
date >> /tmp/_wifi.log
echo ----------------------------------- >> /tmp/_wifi.log
ifconfig wlan0 up >> /tmp/_wifi.log
for i in $(seq 1 5)
do
  sleep 1
  echo try $i >> /tmp/_wifi.log
  iwlist wlan0 scanning >/dev/null
  if [[ $? -eq 0 ]]
  then
    echo succeeded >> /tmp/_wifi.log
    break
  fi
  echo unsuccesfull >> /tmp/_wifi.log
done
wpa_supplicant -B -Dwext -i wlan0 -c /opt/wpa_supplicant.conf >> /tmp/_wifi.log
/sbin/udhcpc -b -i wlan0 -x hostname:cherry >> /tmp/_wifi.log
# ------------------eind script-----------------

I wanted to use the wifi.tcz script, but that does not use the -b option in the udhcpc command. The -b option waits until it obtains a lease, and does not quit. My modem is slow or something, because without the -b it doesn't always work.

my Raspberry Pi page: http://raspberry.gerrelt.nl

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore 5.0.alpha3
« Reply #42 on: October 01, 2013, 05:23:53 AM »
Hi!

No X-version of this new build?

Kind greetings,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: piCore 5.0.alpha3
« Reply #43 on: October 01, 2013, 05:33:15 AM »
Hi!

No X-version of this new build?

Kind greetings,
meo

Code: [Select]
tce-load -iw TC
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 178
Re: piCore 5.0.alpha3
« Reply #44 on: October 01, 2013, 10:34:13 AM »
Hi Bmarkus,

  This evening I installed Alpha 3, and everything is working great!

Wifi is working with the ralink RT5370 WiFi adapter.
Beside the normal WiFi installation/settings I normally do, I had to install the extra ralink drivers like this:

Code: [Select]
tce-load -wi firmware-ralinkwifi.tcz
And then, after a reboot, it worked!
The modprobes that were needed in alpha 2 are not needed anymore.

Thanks!  :)

Greetings,
    Gerrelt.
my Raspberry Pi page: http://raspberry.gerrelt.nl