WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: 5.x users of firefox --read when you get a chance pls  (Read 6320 times)

gordonselfish

  • Guest
5.x users of firefox --read when you get a chance pls
« on: September 17, 2013, 06:13:11 PM »
Hi

I have firefox-get in the 5.x repo if interested. It is designed to reduce users posting in forums about the latest firefox.
----while the download structure for firefox remains unchanged. To download an old firefox.tcz is about 25 megs and to download firefox-get and then the latest firefox will still be about 29 megs. But here are the main differences

If you are one user,
###########
 you can keep firefox in your home folder and run it from your home folder.
-- you can have it check for updates and update......no more TCZs

Of course, you could have done this in the past as well, without my script
but my script hopefully gives you a .local/bin/wolf command
so you can also click on run and type "wolf" without the quotes to start firefox

If you prefer TCZs or have multiple users short of space etc
#################################
the script will build a tcz called wolf-----if you tell it to
----its called wolf so that /usr/local/bin/wolf does not interfere with those who still use /usr/local/bin/firefox
so you can have 2 loaded at one and running at once.....why I don't know!

When you become aware there is an update for going thru help----check for updates
---or changing your settings as per the info file
THEN you re-load firefox-get and re-run to download the newer version

To be safe, copy existing wolf* out of tce/optional until you confirm new wolf works ok.

Of course, I can not predict the future, so the script only works why the download link style is the same as 23.0.1
If that changes post a bug report and someone should be able to tweak it

good luck

click on image to zoom if interested

« Last Edit: September 17, 2013, 06:28:11 PM by gordonselfish »

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #1 on: September 17, 2013, 06:25:07 PM »
LOL

the correct version to input when prompted is 24.0, its just updated and I have only just checked

If you did not read this when you downloaded 23.0.1, then re-run the script and type in 24.0
full reboot will give you a new wolf
« Last Edit: September 17, 2013, 07:28:15 PM by gordonselfish »

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #2 on: September 17, 2013, 06:26:32 PM »
If I forget to post, others feel free to post when the latest version is out

That way newbies know what to type in at the prompt

cheers

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: 5.x users of firefox --read when you get a chance pls
« Reply #3 on: September 17, 2013, 06:54:29 PM »
Hey gordonselfish
Sounds good to be able to get latest firefox easily, but..

Quote
the script will build a tcz called wolf-----if you tell it to
----its called wolf so that /usr/local/bin/wolf does not interfere with those who still use /usr/local/bin/firefox

Does that mean that Firefox downloaded via this script will always be called or be placed in 'wolf' or can we add wolf as parameter to firefox-get?

I do not want Firefox to be in wolf because Flash, Java and personal settings .tcz might not find firefox folders for symlinks. Neither do I need two installations of firefox.

Thanks

Download a copy and keep it handy: Core book ;)

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #4 on: September 17, 2013, 07:21:52 PM »
Quote
Does that mean that Firefox downloaded via this script will always be called or be placed in 'wolf'

1) If you choose local
you get a home folder of firefox
you get a .local/bin/wolf

2) If you choose tcz
you will always get a wolf.tcz.....which is a private extension but you can edit the script or the TCZ.
Quote
or can we add wolf as parameter to firefox-get?
I suggest you run the script, there is no option to input the word "wolf"

BUT
####

I don't use getflash.

firefox-get is a MIT license so download and load and copy into /home/yourname/.local/bin the file called /usr/local/bin/firefox-get

then edit it to whatever you like.

If getflash is looking for firefox pathway, you might need to check what it is looking for.

Roughly speaking, if you keep firefox folder in your home folder, then just download flash and copy the um flash-file into its correct folder.

I am a bit busy with other things at the moment but feel free to post any issues you have after trying it.

2) If you try it, download input version is
24.0

good luck
« Last Edit: September 17, 2013, 07:25:27 PM by gordonselfish »

Offline LinuxUser01

  • Full Member
  • ***
  • Posts: 111
Re: 5.x users of firefox --read when you get a chance pls
« Reply #5 on: September 18, 2013, 04:50:22 PM »
I have downloaded firefox-get as DOWNLOAD ONLY, and it has placed it into tce/optional as firefox-get.tcz. This is my first time trying to run a script on TinyCore and i have tried getting into that folder and running it from the terminal with no success. If there is anybody that has executed this script can you please assist me, thanks.

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #6 on: September 18, 2013, 05:28:31 PM »
Hi welcome to download only method of APPS

now once it is downloaded, it is not loaded

so load it with and last line to execute it (as non-root please)
Code: [Select]
tce-load -i firefox-get
firefox-get

good luck

and yes you have chosen the correct option as this is an infrequent script to run so does not belong in your onboot.lst

Offline LinuxUser01

  • Full Member
  • ***
  • Posts: 111
Re: 5.x users of firefox --read when you get a chance pls
« Reply #7 on: September 18, 2013, 06:17:26 PM »
The script ran fine, i chose 24.0 and local. I edited the preferences in Firefox and saved then rebooted. Came back from the reboot and the preferences are still saved. So thats a good thing. Looks like i have to open terminal and type wolf for Firefox to load instead of just the icon from the wbar. That shouldn't be an issue, i'm sure there is a way around it to make an icon in wbar and load it somehow. You did a great job with the script. Thanks.

Another thing, i haven't got around to using flash yet since getflash11 isn't in the Apps Browser for TC 5.0. Not sure how users have got Firefox and flash working in TC 5.0. Not even sure if its going to work since the loading of firefox is totally different from the regular loading with this script.
« Last Edit: September 18, 2013, 06:23:37 PM by LinuxUser01 »

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #8 on: September 18, 2013, 06:35:15 PM »
Hi
no need to open a terminal
click on run wbar icon
type wolf and press enter

2) no need to use getflash*
download flash from adobe, unpack it for the so file and copy (not symlink) the entire file into the plugins folder

I have not tested this, as I know the adobe plugin is very old

good luck

3)  When I can get a LXDE (eyes blinking must be smoke in the room)
then I can see about a local wbar desktop entry
but not now as I  am busy with other things sorry
« Last Edit: September 18, 2013, 06:55:15 PM by gordonselfish »

Offline LinuxUser01

  • Full Member
  • ***
  • Posts: 111
Re: 5.x users of firefox --read when you get a chance pls
« Reply #9 on: September 18, 2013, 07:02:09 PM »
I'm guessing .tar.gz for Adobe Flash 11.2.202.310 is the one that i download instead of the other options. I'm looking for the plugin folder through /home/tc/ section and can't seem to find it. The file name that its going to download is install_flash_player_11_linux.i386.tar.gz.

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #10 on: September 18, 2013, 08:18:05 PM »
I will edit this, I better have a look I suppose

Offline LinuxUser01

  • Full Member
  • ***
  • Posts: 111
Re: 5.x users of firefox --read when you get a chance pls
« Reply #11 on: September 18, 2013, 08:36:41 PM »
That XFE comes with its own zip/unzip feature. It would of been helpful if it was accessible in the TC5.0 Apps Browser since i will need to delete a file and unzip another. I think that firefox-24.0/tar.bz2 file is the reason why rebooting is taking so long. Does this TC come with its own zip/unzip commands through the terminal by any chance? How about deleting a file through the terminal? Thanks in advance.

gordonselfish

  • Guest
Re: 5.x users of firefox --read when you get a chance pls
« Reply #12 on: September 18, 2013, 09:03:49 PM »
LinuxUser01
Quote
I think that firefox-24.0/tar.bz2 file is the reason why rebooting is taking so long.
Did you read this part of the script running and did you understand persistence wiki?
Quote
For local choice,  be aware that you have a large bz2 file
   in your home folder and a large sub-folder. You may like to
   delete the bz2 file if script works.

   Suggest you read the wiki on persistence and what effect will
   occur to have large files in your backup.

   .cache is already excluded from your backup

2) If in doubt just delete the bz2 file, or move it onto an usb stick etc

3) flash will not work on 5.x.....I just did a few simple things
/home/tc/.mozilla  create plugins folder
moved libflashplayer.so there and made it executable

restarted wolf which now ......and only now ....complains missing XPCOM
and link says that is a part of xulrunner

and so we have google
https://bbs.archlinux.org/viewtopic.php?id=65846

4) xfe is offtopic but you will see a recent post of someone submitting it

5) xulrunner is clearly ontopic....for adobe flash users and another post shows someone is building that as well

VERDICT
You will not be able to run flash until XPCOM is working in 5.x

As I said I don't use flash....there are alternatives to it depending on what you are doing.

Quote
Does this TC come with its own zip/unzip
I suggest you download and consider having onboot app = xarchiver
or search APPS for zip and you will see zip-unzip

good luck
« Last Edit: September 18, 2013, 09:06:35 PM by gordonselfish »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: 5.x users of firefox --read when you get a chance pls
« Reply #13 on: September 18, 2013, 09:25:02 PM »
Flash actually does work with default Firefox extension on 5.x.

flash11.tcz includes
libflashplayer.so (linked to "/usr/local/firefox/plugins/" and "/usr/local/firefox-official/plugins/" )
libflashsupport.so (linked to "/usr/lib/")
Download a copy and keep it handy: Core book ;)

Offline LinuxUser01

  • Full Member
  • ***
  • Posts: 111
Re: 5.x users of firefox --read when you get a chance pls
« Reply #14 on: September 18, 2013, 09:31:59 PM »
Yes, that is how i found out about firefox-24.0/tar.bz2 that might be creating the issue with the backup taking too long. Yes, i read on the XFE thread on how it will hopefully be submitted soon. Not familiar with xulrunner and XPCOM. I just use flash for simple things like youtube. Thank you for all of your replies. I'll probably just keep on using TC 4.7.7 until all of this gets squared off.