WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Extensions from 4.x repo verified ok with tc-5  (Read 81311 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #105 on: October 07, 2013, 03:09:49 AM »
inflator and google-talkplugin  copied over

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #106 on: October 07, 2013, 04:09:07 AM »
links updated/posted, gpm copied over

Offline Lee

  • Hero Member
  • *****
  • Posts: 645
    • My Core wiki user page
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #107 on: October 07, 2013, 07:27:48 PM »
grub4dos from 4.x seems to work in 5.x
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm  |  - Testing -
PPR, data persistence through filetool.sh          |  32 bit core 8.0 alpha 1
USB Flash drive, one partition, ext2, grub4dos  | Otherwise similar

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #108 on: October 07, 2013, 11:30:11 PM »
copied over

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #109 on: October 08, 2013, 01:54:12 AM »
Hi,

more extensions working from 4.x to 5.x

usb-modeswitch-data.tcz
usb-modeswitch.tcz
libssl-0.9.8.tcz
tcl-tk.tcz
wvdial.tcz
wvstreams.tcz


Offline jls

  • Hero Member
  • *****
  • Posts: 2133
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #110 on: October 08, 2013, 02:16:09 AM »
plz copy tint2 (modify the Xorg dep)
dCore user

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #111 on: October 08, 2013, 02:21:31 AM »
tcl_tk looks like it is a combination of the tcl and tk extensions already in the tc-4.x and tc-5.x repos, is this correct? If so, we might as well change the dep from tcl_tk to tcl and tk for usb-modeswitch.

libssl-0.9.8 has been superseded by libssl-1.0.0 in the tc-5.x repo, so extensions like wvdial that depend on it will need recompiling.
« Last Edit: October 08, 2013, 02:23:57 AM by Juanito »

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #112 on: October 08, 2013, 02:24:27 AM »
tcl_tk looks like it is a combination of the tcl and tk extensions already in the tc-4.x and tc-5.x repos, is this correct? If so, we might as well change the dep from tcl_tk to tcl and tk for usb-modeswitch.

Yes.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #113 on: October 08, 2013, 03:01:27 AM »
usb-modeswitch-data, usb-modeswitch and tint2 posted

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #114 on: October 11, 2013, 10:21:32 AM »
scite.tcz works OK in Tc5.x!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #115 on: October 11, 2013, 11:24:16 PM »
copied over - thanks

Offline theYinYeti

  • Full Member
  • ***
  • Posts: 177
    • YetI web site
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #116 on: October 12, 2013, 04:11:37 AM »
nmap works OK with this dep file:
Code: [Select]
libpcap.tcz
pcre.tcz
openssl-1.0.0.tcz
ncurses.tcz
libnl.tcz

Offline theYinYeti

  • Full Member
  • ***
  • Posts: 177
    • YetI web site
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #117 on: October 12, 2013, 04:22:23 AM »
..The .dep files for getlocale and gftp2 should be changed accordingly, then.
You'll need to try them - I'd guess they're (at least gftp2 and aircrack-ng) going to need re-compiling
Indeed, gftp2 doesn't work by simply changing the dep file. Not even by linking the lib file to the old name and ldconfig...

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #118 on: October 12, 2013, 11:23:46 AM »
flpicsee
dCore user

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #119 on: October 12, 2013, 10:59:19 PM »
nmap works OK with this dep file

I don't see how:
Code: [Select]
$ ldd /usr/local/bin/nping | grep libnl
        libnl.so.1 => not found

From libnl:
Code: [Select]
$ ls /usr/local/lib/libnl*
/usr/local/lib/libnl-3.so
/usr/local/lib/libnl-3.so.200
/usr/local/lib/libnl-3.so.200.16.1
...

As mentioned (I might be wrong) nmap will need recompiling against the version of libnl in the tc-5.x repo.