WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Extensions from 4.x repo verified ok with tc-5  (Read 81181 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #45 on: September 19, 2013, 09:03:28 PM »
busybox-httpd and libevent posted

transmission-gtk throws error while loading shared libraries: libpng12.so.0 - even with libpng.tcz loaded.

transmission also needs recompiling against openssl-1.0.0

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #46 on: September 19, 2013, 09:06:28 PM »
smallbasic-cli.tcz and smallbasic-doc.tcz seem to be ok

posted

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7022
    • My Community Forum
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #47 on: September 19, 2013, 10:56:39 PM »
libevent.tcz is an ancient version from January 2011. WHile it may work would deserve an update to current upstream.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #48 on: September 20, 2013, 04:17:26 AM »
Gnumeric requires libpng, so it will need to be rebuilt.
In a pinch, it seems to work by making a symbolic link to libpng16.so to libpng12.so.0. This is not a long-term solution, though.

HTH

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #49 on: September 20, 2013, 04:19:09 AM »
elinks works from 4.x. Posting using elinks now [knock on wood].

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #50 on: September 20, 2013, 04:25:05 AM »
elinks-nodep posted

elinks has a dep on openssl-0.9.8 so will need recompiling

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #51 on: September 20, 2013, 04:31:07 AM »
actkbd works from 4.x repo [no dependencies].

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #52 on: September 20, 2013, 04:52:40 AM »
posted

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 355
    • Zendrael's home of projects
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #53 on: September 20, 2013, 07:50:58 AM »
Also working ok:

  • svn.tcz
  • apr.tcz
  • apr-util.tcz


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #54 on: September 20, 2013, 08:04:52 AM »
svn, apr, apr-util posted

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #55 on: September 20, 2013, 04:09:25 PM »
elinks-nodep posted

elinks has a dep on openssl-0.9.8 so will need recompiling

Ah, of course. Thanks for checking that part!

DLT

Offline dentonlt

  • Sr. Member
  • ****
  • Posts: 307
    • the trombone analog
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #56 on: September 20, 2013, 11:09:12 PM »
pilot-link-base.tcz from 4.x works. Dependencies are usb utils, etc.

jpilot will require a rebuild once eglibc_gconf is available. I'll try to rebuild jpilot without the latter.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #57 on: September 20, 2013, 11:28:35 PM »
pilot-link-base posted - I'm not sure how the dev extension can have a dep on ncurses that is not present in the base extension?

glibc_gconf is available  :)

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #58 on: September 21, 2013, 10:15:28 AM »
working:     iptables.tcz (in the iptables.tcz.dep changing the entry netfilter-3.0.21-tinycore.tcz to netfilter-3.8.10-tinycore.tcz)


Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #59 on: September 21, 2013, 10:21:40 AM »
In the .dep file of my copy of iptables there is only one line:
netfilter-KERNEL.tcz
(literaly)
Bug or feature?
It does work, however.
Download a copy and keep it handy: Core book ;)