WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Extensions from 4.x repo verified ok with tc-5  (Read 81752 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #150 on: February 10, 2014, 09:36:27 PM »
As I recall, libssl-0.9.8 was created so as not to conflict with openssl-1.0.0 and provide backwards compatibility for the tc-4.x repo.

As libssl-0.9.8 has been updated to 1.0.0, it makes sense to only use this for the tc-5.x repo rather than (re)introduce two version of the same library.

Offline thane

  • Hero Member
  • *****
  • Posts: 644
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #151 on: February 10, 2014, 09:48:00 PM »
OK, found that the dependency on libssl-0.9.8 is in vorbis-tools.tcz.dep. Changed this dependency to openssl-1.0.0.tcz (which I already had downloaded before all this) and deleted the libssl-0.9.8.tcz extension. Rebooted and Audacious still works with MP3. So it looks like openssl-1.0.0 has whatever functions the vorbis-tool needs?

edit: Also meant to post that there's no dependency in audacious on libpng12, but there is on libpng16.
« Last Edit: February 10, 2014, 09:51:12 PM by thane »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #152 on: February 10, 2014, 11:16:55 PM »
audacious and deps copied to tc-5.x repo

Note:

* various deps adjusted
* I cannot get audacious to work with alsa - it does not list alsa as an output option, even though the output library is present
* I could not find any dep on libssl
* several optional deps (eg libavformat) are unlikely to work as the libraries have been updated to newer versions

Offline thane

  • Hero Member
  • *****
  • Posts: 644
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #153 on: February 11, 2014, 12:41:52 AM »
Deleted my hack and downloaded the 5.x version Juanito made. It works with alsa on my box (previously had alsa installed and working with XMMS). When I right-click on the Audacious panel and select Preferences the Current output plugin dropdown shows as ALSA Output Plugin. Besides alsa, I have Firefox 27.0 (used Firefox-get to obtain it), jdk7 (obtained via java-installer), Flash, evince2, flpicsee, and fluff -- a very minimal setup. Possibly Audacious is missing a dependency that I happen to have from one of those apps? Also I'm running xorg.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #154 on: February 11, 2014, 12:59:21 AM »
Deleted my hack and downloaded the 5.x version Juanito made.

I didn't make the extension, I just copied it from the 4.x repo and corrected the deps.

'glad it works for you  :)

Offline thane

  • Hero Member
  • *****
  • Posts: 644
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #155 on: February 12, 2014, 10:29:48 AM »
So far so good with Audacious on 5.x. Belated thanks to Juanito for getting this set up.

Thane

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6965
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #156 on: February 12, 2014, 01:05:28 PM »
Hi Juanito
A per this thread:
http://forum.tinycorelinux.net/index.php/topic,16641.msg99344.html#msg99344
xdrdesktop.tcz  works on TC5.x. There was a warning message shown here:
http://forum.tinycorelinux.net/index.php/topic,16641.msg99414.html#msg99414
This was fixed by loading  glibc_gconv.tcz. I ran ldd on the  rdesktop  executable and the libraries it depends on but was
unable to determine which one needed  glibc_gconv.tcz.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #157 on: February 12, 2014, 10:48:04 PM »
thanks - xdrdesktop copied to tc-5.x repo and glibc_gconv added to deps

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #158 on: February 12, 2014, 10:51:51 PM »
'glad it works.

Note that the existing gtk2 version of audacious has been renamed audacious2 and audacious has been updated to the gtk3 version.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6965
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #159 on: February 13, 2014, 08:45:36 AM »
Hi Juanito
Just out of curiosity, were you able to figure out which extension depended on  glibc_gconv.tcz  or did you just add it
to  rdesktop.tcz?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #160 on: February 13, 2014, 08:58:43 PM »
In fact I didn't try, I just put it as a dep of xdrdesktop.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10069
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #161 on: February 14, 2014, 01:49:40 AM »
It's an optional dep of rdesktop.
The only barriers that can stop you are the ones you create yourself.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #162 on: February 17, 2014, 08:35:27 PM »
bonnie++  tests ok in tc-5.x   

dep perl5.tcz is already in repo

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #163 on: February 17, 2014, 10:17:14 PM »
copied over - thanks

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: Extensions from 4.x repo verified ok with tc-5
« Reply #164 on: February 20, 2014, 02:24:07 AM »
Hi Juanito,

fwbackups.tcz runs OK in TC-5.x, it can be copy his deps python_paramiko.tcz and pycrypto.tcz also
In fwbackups.tcz.dep must be changed pygtk-2.7.tcz to pygtk.tcz