WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Core v5.0rc1  (Read 33547 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Core v5.0rc1
« Reply #60 on: September 03, 2013, 04:51:39 PM »
Using Xvesa and the following firefox dep file:
Code: [Select]
gtk2.tcz
libasound.tcz
dbus-glib.tcz
hicolor-icon-theme.tcz
..firefox now works for me in tc-5.x - the issue was that the dep file I had was missing dbus-glib.

I presume the dep file for minefield21 is the same? I'll copy both to the tc-5.x repo when I next have access.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Core v5.0rc1
« Reply #61 on: September 03, 2013, 05:49:51 PM »
-wl is not a valid combination of options.

gordonselfish

  • Guest
Re: Core v5.0rc1
« Reply #62 on: September 03, 2013, 11:45:33 PM »
gerald_clark
Quote
-wl is not a valid combination of options.

maybe, but have a look at my reply number 86, it works there,
but I was reporting what I might call "bad" builds due to permission errors.

to save you looking the top part is
Code: [Select]
#!/bin/sh
LIST1="compiletc squashfs-tools-4.x wget net-snmp cups-dev libusb-dev python-dev dbus-glib-dev dbus-python-2.7 sane-backends-dev "
for Z in $LIST1
do
      tce-load -wl $Z
      tce-load -i  $Z
done

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #63 on: September 04, 2013, 04:26:41 PM »
I've been using evince2, which functioned well.

using Xorg-7.7

loading evince (without the older evince2 loaded) results in two desktop entries and two wbar icons
1. evince
2 dconfeditor

selecting new evince  throws an error without loading
evince: symbol lookup error: /usr/local/lib/libevview3.so.3: undefined symbol: gtk_container_accessible_get_type

selecting new dconfeditor loads without error.




booting base  with Xvesa

loading evince results in one desktop entrie and one wbar icon: evince
also
...
harfbuzz.tcz: OK
/usr/local/bin/pango-querymodules: error while loading shared libraries: libXft.so.2: cannot open shared object file: No such file or directory
pango.tcz: OK
...


starting app in terminal
evince: symbol lookup error: /usr/local/lib/libevview3.so.3: undefined symbol: gtk_container_accessible_get_type

additionally a GTK3 Warning  could not find icon 'go-previous-symbolic'

also 'no hicolor theme found' (maybe I need to update my deps?)





booting base  with Xorg7.7

loading evince results in one desktop entries and one wbar icon: evince
also
...
harfbuzz.tcz: OK
/usr/local/bin/pango-querymodules: error while loading shared libraries: libXft.so.2: cannot open shared object file: No such file or directory
pango.tcz: OK
...


starting app in terminal results in
evince: symbol lookup error: /usr/local/lib/libevview3.so.3: undefined symbol: gtk_container_accessible_get_type

additionally a GTK3 Warning  could not find icon 'go-previous-symbolic'

also 'no hicolor theme found' (maybe I need to update my deps?)


« Last Edit: September 04, 2013, 05:13:52 PM by coreplayer2 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Core v5.0rc1
« Reply #64 on: September 04, 2013, 04:51:48 PM »
glib2 and gtk3 have been updated recently - perhaps you're missing the latest version?

I just checked and evince works OK for me from a clean boot  - I usually try to avoid putting hicolor-icon-theme/gnome-icon-theme/gnome-icon-theme-symbolic as deps, but in this case none of the menu icons come up without it, making evince difficult to use.

I'll add gnome-icon-theme-symbolic as a dep next chance I get to access the repo.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #65 on: September 04, 2013, 05:17:26 PM »
Ok just made a 'Xvesa base' and 'Xorg base' boot loader options and
updated my last post above (re evince) with both

booting base  with Xorg
booting base  with Xvesa



@ juanito, yes it looks like i need to update..  brb

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: Core v5.0rc1
« Reply #66 on: September 04, 2013, 05:22:49 PM »
click on thumbnail if interested, but to save you time, calculator is loaded but no wbar
-----maybe because I have gtk2 and 3?
No, the desktop file has the wrong name - I'll fix this in the next day or two.

Quote
but the next image is more important see the missing icons at RH side?
loading one of the icon-theme extensions will fix this

Thanks for the feedback

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #67 on: September 04, 2013, 05:23:35 PM »
I was familiarizing myself with tce-load options since I also use it a lot.  AIUI the 'l' option only means anything when preceded by an i, otherwise does nothing; right?


Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #68 on: September 04, 2013, 07:22:56 PM »
gordon,  yes I was interested in the tce-load option you have used, particularly with the
tce-load -wil ""
tce-load -i ""
loop you have implemented and yes i experimented with various apps and can confirm lower case l is only effective when it is preceded by an -i , otherwise has no effect. I believe -w will only download in any case.

:)
« Last Edit: September 04, 2013, 07:45:22 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #69 on: September 04, 2013, 07:39:12 PM »
Ok have been experimenting with evince.

updating my deps fixed the big issue, thanks

with gnome-icon-symbolic added to evince dep list, evince loads and starts perfectly from the terminal (or apps 'load app locally')  thanks juanito, great job

Only thing I haven't figured out is,  if evince is added to the onboot list of either ( 'base with Xorg' or 'base with Xvesa'  onboot-base.lst's or my default onboot.lst ) then on every subsequent reboot there is an extra icon and desktop menu entry loaded from dconf-editor, which can be run separately and in addition to evince.

 :)

« Last Edit: September 04, 2013, 07:41:27 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #70 on: September 04, 2013, 07:55:11 PM »
Oooop's I spoke too soon,  I guess it would help to test that evince actually opens a document and displays it as expected, right?

well on attempt to open a pdf file the app exited and left this in the terminal

Code: [Select]
evince

(evince:10680): GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.lockdown' is not installed

Trace/breakpoint trap


Same applies to a sample tiff file I downloaded for the test


edit:  looks like we need 'gsettings-desktop-schemas.tcz' as a dep also
« Last Edit: September 04, 2013, 08:10:32 PM by coreplayer2 »

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6950
Re: Core v5.0rc1
« Reply #71 on: September 04, 2013, 08:12:17 PM »
Hi coreplayer2
Quote
(evince:10680): GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.lockdown' is not installed
Don't know if this is related, but  gsettings-desktop-schemas.tcz  contains something called
org.gnome.desktop.lockdown.gschema.xml

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #72 on: September 04, 2013, 08:13:22 PM »
yes thanks that was it  tiff and pdf's load fine now

thanks


added these tcz's to my evince dep list
gsettings-desktop-schemas.tcz
gnome-icon-symbolic.tcz

sample files open fine now
« Last Edit: September 04, 2013, 08:27:12 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #73 on: September 04, 2013, 08:29:07 PM »
evince has a really nice editor / viewer now, but what's in the secret sauce?  :p



the dconfeditor icon (with the magnifying glass) appears and can launch it's application independantly from evince, only when evince is loaded via onboot.lst
the dconfeditor icon and desktop menu item doesn't appear when loaded via tce-load, via apps, or when run from the ondemand menu


update: added results when run from ondemand
« Last Edit: September 04, 2013, 09:30:18 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Core v5.0rc1
« Reply #74 on: September 04, 2013, 09:35:45 PM »
Also noticed that removing an app from the OnDemand directory can only be accomlished by deleting the script manually.  the feature to remove OnDemand items in apps doesn't appear to be functioning on my system for some reason, though I have checked the dir and script permissions without revealing any insight as to why this is.