WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TCL on Samsung N150: special keys doesn't work, nor touchpad scroll availability  (Read 3378 times)

Offline DanielH

  • WikiUser
  • *
  • Posts: 15
Hello.

I've installed TCL on a Samsung N150, Atom N450 processor, 1 GB RAM.
Standard Xvesa server (not Xorg), FLWM, 915resolution.tcz on boot, alsa and a lot of .scm and .tcz apps.

It boots and run very quickly, but Samsung special keys doesn't work, nor vertical nor horizontal scroll is available in touchpad.

Fn + up/down cursor keys for display brightness control doesn't work. I've tried using "acpi_backlight=vendor" bootcode (used in Debian and derivatives distros), but nothing happens.
Note I: the display brightness decreases when netbook is running on battery, and rises when the power adapter is connected.

Fn + left/right cursor keys for sound level control:  these doesn't works at all.
Note II: running flit.tcz, Ctrl + U and Ctrl + L increases/decreases the volume, as is expected.
Fn + ESC, Fn + F2 to F9: nothing works; however Fn + F10 keys allows enable/disable touchpad) and Fn + F11 (number lock) allows the use of optional numeric and math operators keys.

Scroll: not working using Synaptics touchpad, but works seamless using a 2 button + wheel USB mouse:

cat /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input7
U: Uniq=
H: Handlers=mouse1 event7
B: PROP=9
B: EV=b
B: KEY=6420 0 30000 0 0 0 0 0 0 0 0
B: ABS=2608000 11000003

I: Bus=0003 Vendor=0458 Product=003a Version=0111
N: Name="Genius Optical Mouse"
P: Phys=usb-0000:00:1d.3-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/input/input6
U: Uniq=
H: Handlers=mouse0 event6
B: PROP=0
B: EV=17
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103
B: MSC=10

I've search in TCL forum, and in other distros forums, but seems there is not solution under Xvesa (perhaps there are some tricks under Xorg, but I prefer to avoid it).
.......

My boot codes: nozswap norestore laptop noautologin nodhcp showapps xvesa=1024x600x32 kmap=/qwerty/la-latin1 tce=sda1 opt=sda1 home=sda1 waitusb=5:UUID="dd7527a3-272b-421d-ad63-35ac2988679d" tce=UUID="dd7527a3-272b-421d-ad63-35ac2988679d"

My .xsession:
Xvesa -br -screen 1024x600x24 -shadow -2button -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1 &
export XPID=$!
waitforX || ! echo failed in waitforX || exit
sleep 3 && xmodmap -e "clear Mod4" -e "add Mod5 = Mode_switch" &
"$DESKTOP" 2>/tmp/wm_errors &
export WM_PID=$!
[ -x ./.setbackground ] && ./.setbackground
[ -x ./.mouse_config ] && ./.mouse_config &
[ $(which "$ICONS".sh) ] && ${ICONS}.sh &
[ -d ".X.d" ] && find ".X.d" -type f -print | while read F; do . "$F"; done
[ $(which flit) ] && flit &
[ $(which watcher) ] && watcher -g +0-0 &


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 10160
Scroll: not working using Synaptics touchpad, but works seamless using a 2 button + wheel USB mouse:

You will need Xorg for detailed control of the touch pad - Xorg-7.6 contains the synaptics driver

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
As a "better-than-nothing" solution, you could try to set brightness and volume (max recommended) at bootloader time, before the kernel has taken control of hardware.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9874
Special keys: they require kernel support to register at all, and some of them (volume for example) may still not do anything unless you bind them. Brightness, numpad usually work as is, as they don't require userspace support.
The only barriers that can stop you are the ones you create yourself.