WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: opera 4.x users pls read you get a chance  (Read 1805 times)

aus9

  • Guest
opera 4.x users pls read you get a chance
« on: June 23, 2013, 02:56:47 AM »
hI

I have permission from 3 maintainers to update opera for 4.x.
But similar to firefox, the name will be opera.tcz leaving the other operaN.tczs alone.
To act as a rolling release.

Mine has no locale as I used the i386 version and not the one you see when you first go to downloads which is 64 bit.

As you won't see it in your apps update, look in apps browse in about 2 weeks from now, if my build is good enough.

Thanks

Offline hiro

  • Hero Member
  • *****
  • Posts: 1073
Re: opera 4.x users pls read you get a chance
« Reply #1 on: June 23, 2013, 08:50:49 AM »
Is the question just about whether next opera-next.tcz update should be renamed into opera.tcz?

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: opera 4.x users pls read you get a chance
« Reply #2 on: June 23, 2013, 03:18:09 PM »
Sounds like a horrible idea, in particular to current circumstances of Opera, in general to approach of alpha or beta software.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

aus9

  • Guest
Re: opera 4.x users pls read you get a chance
« Reply #3 on: June 23, 2013, 03:29:58 PM »
Quote
Is the question just about whether next opera-next.tcz update should be renamed into opera.tcz

hiro, no attempt to do anything to any existing opera versions.

Actually I find some of the versions in our repo confusing, but I am easily confused  :D

Offline hiro

  • Hero Member
  • *****
  • Posts: 1073
Re: opera 4.x users pls read you get a chance
« Reply #4 on: June 24, 2013, 03:15:51 AM »
It's confusing, I agree.

I'm currently using 11.61, and it used to be very buggy on my system.
Although in the last months out of unknown reasons it has been very stable. Perhaps because I've stopped using it with flash. Instead I use quvi together with mplayer for videos.

The switch to webkit is frightening on many levels. I will simply stop caring about new opera releases, so I don't care about opera.tcz.
Stuff with presto shouldn't be rolling release, as it would be more useful to people like me and tinypoodle to have some choice between packs of bugs we think we can live with.

aus9

  • Guest
Re: opera 4.x users pls read you get a chance
« Reply #5 on: June 24, 2013, 03:59:41 AM »
thanks for sharing but I ask for more.

sorry I am not a opera user. Sorry if that sounds weird.

If you and others could post here what your ideal package arrangements "should" be, maybe we can come to an arrangement.

opera also works with a slight mod, on alpha 5x, but I have withheld submitting that until Xorg goes 7.7. No doubt people may not like that either, depending on Xorg-7.7-lib?

anyhow, what I am trying to say,
a) my submission may be rejected as a bad build if not---on 4x
b) someone else could maintain it or not as they see fit.
c) we all have time issues
--I selfishly grabbed permission so I could use an up-to-date browser on alpha and mozilla stuff will take too long to build for alpha.....so I am quite relaxed on others taking over maintainership

I hope that gives you light at the end of the tunnel?

I hope you agree there are issues with what I said earlier?
opera appears to offer up-to-date 32 bit or 64 bit.

I know nothing about your other concerns so am happy to handball.