WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Tiny Core 5.0 Alpha 2 Testing  (Read 68569 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11201
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #120 on: June 21, 2013, 06:14:15 AM »
efi (mac mini) and uefi (dell latitude e6220) boot both tested OK from a usb stick using grub2:
Code: [Select]
$ fdisk -l /dev/sdc
Found valid GPT with protective MBR; using GPT

Disk /dev/sdc: 2030592 sectors, 1983K
Logical sector size: 512
Disk identifier (GUID): 4201139c-424d-43d7-af02-8ba04d30463b
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 2030558

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          245760        238K   0700  EFI System
   2          247808         2030558       1740K   0700  Linux/Windows data

Code: [Select]
$ cat /mnt/sdc1/EFI/BOOT/grub/grub.cfg
search --no-floppy --fs-uuid --set=root 74d071dc-a992-4493-8b54-168fb79897dd

menuentry "rootfs64" {
  linux /boot/vmlinuz64 quiet noswap tce=UUID=74d071dc-a992-4493-8b54-168fb79897dd waitusb=10:UUID=74d071dc-a992-4493-8b54-168fb79897dd tz=GMT-4 blacklist=bcma blacklist=ssb blacklist=b43 text
  initrd /boot/rootfs.gz /boot/modules64.gz

Note that in both cases the (u)efi boot loader is 64bit "/mnt/sdc1/EFI/BOOT/BOOTX64.EFI", so not tested with 32bit tc-5.x
« Last Edit: June 21, 2013, 06:18:48 AM by Juanito »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Tiny Core 5.0 Alpha 2 Testing
« Reply #121 on: June 21, 2013, 06:43:04 AM »
Updated Xlibs and rebooted, this happened

I just re-downloaded Xlibs from the 5.x repo and "startx" is definately there in /usr/bin - does the md5sum check out OK?

If it happens again ill check the md5sum, possibly the error was the result of a bad download.


Sent from my iPad using Tapatalk HD

aus9

  • Guest
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #122 on: June 21, 2013, 05:36:52 PM »
hi
testing alsa update (have not tried before update)
before loading alsaconf, without using onboot, alsa loads, daemon status is running but no sound

ok so
Code: [Select]
tc@box:~$ tce-load -i alsaconf
/etc/sysconfig/tcedir/optional/alsaconf.tcz: OK
tc@box:~$ sudo alsaconf
sudo: unable to execute /usr/local/sbin/alsaconf: No such file or directory
tc@box:~$ ls /usr/local/sbin/alsaconf
/usr/local/sbin/alsaconf
tc@box:~$ ls -al /usr/local/sbin/alsaconf
lrwxrwxrwx    1 root     root            44 Jun 22 00:27 /usr/local/sbin/alsaconf -> /tmp/tcloop/alsaconf/usr/local/sbin/alsaconf
tc@box:~$ ls -al /tmp/tcloop/alsaconf/usr/local/sbin/alsaconf
-rwxr-xr-x    1 root     root         35619 Jun 21 15:47 /tmp/tcloop/alsaconf/usr/local/sbin/alsaconf
tc@box:~$ sudo /tmp/tcloop/alsaconf/usr/local/sbin/alsaconf
sudo: unable to execute /tmp/tcloop/alsaconf/usr/local/sbin/alsaconf: No such file or directory

aus9

  • Guest
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #123 on: June 21, 2013, 05:39:12 PM »
altho I know you are super busy, a blantant bump for gtk2-dev but extra

both gtk2-dev and gtk1-dev have a missing depend of the same file
Quote
Xorg-7.6-dev.tcz

thanks for reading

aus9

  • Guest
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #124 on: June 21, 2013, 05:49:20 PM »
to anyone

I guess the reason for coreplayer2 boot up issue earlier?

have a look at the new depends of Xlibs and flwm_topside
If users had not waited for all of those depends to download, maybe he was just missing one on reboot?

aus9

  • Guest
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #125 on: June 21, 2013, 06:14:48 PM »
update to reply 122,

I leave the alsaconf there for any one to grasp, but I just rebooted and have sound but still a little dirty
Code: [Select]
sudo /usr/local/etc/init.d/alsasound start
rmmod: can't unload 'snd_hda_codec_idt': Resource temporarily unavailable
rmmod: can't unload 'snd_hda_codec': Resource temporarily unavailable
rmmod: can't unload 'snd_hwdep': Resource temporarily unavailable
rmmod: can't unload 'snd_pcm': Resource temporarily unavailable
rmmod: can't unload 'snd_timer': Resource temporarily unavailable
rmmod: can't unload 'snd': Resource temporarily unavailable
Starting sound driver: snd-hda-intel 
tc@box:~$ speaker-test -c 2 -t wav
sound works I was tricked by the output, .....but I am easily tricked, hey where are my clothes? :P

Offline Lee

  • Hero Member
  • *****
  • Posts: 645
    • My Core wiki user page
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #126 on: June 21, 2013, 09:33:11 PM »
emelfm2.tcz from the 4.x repo seems to work in 5.0.alpha2 if you add Xorg-7.6-lib to its .dep file.

I haven't done extensive testing, but it looks ok on a brief tryout.
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm  |  - Testing -
PPR, data persistence through filetool.sh          |  32 bit core 8.0 alpha 1
USB Flash drive, one partition, ext2, grub4dos  | Otherwise similar

Offline Lee

  • Hero Member
  • *****
  • Posts: 645
    • My Core wiki user page
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #127 on: June 21, 2013, 09:39:32 PM »
sylpheed.tcz (the regular, gtk2 version) from the 4.x repo seems to work in 5.0.alpha2 if you add Xorg-7.6-lib to its .dep file, bring over libssl-0.9.8.tcz and make new symlink to libpng16.so.16.2.0 as libpng12.so.0.  I suppose it ought to be recompiled to resolve the libpng issue.

As with emelfm2, I haven't done extensive testing, but it looks ok on a brief tryout.
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm  |  - Testing -
PPR, data persistence through filetool.sh          |  32 bit core 8.0 alpha 1
USB Flash drive, one partition, ext2, grub4dos  | Otherwise similar

Offline Lee

  • Hero Member
  • *****
  • Posts: 645
    • My Core wiki user page
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #128 on: June 21, 2013, 09:42:11 PM »
libssl-0.9.8.tcz from the 4.x repo seems to work in 5.0.alpha2, at least in as much as it allows sylpheed.tcz to work.
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm  |  - Testing -
PPR, data persistence through filetool.sh          |  32 bit core 8.0 alpha 1
USB Flash drive, one partition, ext2, grub4dos  | Otherwise similar

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11201
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #129 on: June 21, 2013, 11:08:20 PM »
testing alsa update (have not tried before update)
before loading alsaconf, without using onboot, alsa loads, daemon status is running but no sound

Thanks - I missed the alsaconf dep file - it should be OK now.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11201
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #130 on: June 21, 2013, 11:19:42 PM »
emelfm2.tcz from the 4.x repo seems to work in 5.0.alpha2 if you add Xorg-7.6-lib to its .dep file.

Thanks - copied over with Xorg-7.7-lib as a dep

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11201
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #131 on: June 21, 2013, 11:22:03 PM »
sylpheed.tcz (the regular, gtk2 version) from the 4.x repo seems to work in 5.0.alpha2 if you add Xorg-7.6-lib to its .dep file, bring over libssl-0.9.8.tcz and make new symlink to libpng16.so.16.2.0 as libpng12.so.0.  I suppose it ought to be recompiled to resolve the libpng issue.
Basically, everything with a dep on the old libpng will need recompiling

Quote
libssl-0.9.8.tcz from the 4.x repo seems to work in 5.0.alpha2, at least in as much as it allows sylpheed.tcz to work.
Let's try and use openssl-1.0.0 and newer in the 5.x repo
« Last Edit: June 21, 2013, 11:26:12 PM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11201
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #132 on: June 21, 2013, 11:24:38 PM »
altho I know you are super busy, a blantant bump for gtk2-dev but extra

both gtk2-dev and gtk1-dev have a missing depend of the same file - Xorg-7.6-dev.tcz

I think it would be better to wait until Xorg-7.7-dev is out and compile things against that.

aus9

  • Guest
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #133 on: June 22, 2013, 01:05:16 AM »
Quote
I think it would be better to wait until Xorg-7.7-dev is out and compile things against that.
ok, message finally received and understood

trivia, cups the way I build it, depends on gtk2-dev, avahi-dev and ghostscript, most waiting on Xorg-7.7 or cut down dep files.
I have rebuilt the dep files for each but can't really do anything if you were as impatient as me.

2) It should be safe to upload cups-filters and libcups-filters as neither of them depend on Xorg or png stuff.
Or I could mention to my friend when I finally submit the build for cups?

3) I have always been a bit unsure of my wireless skills so cups-browsed won't be built until cups lands. But that is exactly how I did it in 4x.....cups-filters then cups then cups-browsed. With cups-browsed built against cups 1.6.2

4) Trivia, I have not loaded the led* TCZ but my num pad is now working beautifully in 5x----good stuff.

Each time I look my build, I can move more stuff for 5x to load and less for 4x, which is wonderful
Keep up the magnificant job you guys.

coreplayer2
You wouldn't be building or testing firmware and related packages by any chance?

aus9

  • Guest
Re: Tiny Core 5.0 Alpha 2 Testing
« Reply #134 on: June 22, 2013, 01:21:52 AM »
alsa revisited---sorry
Code: [Select]
sudo /usr/local/etc/init.d/alsasound start
rmmod: can't unload 'snd_hda_codec_idt': Resource temporarily unavailable
rmmod: can't unload 'snd_hda_codec': Resource temporarily unavailable
rmmod: can't unload 'snd_hwdep': Resource temporarily unavailable
rmmod: can't unload 'snd_pcm': Resource temporarily unavailable
rmmod: can't unload 'snd_timer': Resource temporarily unavailable
rmmod: can't unload 'snd': Resource temporarily unavailable
Starting sound driver: snd-hda-intel 
tc@box:~$ speaker-test -c 2 -t wav

speaker-test 1.0.27.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
speaker-test: relocation error: speaker-test: symbol snd_pcm_get_chmap, version ALSA_0.9 not defined in file libasound.so.2 with link time reference

just running speaker-test gives a similar error