WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Disable Ctrl Alt Delete?  (Read 2270 times)

Offline thoard

  • WikiUser
  • *
  • Posts: 2
Disable Ctrl Alt Delete?
« on: May 13, 2013, 04:11:13 PM »
I built a VMWare View client boot CD from the Tiny Core builder. When we boot to it and go into our virtual machine, if someone mistakenly hits control + alt + delete it goes back to a prompt for Tiny Core. I guess the question I have is, is there anyway to change those key assignments or completely disable them inside of Tiny Core? Any help you guys could give would be greatly appreciated  :)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7387
Re: Disable Ctrl Alt Delete?
« Reply #1 on: May 13, 2013, 11:06:27 PM »
Hi thoard
Don't know if this will work, but you could try commenting out the  ctrlaltdel  line in  /etc/inittab.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1027
Re: Disable Ctrl Alt Delete?
« Reply #2 on: May 14, 2013, 12:01:11 AM »
hi friends,

in my "usb-stick-mount-mode-installation" ctrl+alt+del just ends my xvesa-session, syncs the filesystem and then halts.
i have to hit ctrl+alt+del again to reboot the system...
is this the common and wanted behavior?

thank you for your comments.
« Last Edit: May 14, 2013, 12:04:05 AM by netnomad »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10159
Re: Disable Ctrl Alt Delete?
« Reply #3 on: May 14, 2013, 03:30:17 AM »
@netnomad

It should reboot, it may be your bios that's not letting it. Once it's halted, the new ctrl-alt-del press goes to the bios and not the OS.
The only barriers that can stop you are the ones you create yourself.

Offline thoard

  • WikiUser
  • *
  • Posts: 2
Re: Disable Ctrl Alt Delete?
« Reply #4 on: May 14, 2013, 03:33:08 PM »
Thanks Rich, I will give that a shot here soon.