WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Custom vga mode  (Read 1342 times)

Offline 2os

  • WikiUser
  • *
  • Posts: 22
Custom vga mode
« on: May 10, 2013, 02:16:07 PM »
If during install I specify an invalid "vga=.." value, later on boot I get the option to select a valid mode. The mode that works best for me is:
vga mode: 356 [letter x]
resolution: 1152x864x32

How can I specify this mode to be the default for my installation? The example chart is not showing this mode.

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Custom vga mode
« Reply #1 on: May 11, 2013, 03:39:38 AM »
Hi 2os.

If the chart(list) does not show the mode(even scanned), you cannot set the vga mode.
Selecting from the list is needed.

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Custom vga mode
« Reply #2 on: May 11, 2013, 03:49:03 AM »
If the chart(list) does not show the mode(even scanned), you cannot set the vga mode.
Selecting from the list is needed.

Would you have any references to documentation?
I failed to find anything making it clear, while wondering the same as OP.
« Last Edit: May 11, 2013, 04:01:12 AM by tinypoodle »
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Custom vga mode
« Reply #3 on: May 11, 2013, 04:14:41 AM »
Hello, tinypoodle.

The information is from linux kernel documents.

According to the section 2 of https://www.kernel.org/doc/Documentation/svga.txt,
Quote
If you are not happy with the mode list offered (e.g., if you think your card is able to do more), you can enter "scan" instead of item number / mode ID. The program will try to ask the BIOS for all possible video mode numbers and test what happens then.

So the video mode which 2os wants to use is not supported by BIOS, I think.

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Custom vga mode
« Reply #4 on: May 11, 2013, 04:27:31 AM »
Yes, but according to section 3:

Quote
You can set a mode by entering its mode directly if you know it even if it isn't shown on the menu.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Custom vga mode
« Reply #5 on: May 11, 2013, 04:46:26 AM »
Oh, thank you.
It was my fault.

But, 2os could not set to the mode even if it was hex valiable.
So the video card does not support the mode implicit and explicit, isn't it?

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Custom vga mode
« Reply #6 on: May 11, 2013, 05:04:52 AM »
If I understand right, what OP tries to achieve is setting a mode which would be selectable with 'vga=ask' directly as boot parameter.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Custom vga mode
« Reply #7 on: May 11, 2013, 05:20:49 AM »
Oh!!! I see...
You are right.
Sorry for my misunderstanding.

Then, 2os,
add "vga=0x356" to the end of the syslinux.cfg's "kernel" line to set the vga mode default.

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline 2os

  • WikiUser
  • *
  • Posts: 22
Re: Custom vga mode
« Reply #8 on: May 13, 2013, 10:03:28 AM »
Akane and tinypoodle - thank you both for your dialog in response to my query. You did help me to resolve this issue.

First, the vga mode I wanted to embed as default:

vga mode: 356 [letter x]
resolution: 1152x864x32

is presented as an option when I choose scan on boot and even without scan. This is the best display mode this particular laptop can handle and as such I wanted to embed it as default.

Second,  the last response by Akane, is the key to this solution. Instead of editing syslinux.cfg, I specified vga=0x356 during the install. This resulted in an installation that boots every time to this vga mode I wanted with no prompts or delays. Prefect. Thanks a bunch!!