WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: HELP:Cannot boot VAIO into X from LiveCD CorePlus 4.7.7. Stuck at "tc@box:~$".  (Read 2861 times)

Offline jam_27

  • WikiUser
  • *
  • Posts: 4
Last weekend I decided to dust off my old SONY VAIO PCG U3 but could not boot into X with any of the options available on the LIVE CD 4.7.7 (CorePlus).

System info :

PCG-U3, Transmeta Crusoe TM5800 @ 933 MHz, 1024×768 resolution, ATI Mobility Radeon M6 w/8 MB VRAM,
RAM (2x256) 512 MB and 16 GB Compact flash (Pretec 433x) IDE  (replacement for original 20 GB ATA HDD)


This machine is known to boot only via a CD/DVDROM drive connected to its i.LINK (IEEE1394) terminal S400(four pin) and internal drive (as well as via network). USB flash/CD ROM drives do not work. There is no BIOS setting to make them work.

Any way, I am currently running CTKArch without issues on this machine but is slow, So I decided I should try TCplus.

Burned the TCplus ISO onto a CD and tested it on my Thinkpad T60p and it booted up without issues. But on my PCG U3 it gets me to a log in prompt "tc@box:~$".

I cannot get into Tiny X GUI.

I have already tried the suggestions here /tinycorelinux.net/faq.html#xsetup and a few other boot codes (e.g. tinycore waitsub=20). Nothing has resolved this issue.

Please help me resolve this issue. I am relatively new to Linux so I expect that with some initial some spoon feeding I should be able to resolve this issue.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
If the cd drive is indeed connected via Firewire, it's a case of TC not being able to access it, to load the X extensions. The firewire support is in an extension, but I'm not sure a CD drive would be supported even with it.

A recommended path would be to install to the CF card on another computer and plug it in, avoiding the cd issue.
The only barriers that can stop you are the ones you create yourself.

Offline jam_27

  • WikiUser
  • *
  • Posts: 4
Ok, some more info. I just tried the same CD on my thinkpad 600X and it resulted in the same "tc@box:~$" prompt.  So, may be the issue is with older hardware as the same CD works (boots to X) fine on my Thinkpad T60P and my Panasonic SX2.

Anyway,

While I await a less mechanical (disassembly) solution I can try to use my PCMCIA to CF card adapter on my Thinkpad T60P and install TC on it. Will this work? Please advice.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
Yes, it will work. But double-check you install to the correct drive.
The only barriers that can stop you are the ones you create yourself.

Offline jam_27

  • WikiUser
  • *
  • Posts: 4
Hmm, I am a little reluctant to take my CF card out from my VAIO at this moment as my old Thinkpad 600X (runs XP currenly) gave me the same prompt on TC bootup. Its likely to be a old hw issue.
While I decide about the disassembly, do I need to keep anything specific in mind when installing TC on a USB connected drive (CF in my case)?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10289
Your thinkpad very likely has a different issue - the base image contains no Firewire drivers.
The only barriers that can stop you are the ones you create yourself.

Offline jam_27

  • WikiUser
  • *
  • Posts: 4
Installed using CorePlus 4.7.7 core2usb v1.6 on the CF card (via a usb card reader) after formatting it FAT 32. Still the same result on boot- stuck on tc@box:~$.  Please advice.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
What do you have "onboot"?