WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: HD44780 display does not work (GPIO question)  (Read 2154 times)

Offline thomka

  • WikiUser
  • *
  • Posts: 5
HD44780 display does not work (GPIO question)
« on: February 21, 2014, 01:39:25 PM »
Hi TC Community,

Im planning to build an small and tiny streaming client on a tinycore basis. I therefore used tc and tried to attach a HD44780 based display.

I have installed python, pathon-dev and python-GPIO via tce and then I plugged in the HD44780 display ( Frizing: http://www.schnatterente.net/img/articles/raspberrypi-display/raspberry-pi-display-aufbau.png) afterwards I have used the testscript from schnatterente.net (wget http://www.schnatterente.net/code/raspberrypi/displaytest.py), but there was nothing on the display.

Do you have any idea, what I have done wrong? Is it enough to install the above mentioned packages?

thanks and best regards,
Thomas

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6430
Re: HD44780 display does not work (GPIO question)
« Reply #1 on: February 21, 2014, 02:34:18 PM »
Hi thomka
That's not much to go on. Did you get any error messages when you ran the script? What is the script supposed to display?
I don't do Python but it looks to me like that script is supposed to display 16 blank characters.

Offline thomka

  • WikiUser
  • *
  • Posts: 5
Re: HD44780 display does not work (GPIO question)
« Reply #2 on: February 22, 2014, 12:51:18 AM »
Hi Rich,

Normally the script should show the "lcd_string" messages.
I ran the script some weeks ago under raspian and it works.


No there are no error messages.

It runs for about 10 seconds and then it ends.

Br

Thomas


Sent from my iPhone using Tapatalk

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6996
    • My Community Forum
Re: HD44780 display does not work (GPIO question)
« Reply #3 on: February 22, 2014, 02:16:26 AM »
Updated python-RPi.GPIO.tcz to version 0.5.4

Are you running the script as root?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline thomka

  • WikiUser
  • *
  • Posts: 5
Re: HD44780 display does not work (GPIO question)
« Reply #4 on: February 23, 2014, 09:55:43 AM »
Hi Markus, I started it with sudo




Sent from my iPhone using Tapatalk

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6996
    • My Community Forum
Re: HD44780 display does not work (GPIO question)
« Reply #5 on: February 23, 2014, 11:07:01 AM »
Which piCore version are you using?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline thomka

  • WikiUser
  • *
  • Posts: 5
Re: HD44780 display does not work (GPIO question)
« Reply #6 on: February 24, 2014, 08:07:26 AM »
Hi Markus,

uname -a shows following:

"Linux piCorePlayer 3.12.9-piCore #1 PREEMPT Sun Feb 9 09:42:09 CET 2014 armv6l GNU/Linux"

BR,
Thomas

Offline thomka

  • WikiUser
  • *
  • Posts: 5
Re: HD44780 display does not work (GPIO question)
« Reply #7 on: February 24, 2014, 08:41:07 AM »
no changes with "python-RPi.GPIO.tcz version 0.5.4"