WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] /etc/X11/xorg.conf not available on reboot.  (Read 6850 times)

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
[SOLVED] /etc/X11/xorg.conf not available on reboot.
« on: December 06, 2008, 01:24:26 AM »
Xorg 7.4 works without any xorg.conf file but in case I generate one it is not saved and hence not available for next boot. I copied the file to /home/tc and added this line to /opt/bootlocal.sh
Quote
cp /home/tc/xorg.conf /etc/X11/xorg.conf

kagashe
« Last Edit: December 06, 2008, 06:53:02 PM by kagashe »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10273
Re: /etc/X11/xorg.conf not available on reboot.
« Reply #1 on: December 06, 2008, 01:29:46 AM »
You can tweak what is saved to your backup in /opt/.filetool.lst - it's the list of what files/directories are saved on shutdown.

Edit: see the "backup" part of getting_started.html
« Last Edit: December 06, 2008, 01:34:16 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
Re: /etc/X11/xorg.conf not available on reboot.
« Reply #2 on: December 06, 2008, 06:52:15 PM »
You can tweak what is saved to your backup in /opt/.filetool.lst - it's the list of what files/directories are saved on shutdown.

Edit: see the "backup" part of getting_started.html
I am using backup to save /home/tc and that is how a copy of xorg.conf is available on reboot. What I mean is Xorg started fresh on reboot without my xorg.conf and failed. I have added a line in /opt/bootlocal.sh to copy the file from /home/tc to /etc/X11 in addition to modprobe commands to load the modules which are not being added in my case (intel chip).

As you have written in your Xorg document that user should generate a file with "# Xorg -configure" please warn the user that any file generated as above and copied as /etc/X11/xorg.conf is not going to be available for next reboot, else, remedy the situation as I have done or by any other means.

kagashe

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #3 on: December 06, 2008, 07:04:58 PM »
You can also use the backup to restore those files upon next reboot, which is the standard method afaik.

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #4 on: December 07, 2008, 12:48:14 AM »
You can also use the backup to restore those files upon next reboot, which is the standard method afaik.
I have tried. /opt/.filetool.lst refuses to accept /etc/X11/xorg.conf file for back-up. I got errors on exit (shutdown canceled) and I had to remove the line:
/etc/X11/xorg.conf

from .filetool.lst

However, my method of keeping a copy of xorg.conf at /home/tc and putting cp command to copy it to /etc/X11 in bootlocal.sh works.

kagashe

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #5 on: December 07, 2008, 02:30:37 AM »
You probably made the mistake of placing the leading / in front, as the other entries should show I think.  Probably could be clearer on the getting started doc (if you were using that).
« Last Edit: December 07, 2008, 02:32:17 AM by ^thehatsrule^ »

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #6 on: December 07, 2008, 03:38:03 AM »
You probably made the mistake of placing the leading / in front, as the other entries should show I think.  Probably could be clearer on the getting started doc (if you were using that).
I did it from GUI Tools/Add_to_filetool which places the leading / in front.

This time once again I used GUI to insert the line, then opened it on vi and removed the leading /.

Thank you.

kagashe

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #7 on: December 07, 2008, 09:47:01 PM »
This seems to be misleading.  I tried to reproduce your steps, but found that either having the leading / in front or not doesn't matter because tar will automatically remove it.

The suggestion I gave was just something I remembered, probably from another/older version.  I have no idea why it worked for you(?).

To others: please ignore my previous post in this thread.

Offline kagashe

  • Full Member
  • ***
  • Posts: 129
    • My Tryst with Linux
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #8 on: December 10, 2008, 12:06:57 AM »
This seems to be misleading.  I tried to reproduce your steps, but found that either having the leading / in front or not doesn't matter because tar will automatically remove it.

The suggestion I gave was just something I remembered, probably from another/older version.  I have no idea why it worked for you(?).

To others: please ignore my previous post in this thread.
Yes., having a leading / does not matter but there is a problem when you reboot/shutdown with a check mark in Back up. You get following message:
Quote
Back up produced errors. Please see /tmp/backup_status. Shutdown aborted.
and the shutdown is actually aborted. File /tmp/backup_status reads:
Quote
tar: removing leading '/' from member names.
If that is supposed to mean that leading '/' gets removed from the file listed in /opt/.filetool.lst it is not REMOVED.

Finally you have to shutdown unchecking the Back up option and it is fine since in spite of leading '/' in .filetool.lst the file gets loaded on reboot.

kagashe

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: [SOLVED] /etc/X11/xorg.conf not available on reboot.
« Reply #9 on: December 10, 2008, 01:36:13 AM »
Aha, I see what the problem is now.  Thanks for replying again.

I was backing up manually without shutting down, and overlooked different scenarios.  While keeping the idea that the fix is to remove the leading /, a quick interim fix would be to change the add2file program.  For example, if modifying the .cxx, you can change line 33 to
Code: [Select]
fout << chooser.value()+1 << endl;
This brings up some problems with some scripts related to this that will be looked at.

FYI, that error in backup_status is generally a "safe-to-ignore" warning from tar and it does not mean that it modifies your .filetool.lst at all.