WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Setting keyboard layout for Xorg  (Read 3822 times)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
Setting keyboard layout for Xorg
« on: January 22, 2013, 04:05:41 AM »
If you want to change keyboard layout for Xorg in piCore, create xorg.conf file in /usr/local/share/X11 (or edit if already exists) and add a section like this:

Code: [Select]
Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbLayout" "hu"
    Option "XkbModel" "pc105"
EndSection

It is setting a Hungarian layout for a pc105 keyboard. Replace it with your own settings and add xorg.conf to backup to make it persistent.

You can put a small config file, for example mykbd.conf with the same content to /usr/local/share/X11/xorg.conf.d alternatively.

It is fixing the layout issue, but special keys and key combinations still doesn't work. It is the next step.
« Last Edit: January 22, 2013, 04:54:40 AM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9931
Re: Setting keyboard layout for Xorg
« Reply #1 on: January 22, 2013, 06:20:39 AM »
Huh, why not the standard /etc/X11 dir?
The only barriers that can stop you are the ones you create yourself.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
Re: Setting keyboard layout for Xorg
« Reply #2 on: January 22, 2013, 06:25:47 AM »
Huh, why not the standard /etc/X11 dir?

Is it matter if doesn't worK :)

Just joking. It was picked up by configure as default at compile time. Anyhow, I have to rebuild it soon.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."