WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: *SOLVED*_THX_Mplayer SCM has NO audio  (Read 2494 times)

Offline eltone

  • Full Member
  • ***
  • Posts: 137
*SOLVED*_THX_Mplayer SCM has NO audio
« on: January 18, 2013, 04:53:12 PM »
Re: TCP 4.7.3
Hi,
I thought ALSAmixer could handle mplayer SCM audio, but it must be another extension.

Which one?
Code: [Select]

tc@box:~$ sudo mplayer /home/tc/Desktop/TEST.WAV
MPlayer 1.1-4.6.1 (C) 2000-2012 MPlayer Team
192 audio & 400 video codecs

Playing /home/tc/Desktop/TEST.WAV.
libavformat version 54.6.101 (internal)
Audio only file format detected.
Load subtitles in /home/tc/Desktop/
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 16000 Hz, 2 ch, s16le, 512.0 kbit/100.00% (ratio: 64000->64000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
[AO_ALSA] alsa-lib: conf.c:4184:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
[AO_ALSA] alsa-lib: conf.c:4184:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
[AO_ALSA] alsa-lib: conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
[AO_ALSA] alsa-lib: conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
[AO_ALSA] alsa-lib: pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM default
[AO_ALSA] Playback open error: No such file or directory
[JACK] cannot open server
[AO SDL] Samplerate: 16000Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
[AO_ALSA] alsa-lib: conf.c:4184:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
[AO_ALSA] alsa-lib: conf.c:4184:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
[AO_ALSA] alsa-lib: conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
[AO_ALSA] alsa-lib: conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
[AO_ALSA] alsa-lib: pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM default
[AO SDL] Unable to open audio: No available audio device
DVB card number must be between 1 and 4
AO: [null] 16000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.0 (unknown) of 0.0 (unknown) ??,?%                                       


Exiting... (End of file)
tc@box:~$
************
eltone
« Last Edit: January 19, 2013, 07:03:58 AM by eltone »

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Mplayer SCM has NO audio
« Reply #1 on: January 18, 2013, 05:45:29 PM »
Looks like you don't have a proper alsa set up.
Have you read info file and related wiki articles?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline eltone

  • Full Member
  • ***
  • Posts: 137
SOLVED_Re: Mplayer SCM has NO audio
« Reply #2 on: January 18, 2013, 07:55:11 PM »
Hi,
'ossxmix' from CLI got audio functional.