WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: *SOLVED* WLAN Out to Lunch  (Read 14309 times)

aus9

  • Guest
Re: WLAN Out to Lunch
« Reply #30 on: January 13, 2013, 06:36:28 AM »
eltone

I wonder if we research a way forward?

1) Download CorePlus 4.7.3 check its hash with
Code: [Select]
md5sum CorePlus-4.7.3.iso
must match this page
http://tinycorelinux.net/4.x/x86/release/CorePlus-4.7.3.iso.md5.txt

2) Suggest you do not have any ethernet cable or hardware converter connected

Suggest you do not attempt in any way to configure DNS

Suggest at boot loader stage or by command such as modprobe -r.....to blacklist or remove any modules

From your previous posts, you appear to already have b43 module so try clicking on the wifi icon

I am sorry if you feel you have done this, but when I have attempted to have both ethernet and wifi I think most distros get confused
YMMV

what I am hoping is you had a bad burn, or ethernet interfered with DNS or something
as you can tell I am not an expert so feel free to ignore

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: WLAN Out to Lunch
« Reply #31 on: January 13, 2013, 11:05:28 AM »
Using multiple net interfaces is the only way I can get TCP online.  If the wifi is turned OFF, the wired connection fails and visa versa. 
That does not make any sense.
Having 2 concurrent gateways could never work, and connecting 2 interfaces to the same subnet is unlikely to work right by default.
Quote
I agree there's a bug lurking in the DNS.
Bug how? You have not provided any indication of any bug.
DNS is an issue totally independent of your routing table which is most obviously messed up.

I'd suggest you boot either with wireless on and boot code "nodhcp" or with wireless off and try to activate one interface only.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: WLAN Out to Lunch
« Reply #32 on: January 13, 2013, 07:06:24 PM »
Then your DHCP server is configured to give out your gateway address as a nameserver.  Fix your dhcp server.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: WLAN Out to Lunch
« Reply #33 on: January 13, 2013, 07:45:42 PM »
1. '/etc/resolv.conf' could not cause an internet connection to fail.
2. DNS is a totally separate subject not related to whatever discussed in this thread so far.
3. Configuration and bugs are totally different subjects.
4. If you'd use the search function of this forum, you would already have found many answers and avoided many setup issues.
e.g. http://forum.tinycorelinux.net/index.php/topic,8019.msg43028.html#msg43028
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: WLAN Out to Lunch
« Reply #34 on: January 13, 2013, 08:50:04 PM »
Not really a need for wifi to get activated at boot, but preferably unplug ethernet cable first or at least use boot code "nodhcp" to prevent possible conflicts.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: WLAN Out to Lunch
« Reply #35 on: January 13, 2013, 09:59:53 PM »
What is the preferred method to auto-start b43, at boot?

I've probably had three different sets of broadcom hardware that worked with the b43 module and firmware obtained using b43-fwcutter (my current hardware will only work with the wl module):

If the wireless-KERNEL extension is loaded at boot, the b43 module will load automatically as long as the wifi hardware switch is in the "on" position.

If your broadcom hardware requires a home-made (using b43-fwcutter) firmware extension in order to work, this extension needs to be loaded before the wireless-KERNEL extension.

So, whilst you're figuring things out, it's better not to load the wireless-KERNEL extension "onboot".

Once things are working, I believe you should be able to load your home-made firmware extension "onboot" and run the wifi script from bootlocal (which will load the wireless-KERNEL extension).
« Last Edit: January 13, 2013, 10:06:01 PM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: WLAN Out to Lunch
« Reply #36 on: January 21, 2013, 01:12:02 AM »
Assuming your wifi is enabled in hardware, if you do this:
Code: [Select]
$ tce-load -i wireless-KERNEL
$ lsmod
..has the b43 module been loaded automatically?

Does you hardware need firmware loaded to work?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: WLAN Out to Lunch
« Reply #37 on: January 22, 2013, 07:22:03 PM »
I cannot comment on 'tce-load', since man pages has no coverage of it.

"tce-load" is the tinycore command for loading extensions...