WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: *SOLVED* WLAN Out to Lunch  (Read 14323 times)

Offline eltone

  • Full Member
  • ***
  • Posts: 137
*SOLVED* WLAN Out to Lunch
« on: January 07, 2013, 12:10:15 PM »
Re: WLAN Out to Lunch
1) CorePlus-4.7.3.iso
2) hp dv8000
3) Wireless Chip Set: Broadcom Corporataion BCM4318 [AirForcce One 54g] 802.11g

Hi,
CorePlus-4.7.3 booted from LiveUSB, on hp laptop referenced above,  but cannot find wifi OoTB!
The b43 firmware cutter appears to be bundled with ISO.  What is the correct way to install the b43 wifi driver?
Regards,
eltone

$ sudo lspci -v

   

06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
   Subsystem: Hewlett-Packard Company Broadcom 802.11b/g WLAN
   Flags: bus master, fast devsel, latency 64, IRQ 21
   Memory at c0204000 (32-bit, non-prefetchable) [size=8K]
   Kernel driver in use: b43-pci-bridge
   Kernel modules: ssb

$

***************************


« Last Edit: January 22, 2014, 09:23:04 PM by eltone »

aus9

  • Guest
Re: WLAN Out to Lunch
« Reply #1 on: January 07, 2013, 03:49:55 PM »
eltone

welcome to TinyCore. I am not an expert and used wired but did try the coreplus on a neighbour who had broadcom

assuming you chose the top menu item to boot and click on the wifi icon and it said no wireless devices found try this

open a terminal and run

Code: [Select]
lsmod | grep b43
---if no list found then try
sudo modprobe b43
(and repeat lsmod command to see new list as per image)

then retry the wifi wbar icon

good luck

EDIT
it looks like the 4318 is ok by this link
http://linuxwireless.org/en/users/Drivers/b43
« Last Edit: January 07, 2013, 03:56:04 PM by aus9 »

aus9

  • Guest
Re: WLAN Out to Lunch
« Reply #2 on: January 07, 2013, 05:45:32 PM »
I am not an expert, but I can remember I never touched the network panel

until you get a better reply try again and don't touch network
IMHO the wireless must be detected then choose an network then input the WPA2 or whatever security you have
--then you have a network

I will have to slink away as am not an expert
good luck

Offline genec

  • Full Member
  • ***
  • Posts: 240

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6955
Re: WLAN Out to Lunch
« Reply #4 on: January 08, 2013, 06:54:19 AM »
Hi eltone
Quote
tinycore blacklist=bcma
tinycore blacklist=wl
I don't know if  tinycore  is still recognized. Hit F2 before entering the bootcodes for the correct options. I think
they are   plus   tc   mc. You want   plus   and it only needs to be entered once as the first item.
You can blacklist multiple items like this:
Code: [Select]
blacklist=bcma,wl

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6955
Re: WLAN Out to Lunch
« Reply #5 on: January 08, 2013, 07:26:16 AM »
Hi eltone
Are you booting from a CD? If so, it must pause somewhere to give you some options. Or did you install to a
hard drive?

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: WLAN Out to Lunch
« Reply #6 on: January 08, 2013, 04:06:35 PM »
Keys in FAQ are specific to .iso bootloader configuration.
You can either configure your current bootloader or just boot from cd again ;)
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6955
Re: WLAN Out to Lunch
« Reply #7 on: January 08, 2013, 05:13:18 PM »
Hi eltone
Boot the thumb drive. Open a terminal and enter:
Code: [Select]
sudo editorClick File->Open  and navigate to  /mnt/sda1  assuming your thumb drive is sda1
You are looking for  extlinux.conf. If you don't see an  extlinux  directory, check under boot for it.
Open the  extlinux.conf  file and append:
Code: [Select]
blacklist=bcma,wlto the end of the line with the word  quiet  in it. Save and reboot.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: WLAN Out to Lunch
« Reply #8 on: January 08, 2013, 05:30:57 PM »
Q: Can the thumb drive be formatted to FAT32 instead of EXT4?
Assume "tc-install" 'vfat' formatting option is FAT32??

Yes and yes; though vfat could potentially be FAT16 if the partition would be really small.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11098
Re: WLAN Out to Lunch
« Reply #9 on: January 08, 2013, 11:01:04 PM »
Maybe I'm missing something here, but for me:

The wl module comes from the wl-modules-3.0.21-tinycore extension, which you don't need to load unless you're planning on using the broadcom driver.

If you don't load wl-modules-3.0.21-tinycore, then you don't need blacklist=wl (and in any case it will not automagically load itself)

If you use the b43 driver, then I don't believe you need to blacklist anything - since it is an in-kernel driver, it will behave properly with the bcma and ssb modules.
« Last Edit: January 08, 2013, 11:03:21 PM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11098
Re: WLAN Out to Lunch
« Reply #10 on: January 09, 2013, 07:25:09 PM »
Could there be a missing extension, for b43 to hiccup this way?

Not so much a missing extension, but you probably need the appropriate broadcom firmware for your hardware to work, see:

http://linuxwireless.org/en/users/Drivers/b43

Quote
The Broadcom wireless chip needs proprietary software (called "firmware") that runs on the wireless chip itself to work properly. This firmware is copyrighted by Broadcom and must be extracted from Broadcom's proprietary drivers. To get such firmware on your system, you must download the driver from a legal distribution point, extract it, and install it. This is accomplished different ways by different Linux distributions, so please read the section for yours for the best results. You will need an alternate working internet connection (by Ethernet cable, for example) since the firmware cannot be included with the distro itself.

Quote
Other distributions not mentioned above

Note: You need to have a compiler and headers for libc installed, since you will have to build fwcutter from source
...continue reading from here

and

http://wiki.tinycorelinux.net/wiki:list_of_supported_wifi_devices
« Last Edit: January 09, 2013, 10:32:25 PM by Juanito »

Offline genec

  • Full Member
  • ***
  • Posts: 240
Re: WLAN Out to Lunch
« Reply #11 on: January 09, 2013, 07:31:40 PM »
I would have sworn I had a 4318 in something, b43 loaded fine but the wifi was deaf.  Once I blacklisted the other 3 components and loaded the appropriate extensions, wl solved my issue.  I'll need to check what card was in the machine.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11098
Re: WLAN Out to Lunch
« Reply #12 on: January 09, 2013, 07:33:13 PM »
Can RF-kill be the root problem?

You could maybe double-check that your wifi hardware and software (bios) switches are on.

aus9

  • Guest
Re: WLAN Out to Lunch
« Reply #13 on: January 09, 2013, 10:21:49 PM »
it me lurking away

eltone pls ensure that you have completely shutdown windows before booting into linux so that you avoid this scenario
paraphrased....windows locks the wifi device in hibernation etc
source
http://linux.bigresource.com/Ubuntu-Networking-unable-to-turn-wifi-on-after-windows-hibernate-h121tlrfb.html

If I am right, boot back into windows, go into control panel and check that pushing the power button truly shuts down MS
then shutdown then try Linux....I am not an expert in MS so I am hoping its the power management icon in MS

good luck

Offline eltone

  • Full Member
  • ***
  • Posts: 137
Re: WLAN Out to Lunch
« Reply #14 on: January 10, 2013, 09:15:51 PM »

The b43 maintainer says this driver supports these chipsets:
1) 2) BCM4306/3
3) BCM4311
4) BCM4312
5) BCM4318
« Last Edit: February 10, 2014, 09:34:14 PM by eltone »