WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tinycore_1.0rc3  (Read 3865 times)

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
tinycore_1.0rc3
« on: December 05, 2008, 06:30:44 PM »
Release Candidate 3 is now posted.

A few bugs fixed and some cleanup.

* Updated demod (patched for better support of symlinks)
* Fixed appbrowser no selection segfault
* Fixed invalid path for crond in tc-config
* Removed root/.ash_history relic
* Removed unusable function in tc-functions

Thanks for the release candidate testing, feedback, suggestions, and submissions.
10+ Years Contributing to Linux Open Source Projects.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10064
Re: tinycore_1.0rc3
« Reply #1 on: December 06, 2008, 12:25:32 AM »
After reading up on both udevstart's and udevtrigger's sources, I think using udevstart is why we don't have as good netcard detection as we should. Udevstart seems to only create needed devices, without also doing the triggering udevtrigger does. The fact most distributions use udevtrigger to create devices and coldplug also speaks for this.

I suggest replacing the call in tc-config to udevstart with udevtrigger. Same path, no options, still backgrounded. Once it works as well / better, udevstart can then be removed later on.

Also, a similar backgrounded call to udevtrigger should probably be added to the laptop block, right before the echo line, to scan for pcmcia cards and load their modules.
The only barriers that can stop you are the ones you create yourself.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: tinycore_1.0rc3
« Reply #2 on: December 06, 2008, 09:30:35 AM »
Thanks, curaga. I have in there for the next cut.
10+ Years Contributing to Linux Open Source Projects.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: tinycore_1.0rc3
« Reply #3 on: December 07, 2008, 01:42:07 AM »
alsa-modules.tczm is still no-go - not a big deal I think, only required if a sound card doesn't work with oss or for bt headsets

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9667
Re: tinycore_1.0rc3
« Reply #4 on: December 07, 2008, 04:59:19 AM »
Not to get too far off topic, I was also trying to find a way for alsa to work with symlinked  kernel modules, or with real modules installed in /usr/local/lib/modules/'uname -r'.  Either method is not liked by alsaconf.  But that is the only set of kernel modules that does not work with both those methods.  OSS seems happy either way, though you have to adjust the paths in soundon to use modules installed in /usr/local.  There is something coded in alsaconf that uses the full path to modules or uses a test for the modules existing as in /lib/modules as an ELF.  I haven't seen it, but it must be there as the alsa modules can be modprobed with the above approaches.   I am still curious and will look more at it when I have time.

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: tinycore_1.0rc3
« Reply #5 on: December 07, 2008, 09:54:14 PM »
Confirmed invalid $LANG env var setting by default: LANG=en but `locale -a` only shows C and POSIX

Reference thread: http://forum.tinycorelinux.net/index.php?topic=165.0

Possible fix: edit /etc/sysconfig/language and change contents to LANG=C

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: tinycore_1.0rc3
« Reply #6 on: December 07, 2008, 11:52:15 PM »
It is actually being defaulted to "en" in tc-config. But good find. Will fix it.
10+ Years Contributing to Linux Open Source Projects.