WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: WiFi stack added  (Read 118152 times)

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: WiFi stack added
« Reply #15 on: January 24, 2013, 02:43:37 PM »
As it happens I was testing on wifi.sh for the allwinner port and therefore I added a couple of timimg loops for the slower arm devices.  wifi.tcz updated and posted in the repo.
10+ Years Contributing to Linux Open Source Projects.

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 182
Re: WiFi stack added
« Reply #16 on: January 25, 2013, 02:17:25 AM »
Hi Roberts,

 Sorry, I'm new at this, I was trying to contribute to the good cause. I will check out the update. Thank you for your work!

Greetings,

   Gerrelt.
my Raspberry Pi page: http://raspberry.gerrelt.nl

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 182
Re: WiFi stack added
« Reply #17 on: January 27, 2013, 11:41:33 AM »
Hi Roberts,

I've just installed piCore 4.7.4 and the new wifi.sh. It's working great! It now always finds the wifi access points on the first try.
The automatic connect with -a seems to work better too.
I've peeked in the wifi.sh file, and saw your loop. A lot nicer then mine!  :)

Thank you for your work.

Greetings,
    Gerrelt.
my Raspberry Pi page: http://raspberry.gerrelt.nl

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: WiFi stack added
« Reply #18 on: January 27, 2013, 03:50:50 PM »
Hi Gerrelt

Glad to hear it is working. The pi is a bit slower than other devices that have been using wifi.sh.
I actually added two loops on for the device creation and one for scan results. Neither of these
loops should cost faster platforms. So it is an enhancement that is well worth the effort. I was actually
previewing wifi.sh for my recent Allwinner wifi README when you posted. In the end all is well.
10+ Years Contributing to Linux Open Source Projects.

Offline Cloudcentric

  • WikiUser
  • *
  • Posts: 15
Re: WiFi stack added
« Reply #19 on: February 01, 2013, 01:49:57 AM »

Hi.  Just undertook a fresh install of piCore4.7.4 and the Wireless Tool works as expected now, thank you

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: WiFi stack added
« Reply #20 on: February 05, 2013, 11:33:43 AM »
Hi I also got the WiFi to work on the raspberry.

However, I have the problem that the sound from the raspberry is breaking up after 30 - 60 sec. Sometimes it plays very slow, at other times it is just bad.

I have increased the clock from 700 to 850 MhZ, it has helped a little. But somehow it seem like the WiFi is too heavy for the Raspberry. If using a LAN cable, ther is no problem.

The sound is equally bad via the 3.5" audio jack and a extern USB DAC.

Is it possible to debug this problem?

The wifi adaptor is a Comfast 150 Mbps nano adaptor build on REALTEK RTL8188CUS chip. USB 2.0 Hi-Speed connector.

Thanks
Steen

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7179
    • My Community Forum
Re: WiFi stack added
« Reply #21 on: February 05, 2013, 01:16:05 PM »
Did you try it on Raspbian?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline Cloudcentric

  • WikiUser
  • *
  • Posts: 15
Re: WiFi stack added
« Reply #22 on: February 05, 2013, 03:36:10 PM »

I always use a USB Mains Powered Hub for peripherals, the USB is known to be flakey if overloaded...............

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7179
    • My Community Forum
Re: WiFi stack added
« Reply #23 on: February 06, 2013, 12:03:17 AM »
The wifi adaptor is a Comfast 150 Mbps nano adaptor build on REALTEK RTL8188CUS chip. USB 2.0 Hi-Speed connector.


It is not listed as compatible device:

http://elinux.org/RPi_VerifiedPeripherals#USB_Wi-Fi_Adapters

Can be a power issue. Try one from the list.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: WiFi stack added
« Reply #24 on: February 06, 2013, 12:37:54 PM »
Thanks I will try your suggestions.

I just noticed that there is a lot of dropped RX packages:

wlan0     Link encap:Ethernet  HWaddr 00:0F:12:82:13:1F
          inet addr:192.168.1.25  Bcast:255.255.255.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:972254 errors:0 dropped:1159824 overruns:0 frame:0
          TX packets:395648 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1465638498 (1.3 GiB)  TX bytes:39812520 (37.9 MiB)

What can be the reason for that?

bmarcus: I think it is supported, from the page you linked to I found my card:
Comfast
WU710N: chipset RTL8188CUS. The rtl8192cu kernel driver is loaded automatically in the latest Raspian distribution.

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 182
Re: WiFi stack added
« Reply #25 on: February 06, 2013, 01:06:29 PM »
I also use a RTL8188CUS based wifi dongle. It works pretty good on Raspbian Wheezy, not perfect, but pretty good.

But I still have problems with it on TinyCore. Connecting seems sometimes slow, ie it takes a while before it gets an IP address. And sometimes it will get an IP address, but I can't ping it from my PC. Strange.
And sometimes it just works fine, it's a bit intermittent.

@Roberts: I've been playing around with the udhcpc command. It seems that the -b command option works better then the -n option.
The -n option gives up after a few tries, and then quits, if it doesn't get a wifi connection. The -b option forks the udhcpc process and keeps on trying to connect in the background. This seems to work better on our "slow" raspberry devices.

Another thing I found usefull is the "-x hostname:" option. With that option I can set the hostname that will appear on the DHCP client list on my routers managament webpage.
my Raspberry Pi page: http://raspberry.gerrelt.nl

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7179
    • My Community Forum
Re: WiFi stack added
« Reply #26 on: February 06, 2013, 02:25:50 PM »
I also use a RTL8188CUS based wifi dongle. It works pretty good on Raspbian Wheezy, not perfect, but pretty good.

But I still have problems with it on TinyCore. Connecting seems sometimes slow, ie it takes a while before it gets an IP address. And sometimes it will get an IP address, but I can't ping it from my PC. Strange.
And sometimes it just works fine, it's a bit intermittent.


Is it an open network or WPA? Just to identify wether it is a wpasupplicant error or not.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: WiFi stack added
« Reply #27 on: February 06, 2013, 11:22:07 PM »
Hi. For me it is on a WPA protected network.

I could try remove the protection.

Steen

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: WiFi stack added
« Reply #28 on: February 07, 2013, 02:34:47 AM »
As long as you observe a high rate of dropped packages, it might be a good idea to leave protection out of the equation entirely.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Gerrelt

  • Full Member
  • ***
  • Posts: 182
Re: WiFi stack added
« Reply #29 on: February 10, 2013, 02:14:57 AM »
Is it an open network or WPA? Just to identify wether it is a wpasupplicant error or not.

It's WPA. And I created a custom wpa_supplicant.conf file, this one:

Code: [Select]
tc@cherry:/opt$ cat wpa_supplicant.conf
network={
proto=RSN
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
ssid="SeinfeldsHouse"
psk="youdontdoubledip"
}

And these are the commands I am executing:

Code: [Select]
wpa_supplicant -B -Dwext -i wlan0 -c /opt/wpa_supplicant.conf
/sbin/udhcpc -b -i wlan0 -x hostname:cherry

This morning I started the cherry raspberry and it worked in 1 one try again..  ???
Maybe my router is a bit buggy, I've got a hunch it's got something to do with IP lease times.
Resetting my router fixes the connection problem, normally.

edit: I've got some dropped packages too:

Code: [Select]
wlan0     Link encap:Ethernet  HWaddr 00:9E:95:90:5A:75
          inet addr:192.168.0.108  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:598 errors:0 dropped:617 overruns:0 frame:0
          TX packets:303 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:109432 (106.8 KiB)  TX bytes:46935 (45.8 KiB)

617 packages in about 10 minutes, is that a lot?
« Last Edit: February 10, 2013, 02:18:48 AM by Gerrelt »
my Raspberry Pi page: http://raspberry.gerrelt.nl