WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xfbdev  (Read 11509 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: Xfbdev
« Reply #15 on: January 27, 2013, 09:01:22 PM »
As said above, I believe @coreplayer2 has Xfbdev working with an hd4000, but there is corruption when dragging a window right.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2532
Re: Xfbdev
« Reply #16 on: January 30, 2013, 02:52:10 PM »
Xfbdev working great now on Intel HD Graphics 4000  [8086:0166] (rev 09)  (Mac mini, late 2012)

The previous Xfbdev version exhibited video corruption when dragging a window from right to left.   

The latest Xfbdev (thanks juanito) md5 8e44ad536eda290142caa2d6e7d6b373  works great with flwm and flwm_topside    Also the speed of window movement is not impaired any.
« Last Edit: January 30, 2013, 03:00:33 PM by coreplayer2 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: Xfbdev
« Reply #17 on: January 31, 2013, 11:17:22 PM »
posted - thanks for testing  :)

Offline sebus

  • Jr. Member
  • **
  • Posts: 96
Re: Xfbdev
« Reply #18 on: February 10, 2013, 07:20:16 AM »
Have my Hitachi 4Gb Micro Drive in USB reader with Pure64 with xorg7.6 and xf86-video-all

That was working perfectly fine on AMD machine with nVidia GS8400 graphics

And now it is working perfectly on Gigabyte GA-Z77N-Wifi board & i3 3225 with Intel HD 4000 with full HD resolution via HDMI
No issue of any kind with no windows corruption etc

sebus

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2532
Re: Xfbdev
« Reply #19 on: February 15, 2013, 07:37:41 PM »
Looks like the patch fixed that video corruption permanently   thanks  :)

Offline sebus

  • Jr. Member
  • **
  • Posts: 96
Re: Xfbdev
« Reply #20 on: February 16, 2013, 10:29:52 AM »
I suppose the thanks for to Juanito (as I do not use Xfbdev  at all)

Offline polikuo

  • Full Member
  • ***
  • Posts: 245
Re: Xfbdev
« Reply #21 on: February 20, 2017, 01:24:01 AM »
It seems that the latest firefox (51.0.1) doesn't work well with the Xfbdev server.
Every button on the toolbar is unclickable.
Firefox works well under Xorg, not sure about Xvesa.
Any idea ? ???

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: Xfbdev
« Reply #22 on: February 20, 2017, 01:30:33 AM »
If you start firefox from a terminal window, do you see any error messages?

Anything in dmesg or syslog or /tmp/wm_errors?

Offline polikuo

  • Full Member
  • ***
  • Posts: 245
Re: Xfbdev
« Reply #23 on: February 20, 2017, 01:40:53 AM »
If you start firefox from a terminal window, do you see any error messages?

Anything in dmesg or syslog or /tmp/wm_errors?

Terminal output:
Code: [Select]
Xlib:  extension "XInputExtension" missing on display ":0.0".
(firefox:2841): Gtk-WARNING **: Error loading theme icon 'dialog-information' for stock: Icon 'dialog-information' not present in theme Adwaita

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'edit-copy' for stock: Icon 'edit-copy' not present in theme Adwaita

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'media-playback-start' for stock:

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'media-playback-pause' for stock: Icon 'media-playback-pause' not present in theme Adwaita

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'edit-undo' for stock:

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'edit-cut' for stock: Icon 'edit-cut' not present in theme Adwaita

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'edit-paste' for stock: Icon 'edit-paste' not present in theme Adwaita

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'edit-delete' for stock: Icon 'edit-delete' not present in theme Adwaita

(firefox:2841): Gtk-WARNING **: Error loading theme icon 'edit-select-all' for stock: Icon 'edit-select-all' not present in theme Adwaita

dmesg output:
Code: [Select]
Chrome_ChildThr[2801]: segfault at 0 ip 000000000040730b sp 00007f40395fe340 error 6 in plugin-container[400000+60000]

/tmp/wm_errors, nothing at all.
« Last Edit: February 20, 2017, 01:49:03 AM by polikuo »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: Xfbdev
« Reply #24 on: February 20, 2017, 03:33:03 AM »
Is the libXi (or possibly libinput) extension loaded?

You can get rid of several of the other warnings by loading the adwaita-icon-theme extension.

Offline polikuo

  • Full Member
  • ***
  • Posts: 245
Re: Xfbdev
« Reply #25 on: February 20, 2017, 05:25:12 AM »
Is the libXi (or possibly libinput) extension loaded?

You can get rid of several of the other warnings by loading the adwaita-icon-theme extension.

After some testing, I found out that:
1. "adwaita-icon-theme" is unnecessary for the toolbar buttons to work, it's not a part of the dep of Xorg-7.7
2. It doesn't look like a case of missing dependencies
3. Running firefox under Xorg-7.7 also gets the same warning

Code: [Select]
### boot code "base"
tce-load -i aterm wbar Xlibs Xfbdev Xprogs firefox flwm_topside
startx
### buttons unclickable ...
tce-load -i Xorg-7.7
### with Xfbdev still running, unclickable ...
kill `cat /tmp/.X0-lock`
startx
### buttons become functional while the terminal output remains the same.

Edit:
It may have something to do with gtk3

firefox-ESR (45.6.0) has the dep with gtk2 and the toolbar works just fine.

However, running firefox (51.0.1) with both gtk2 and gtk3 under Xfbdev doesn't help.
« Last Edit: February 20, 2017, 05:55:44 AM by polikuo »

Offline Scampada

  • Full Member
  • ***
  • Posts: 164
Re: Xfbdev
« Reply #26 on: March 13, 2017, 09:45:14 AM »
Hi,

where can I ever find source project for Xfbdev??
I tried google as usual 'Xfbdev source download' expecting for sourceforge or github links but, no thing!
The winning entries in UNIX users' hymns competition were 'What's the buzz, tell me what's happening' and 'Strange Thing Mystifying' songs from A.L.Webber's musical.

Tiny Core Linux. Like Gentoo, except Gentoo is easier.

Offline Scampada

  • Full Member
  • ***
  • Posts: 164
Re: Xfbdev
« Reply #27 on: March 13, 2017, 09:47:02 AM »
Looks like it's GLX disabled in the default TC Xfbdev package. I can't run applications requiring GLX, (and in Xorg they're not working too, strange... But this is off topic)
The winning entries in UNIX users' hymns competition were 'What's the buzz, tell me what's happening' and 'Strange Thing Mystifying' songs from A.L.Webber's musical.

Tiny Core Linux. Like Gentoo, except Gentoo is easier.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9612
Re: Xfbdev
« Reply #28 on: March 13, 2017, 09:48:01 AM »
https://github.com/tinycorelinux/tinyx

GLX cannot be enabled in the tiny X servers at all.
The only barriers that can stop you are the ones you create yourself.

Offline Scampada

  • Full Member
  • ***
  • Posts: 164
Re: Xfbdev
« Reply #29 on: March 13, 2017, 10:13:15 AM »
I knew it. I traced the game process and found it that the application was sending GLX requests to X socket then X returned "No GLX here bro". I also found out that TinyX doesn't support GLX at all. Yet just few moments ago I viewed this in my Google output and hoped for best...



PS Do you know other lightweight alternate X server which does support GLX and synaptics but doesn't clutter with unnecessary dependencies? Is it Wayland or something? ???
The winning entries in UNIX users' hymns competition were 'What's the buzz, tell me what's happening' and 'Strange Thing Mystifying' songs from A.L.Webber's musical.

Tiny Core Linux. Like Gentoo, except Gentoo is easier.