WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Caps Lock issue  (Read 5294 times)

Offline fuegos

  • WikiUser
  • *
  • Posts: 24
Caps Lock issue
« on: November 05, 2012, 08:14:45 AM »
Hello,

I have successfully installed and configured 3.8.4 on HP t5520. It works much better than original windows ce. I only got one small issue with Caps Lock - I have to press button 3 times to switch it off. System runs Xvesa-7.1 (nozap) and uk.kmap... Can anyone please help?

Many thanks

« Last Edit: November 07, 2012, 03:52:13 AM by fuegos »

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Caps Lock issue
« Reply #1 on: November 05, 2012, 08:25:04 AM »
I have noted that same behaviour since at least 2.x.
IIRC the other Xvesa extension may not produce such.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline fuegos

  • WikiUser
  • *
  • Posts: 24
Re: Caps Lock issue
« Reply #2 on: November 06, 2012, 12:58:15 AM »
The only reason i went for Xorg's Xvesa is nozap working flawlessly. Ctrl+Alt+Del killing X is just gruesome for all users remoting to Windows (task manager funcionality is essential in their jobs). Where can i find other working Xvesa's or old version of Xorg? There is nothing i could find in the App Browser...  I only need nozap and proper keyboard handling... Thanks.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Caps Lock issue
« Reply #3 on: November 06, 2012, 08:24:26 AM »
Xvesa.tcz ?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline althalus

  • Sr. Member
  • ****
  • Posts: 351
Re: Caps Lock issue
« Reply #4 on: November 06, 2012, 03:33:38 PM »
The only reason i went for Xorg's Xvesa is nozap working flawlessly. Ctrl+Alt+Del killing X is just gruesome for all users remoting to Windows (task manager funcionality is essential in their jobs). Where can i find other working Xvesa's or old version of Xorg? There is nothing i could find in the App Browser...  I only need nozap and proper keyboard handling... Thanks.

Sort of related, but I always thought ctrl+alt+backspace killed X, not ctrl+alt+delete?

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6897
Re: Caps Lock issue
« Reply #5 on: November 06, 2012, 05:55:35 PM »
Hi althalus
Quote
but I always thought ctrl+alt+backspace killed X
That is correct.
Quote
not ctrl+alt+delete?
If I read  /etc/inittab  correctly, that should execute  /sbin/reboot

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Caps Lock issue
« Reply #6 on: November 06, 2012, 09:15:15 PM »
One way to find out... :P
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline fuegos

  • WikiUser
  • *
  • Posts: 24
Re: Caps Lock issue
« Reply #7 on: November 07, 2012, 03:39:56 AM »
Xvesa.tcz ?

 I have tried Xvesa.tcz but used together with -nozap will not load X (cursor blinks for some time, then returns to shell). I found it working only with Xvesa-7.1.tcz but then again there is a Capslock problem...


Hi althalus
Quote
but I always thought ctrl+alt+backspace killed X
That is correct.
Quote
not ctrl+alt+delete?
If I read  /etc/inittab  correctly, that should execute  /sbin/reboot


In my case both ctrl+alt+del and ctrl+alt+backspace kill X, although pressing ctrl+alt+del twice reboots the system.
« Last Edit: November 07, 2012, 03:50:29 AM by fuegos »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Caps Lock issue
« Reply #8 on: November 07, 2012, 08:20:19 AM »
really?  that's interesting,  so I just ran around several pc's running tc with Xorg-7.6.tcz.   Seems as if ctrl+alt+del is functional up to text mode, however once X is running ctrl+alt+del is disabled ?? (grep reports an addition busybox key combination fwiw)  Maybe it's the kernel, or busybox but so far (maybe X version dependent?) ctrl+alt+del has not initiated a reboot once fully booted to an X desktop.


ctrl+alt+backspace terminates X while
ctrl+alt+F1 returns to text mode and
ctrl+alt+F2 restores X    (perhaps not technically the correct phrases)

AIUI  you have the ability to set no zap in the xorg.conf file, you'll still have the magic Sysrq keys - REISUB, these apparently can also be disabled


Anyhow,  the magic key combination " Alt+SysRq+B " will reboot the linux machine and according to the wiki so will " echo b > /proc/sysrq-trigger "

Isn't the Cap's Lock a BIOS issue ?

« Last Edit: November 07, 2012, 09:12:06 AM by coreplayer2 »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10048
Re: Caps Lock issue
« Reply #9 on: November 07, 2012, 09:31:32 AM »
Did you try Xorg with nozap configured (in xorg.conf)?
The only barriers that can stop you are the ones you create yourself.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Caps Lock issue
« Reply #10 on: November 07, 2012, 07:31:18 PM »
An alternative approach would be to remap the capslock key out of reach ;)
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline fuegos

  • WikiUser
  • *
  • Posts: 24
Re: Caps Lock issue
« Reply #11 on: November 08, 2012, 12:39:10 AM »
I'm loading Xorg-7.5.tcz right now to test. Disk space available on thin client is limited to 64MB so i have to be very careful with the software i install. I'll post a follow up when tested. Cheers.

Offline fuegos

  • WikiUser
  • *
  • Posts: 24
Re: Caps Lock issue
« Reply #12 on: November 08, 2012, 03:56:27 AM »
CapsLock and nozap works as it should now. Another issue is the screen resolution i can't change! I have followed all steps from http://wiki.tinycorelinux.net/wiki:using_xorg_over_xvesa but it seems to be stuck in 800x600. Also keyboard layout remains us when i set it to gb... Any clues guys?
« Last Edit: November 08, 2012, 04:11:44 AM by fuegos »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11064
Re: Caps Lock issue
« Reply #13 on: November 08, 2012, 04:01:25 AM »
it would make it easier to help if you could post the relevant part of your /etc/X11/xorg.conf

Offline fuegos

  • WikiUser
  • *
  • Posts: 24
Re: Caps Lock issue
« Reply #14 on: November 08, 2012, 05:39:50 AM »
it would make it easier to help if you could post the relevant part of your /etc/X11/xorg.conf

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/X11/modules"
   FontPath     "/usr/local/lib/X11/fonts/misc/"
   FontPath     "/usr/local/lib/X11/fonts/TTF/"
   FontPath     "/usr/local/lib/X11/fonts/OTF"
   FontPath     "/usr/local/lib/X11/fonts/Type1/"
   FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
   Load  "dri"
   Load  "extmod"
   Load  "dbe"
   Load  "freetype"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option "XkbLayout" "gb"
   Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   Option       "DPMS"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "vesa"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 10

   SubSection "Display"
      Viewport   0 0
      Depth     16
      Modes "1280x1024_60.00"
   EndSubSection
EndSection


I couldn't save that file in /etc/x11 as it was keep disappearing after reboot so i have placed it in /home/tc instead and changed the path in /opt/.filetool.lst respectively. Am i doing something wrong saving files in /etc folder?