WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2  (Read 1844 times)

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Code: [Select]
tc@box:~$ version
4.7rc3
after updating of glib2.tcz, glib2-locale.tcz, libxml2.tcz
and also Xprogs.tcz from release candidat area i got following problems

scripts not loaded from ~/.X.d and seems causes mass warnings on boot screen
Code: [Select]
sh: can't open /dev/tty: No such device or address after switch to first screen by ctrl+alt+f1 i see full screen filled by this warnings

after loading lxde there are no shortcuts icons on desktop, quick start in taskbar and in context menus
mouse cursor looks like cross or even absent, wbar crashes after first program launch

i also tryed booting with norestore bootcode but it works similarly but of course without above warnings
« Last Edit: October 22, 2012, 09:54:02 AM by AbNoRMiS »
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6995
    • My Community Forum
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #1 on: October 22, 2012, 10:56:37 AM »
Installed LXDE2 clean on TC, works fine as expected with the updated components in the repo.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #2 on: October 22, 2012, 01:09:29 PM »
i can't quite understand how it could happen but all following binaries and libraries suddenly lost liblzma.so.5
although before that all applications such as galculator, gsmartcontrol, hardinfo, inkscape, netsurf-gtk, osmo,
remmina, virtualbox-ose worked for me
btw dependencies of lxde2 and pcmanfm2 also listed among following
Code: [Select]
tc@box:~$ for i in /usr/local/bin/*; do ldd $i 2>/dev/null | grep -q found && echo $i && ldd $i | grep found; done
/usr/local/bin/csslint-0.6
liblzma.so.5 => not found
/usr/local/bin/gsf
liblzma.so.5 => not found
/usr/local/bin/gsf-office-thumbnailer
liblzma.so.5 => not found
/usr/local/bin/gsf-vba-dump
liblzma.so.5 => not found
/usr/local/bin/msgmerge
libgomp.so.1 => not found
/usr/local/bin/netsurf-gtk
liblzma.so.5 => not found
/usr/local/bin/obconf
liblzma.so.5 => not found
/usr/local/bin/openbox
liblzma.so.5 => not found
/usr/local/bin/rsvg-convert
liblzma.so.5 => not found
/usr/local/bin/rsvg-view
liblzma.so.5 => not found
/usr/local/bin/update-mime-database
liblzma.so.5 => not found
/usr/local/bin/xsltproc
liblzma.so.5 => not found
Code: [Select]
tc@box:~$ for i in /usr/local/lib/*; do ldd $i 2>/dev/null | grep -q found && echo $i && ldd $i | grep found; done
/usr/local/lib/libcroco-0.6.so
liblzma.so.5 => not found
/usr/local/lib/libcroco-0.6.so.3
liblzma.so.5 => not found
/usr/local/lib/libcroco-0.6.so.3.0.1
liblzma.so.5 => not found
/usr/local/lib/libexslt.so
liblzma.so.5 => not found
/usr/local/lib/libexslt.so.0
liblzma.so.5 => not found
/usr/local/lib/libexslt.so.0.8.13
liblzma.so.5 => not found
/usr/local/lib/libglade-2.0.so
liblzma.so.5 => not found
/usr/local/lib/libglade-2.0.so.0
liblzma.so.5 => not found
/usr/local/lib/libglade-2.0.so.0.0.7
liblzma.so.5 => not found
/usr/local/lib/libgsf-1.so
liblzma.so.5 => not found
/usr/local/lib/libgsf-1.so.114
liblzma.so.5 => not found
/usr/local/lib/libgsf-1.so.114.0.21
liblzma.so.5 => not found
/usr/local/lib/libobparser.so
liblzma.so.5 => not found
/usr/local/lib/libobparser.so.21
liblzma.so.5 => not found
/usr/local/lib/libobparser.so.21.0.9
liblzma.so.5 => not found
/usr/local/lib/libobrender.so
liblzma.so.5 => not found
/usr/local/lib/libobrender.so.21
liblzma.so.5 => not found
/usr/local/lib/libobrender.so.21.0.9
liblzma.so.5 => not found
/usr/local/lib/librsvg-2.so
liblzma.so.5 => not found
/usr/local/lib/librsvg-2.so.2
liblzma.so.5 => not found
/usr/local/lib/librsvg-2.so.2.34.2
liblzma.so.5 => not found
/usr/local/lib/libxml2.so
liblzma.so.5 => not found
/usr/local/lib/libxml2.so.2
liblzma.so.5 => not found
/usr/local/lib/libxml2.so.2.9.0
liblzma.so.5 => not found
/usr/local/lib/libxslt.so
liblzma.so.5 => not found
/usr/local/lib/libxslt.so.1
liblzma.so.5 => not found
/usr/local/lib/libxslt.so.1.1.24
liblzma.so.5 => not found
« Last Edit: October 22, 2012, 01:12:03 PM by AbNoRMiS »
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9619
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #3 on: October 22, 2012, 01:18:06 PM »
Install xz.tcz

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #4 on: October 22, 2012, 01:36:44 PM »
yep, had to add it to onboot.lst
hope it's a temporary measure
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9619
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #5 on: October 22, 2012, 02:41:35 PM »
xz.tcz was added to the dep file of libxml2.tcz yesterday.  Run tce-update and it should make the fix permanent.

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #6 on: October 22, 2012, 04:33:09 PM »
namely dep-file something was missing
thank Jason :)
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2859
Re: LXDE2 and pcmanfm2 does work wrong after update glib2 and libxml2
« Reply #7 on: October 23, 2012, 11:55:01 AM »
I found that adding xz.tcz to the onboot.lst didn't help in the end.    restored original glib2 and libxml2 tcz's and all my apps run again without crashing.