WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: opera-12.scm  (Read 7228 times)

Offline nick65go

  • Full Member
  • ***
  • Posts: 153
Re: opera-12.scm
« Reply #15 on: November 20, 2012, 01:15:26 PM »
Tried 12.10 but it still doesn't recognize any of my plugins  :(

sorry for noise; but did you try the latest flashplugin 11.2.202.251 ?
it is working for me with opera-next 12.50 (Opera/9.80 (X11; Linux x86_64) Presto/2.12.378 Version/12.50)

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: opera-12.scm
« Reply #16 on: November 20, 2012, 01:27:14 PM »
Hmm, the download binaries on opera's ftp server contain "i386" in their name...
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline nick65go

  • Full Member
  • ***
  • Posts: 153
Re: opera-12.scm
« Reply #17 on: November 20, 2012, 02:14:55 PM »
I did not find anymore all the opera-next packages on their ftp;
but here is a hole collection to chose from: http://arc.opera.com/snapshot/linux-freebsd/
just extract the main (big) file, replace it over yours, (chmod +x) and enjoy
so test until you find one which works for you (you could keep many operaX tcz in your bag)
btw: I mostly use x64 linux >3.5 because Xorg drv for my ATI X1400 (else quick fans run/noise in linux 3.2x)
« Last Edit: November 20, 2012, 02:22:20 PM by nick65go »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9173
Re: opera-12.scm
« Reply #18 on: November 20, 2012, 06:54:28 PM »
I have the current opera-12.scm working with a couple versions of flash, opera requires either libcurl.so* to be in the standard path, or for it to be loaded with LD_PRELOAD, which I added to the opera-12 wrapper.  Uploading now, hopefully fixes the issue.

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: opera-12.scm
« Reply #19 on: November 20, 2012, 10:12:56 PM »
Still no plugins detected  :(

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: opera-12.scm
« Reply #20 on: November 20, 2012, 10:35:24 PM »
Still no plugins detected  :(

Any output when running with option "-debugplugin"?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9173
Re: opera-12.scm
« Reply #21 on: November 20, 2012, 10:41:59 PM »
I notice the same when booting bare bones, will look into tomorrow.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9173
Re: opera-12.scm
« Reply #22 on: November 21, 2012, 06:38:22 PM »
Ok, no LD_PRELOAD  needed, just needed to export LD_LIBRARY_PATH to the operapluginwrapper script.   Hopefully all works now.

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: opera-12.scm
« Reply #23 on: November 22, 2012, 08:07:19 AM »
Yes, now it works fine. Big thanks!