WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Firefox Bug - Fonts  (Read 5759 times)

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Firefox Bug - Fonts
« on: June 18, 2012, 12:01:44 AM »
There appears to be a discrepancy between the TCZ and SCM formats of Firefox. Firefox.tcz finds and uses installed fonts, firefox.scm does not.  Illustrated in the attached screen shots.

In both instances the following fonts are loaded via onboot.lst
  • dejavu-fonts-ttf.tcz
  • ttf-bitstream-vera.tcz

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: Firefox Bug - Fonts
« Reply #1 on: June 18, 2012, 01:09:57 PM »
i have an installed dejavu-fonts-ttf.scm instead dejavu-fonts-ttf.tcz
ttf-bitstream-vera.tcz loaded as "ondemand" together with other tcz
or loaded "onboot" with LXDE2.tcz through bootcode desktop=lxde2
also installed liberation-fonts-ttf.tcz loaded through onboot.lst
firefox.scm preferences shows the following


Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #2 on: June 18, 2012, 01:17:45 PM »
I needed to put back in the /apps/gtk2/share/fonts path to /apps/gtk2/etc/fonts/fonts.conf.  That fixed the firefox.scm font issue.  I am uploading it now.

/apps/gtk2/share/fonts contains a symlink in it that points to the system font path /usr/local/share/fonts, so system fonts will be used.

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: Firefox Bug - Fonts
« Reply #3 on: June 18, 2012, 01:26:26 PM »
now clear why such difference
this is because i still don't use gtk2.scm
thus scm uses gtk2.tcz instead gtk2.scm
« Last Edit: June 18, 2012, 01:28:18 PM by AbNoRMiS »
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: Firefox Bug - Fonts
« Reply #4 on: June 19, 2012, 01:03:10 AM »
I needed to put back in the /apps/gtk2/share/fonts path to /apps/gtk2/etc/fonts/fonts.conf.  That fixed the firefox.scm font issue.  I am uploading it now.

/apps/gtk2/share/fonts contains a symlink in it that points to the system font path /usr/local/share/fonts, so system fonts will be used.
Some fonts (tcz) are seen while others (scm) are not, as shown in the screenshot.

Downloaded updates for scms
  • Firefox
  • gtk2

Progs loaded
Code: [Select]
cat /mnt/sdb1/tce/onboot.lst

Xvesa.tcz
Xprogs.tcz
kmaps.tcz
icewm.tcz
ttf-bitstream-vera.tcz

Code: [Select]
cat /mnt/sdb1/tce/scmboot.lst

dejavu-fonts-ttf
firefox
   

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #5 on: June 19, 2012, 04:51:08 AM »
With the below extensions loaded, I don't see the problem, all show up for me.

onboot.lst:
Code: [Select]
ipw2200.tcz
alsa.tcz
Xlibs.tcz
Xprogs.tcz
jwm.tcz
Xvesa.tcz
wireless_tools.tcz

ibam.tcz
ls /apps:
Code: [Select]
Xorg-7.6-lib.tcz/
bin/
dejavu-fonts-ttf/
etc
firefox/
gtk2/
leafpad/
share


Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: Firefox Bug - Fonts
« Reply #6 on: June 19, 2012, 07:37:00 AM »
With the below extensions loaded, I don't see the problem, all show up for me.
We seem to be getting different results from loading similar apps.  I tried again with the following in an attempt to get close to your apps.  I didn't load the wireless progs as this is a cabled machine.

Code: [Select]
cat /mnt/sdb1/tce/onboot.lst

Xvesa.tcz
Xprogs.tcz
kmaps.tcz
jwm.tcz
alsa.tcz

Code: [Select]
cat /mnt/sdb1/tce/scmboot.lst

firefox
gtk2
leafpad
dejavu-fonts-ttf
Result: No dejavu fonts are listed only Bitstream Vera fonts which are not loaded
Screenshot: firefox_cached_fonts.jpg

I suspect the font information is cached somewhere and Firefox is incorrectly reporting the cached info rather than the actual fonts available.  If this is correct it would account for the differences we are seeing.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #7 on: June 19, 2012, 01:55:14 PM »
Hmm, I rebooted with the same setup as I did earlier and now I see the same issue as you.

Let me poke around and see what the culprit is.

Also, it would be more precise for us to list the outputs of the below commands rather than listing the *boot.lst files:

ls /usr/local/tce.installed

ls /apps


Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #8 on: June 19, 2012, 04:35:22 PM »
With the below list of installed tczs:

Code: [Select]
Xlibs
Xprogs
Xvesa
alsa
alsa-config
alsa-modules-3.0.21-tinycore
depmod
fltk-1.10
i2c-3.0.21-tinycore
ibam
input-joystick-3.0.21-tinycore
ipw2200
jwm
libasound
libiw
libpci
ncurses
ncurses-common
pci-utils
v4l-dvb-3.0.21-tinycore
wireless-3.0.21-tinycore
wireless_tools


I loaded the scms in this order, and the fonts were found.  I will try to find the issue though:

Code: [Select]
tc@box:~$ scm-load -i dejavu-fonts-ttf
dejavu-fonts-ttf.scm: OK
tc@box:~$ scm-load -i gtk2
gtk2.scm: OK
tc@box:~$ scm-load -i firefox
firefox.scm: OK
tc@box:~$ scm-load -i flash
flash.scm: OK
tc@box:~$



Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: Firefox Bug - Fonts
« Reply #9 on: June 20, 2012, 12:51:50 AM »
I loaded the scms in this order, and the fonts were found.  I will try to find the issue though:

Code: [Select]
tc@box:~$ scm-load -i dejavu-fonts-ttf
dejavu-fonts-ttf.scm: OK
tc@box:~$ scm-load -i gtk2
gtk2.scm: OK
tc@box:~$ scm-load -i firefox
firefox.scm: OK
tc@box:~$ scm-load -i flash
flash.scm: OK
tc@box:~$

I'm not clear whether this is significant, but I get different results to you.

Code: [Select]
ls -1 /usr/local/tce.installed

Xlibs
Xprogs
Xvesa
alsa
alsa-config
alsa-modules-3.0.21-tinycore
depmod
fltk-1.10
i2c-3.0.21-tinycore
input-joystick-3.0.21-tinycore
jwm
kmaps
libasound
libpci
ncurses
ncurses-common
pci-utils
v4l-dvb-3.0.21-tinycore


Code: [Select]
scm-load -i dejavu-fonts-ttf
scm-load -i gtk2
scm-load -i firefox
scm-load -i flash
Note I do not get the confirmation OK returned to the terminal.


Code: [Select]
ls -1 /apps

bin/
dejavu-fonts-ttf/
etc
firefox/
flash/
gtk2/
share

Firefox does not find the Dejavu fonts, but does list the Bitstream Vera fonts which are not loaded.  Flash works OK.
   

Offline SamK

  • Hero Member
  • *****
  • Posts: 713
Re: Firefox Bug - Fonts
« Reply #10 on: July 10, 2012, 03:22:23 AM »
I loaded the scms in this order, and the fonts were found.  I will try to find the issue though
Cross referencing with the Icecat Bug Topic as the font symptoms are common to both firefox.scm and icecat.scm.
http://forum.tinycorelinux.net/index.php/topic,13617.0.html


Edit
added link
« Last Edit: July 10, 2012, 06:48:43 AM by SamK »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #11 on: July 10, 2012, 08:41:09 AM »
Ok, I tested this today and the dejavu fonts were not available in Firefox, I will check on it tonight.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #12 on: July 10, 2012, 05:05:53 PM »
Using the below installed tczs and scm's it works fine again.  I don't know why sometimes it does not find the fonts

tczs
Code: [Select]
tc@box:~$ ls /usr/local/tce.installed/
Xlibs                           input-joystick-3.0.21-tinycore
Xprogs                          jwm
Xvesa                           libasound
alsa                            libpci
alsa-config                     ncurses
alsa-modules-3.0.21-tinycore    ncurses-common
depmod                          pci-utils
fltk-1.10                       v4l-dvb-3.0.21-tinycore
i2c-3.0.21-tinycore
tc@box:~$




scms
Code: [Select]
tc@box:~$ ls /apps
bin/              etc               flash/            share
dejavu-fonts-ttf/ firefox/          gtk2/
tc@box:~$


Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #13 on: July 10, 2012, 05:56:29 PM »
Ok, once again I saw a failure.   So what I have done is adjust the gtk2.scm, dejavu-fonts-ttf.scm  to hopefully fix this, it is working here.   I have changed the making of the one symlink /usr/local/share/fonts/dejavu that points into the dejavu-fonts-ttf.scm, and instead am linking into /opt/scm/share/fonts, same as /apps/share/fonts.  That way the base system is not modified, as keeping a pristine system is one of the goals of the scm format.  And that /usr/local/share/fonts/dejavu symlink would interfere with the installing of the tcz version of that package, as if the dejavu scm was installed and then uninstalled, that dead symlink would perhaps prevent the tcz from getting loaded and linked correctly.

The fixed gtk2.scm and dejavu-fonts-ttf.scm are uploading now.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9677
Re: Firefox Bug - Fonts
« Reply #14 on: July 10, 2012, 07:13:51 PM »
Updated gtk2.scm and dejavu-fonts-ttf.scm should be in place now.