WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: compiletc installs nothing anymore?  (Read 1000 times)

Offline daemon

  • Newbie
  • *
  • Posts: 4
compiletc installs nothing anymore?
« on: May 15, 2012, 12:59:22 AM »
Greetings,

I've been using Tinycore for several small projects, in which hardware had to be installed with a fast, simple, expendable OS. Tinycore is brilliant. :)

Currently using Tinycore 4.0.

However: Either I haven't had enough coffee, or something else is awry but if I recall correctly, compiletc was supposed to install tools to compile C and C++, right? If i click it and install it 'OnBoot', it reports OK almost immediatly. (Doesn't seem to download anything).
Even after reboot gcc isn't available. Trying to select and install compiletc again, the appbrowser insists that it's already installed. Is the repository broken? Am I doing something else wrong?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6475
Re: compiletc installs nothing anymore?
« Reply #1 on: May 15, 2012, 01:22:16 AM »
It sounds like the file compiletc.tcz.dep is missing, this is what causes the other extensions to be loaded.

Offline daemon

  • Newbie
  • *
  • Posts: 4
Re: compiletc installs nothing anymore?
« Reply #2 on: May 15, 2012, 01:32:55 AM »
Starting to wonder if the following could be the problem:

This is a re-install on a machine that was already running TinyCore.
I figured that a boot-from-CD and a TC_Install, frugal to whole disk would nuke-and-pave the disk, write a new image to the disk and the result would be a new install.

But checking my home directory, I see my old files...

This could also mean that, while tools are gone, the install mechanism things it already has those dependencies.

Is there any way from the installation tool to actually blank-out the entire disk and install TC from the ground up?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6475
Re: compiletc installs nothing anymore?
« Reply #3 on: May 15, 2012, 02:02:54 AM »
If you want to upgrade tc, you usually just need to copy a new core{64}.gz file over the old one. After that it's just a question of checking the release notes to see which files in your backup might need changing.

You can use the gui tools provided to clear onboot/ondemand and boot with "norestore" for a fresh start.

Edit: replaced vlminuz with core.gz
« Last Edit: May 15, 2012, 08:29:35 AM by Juanito »

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: compiletc installs nothing anymore?
« Reply #4 on: May 15, 2012, 02:13:04 AM »
However: Either I haven't had enough coffee, or something else is awry but if I recall correctly, compiletc was supposed to install tools to compile C and C++, right? If i click it and install it 'OnBoot', it reports OK almost immediatly. (Doesn't seem to download anything).
Even after reboot gcc isn't available. Trying to select and install compiletc again, the appbrowser insists that it's already installed. Is the repository broken? Am I doing something else wrong?
is similar to that compiletc.tcz already was installed
if extension is already installed it should be load follows
Code: [Select]
tce-load -i extension.tczloading of installed extension by using appsbrowser
does not load its dependencies

or maybe that gcc.tcz missing or broken
check this by calling command
Code: [Select]
md5sum -c /etc/sysconfig/tcedir/optional/gcc.tcz.md5.txtand try fetch missing dependencies
Code: [Select]
tce-audit builddb
tce-audit fetchmissing
« Last Edit: May 15, 2012, 02:19:05 AM by AbNoRMiS »
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline daemon

  • Newbie
  • *
  • Posts: 4
Re: compiletc installs nothing anymore?
« Reply #5 on: May 15, 2012, 02:46:03 AM »
Hello AbNoRMiS,

Thanks for the feedback.
compiletc.tcz was indeed installed, on a previous install. But I tried to re-format the disk and completly re-install TC from the ground up. The result was, that I didn't appear to have any packages left installed, but the home directory was intact, but no packages re-installed correctly.

Assuming the command
tce-load -i extension.tcz

should then be
tce-load -i compiletc.tcz

Returns an error:
"compiletc.tcz not found!"


The directory '/etc/sysconfig/tcedir/' does not exist (leave alone any of the subdirectories or files. These probably did nót survive the format.)

tce-audit builddb appears to succeed (no errors)
tce-audit fetchmissing returns an error:
Downloading cz.tcz
Error on cz.tcz


Starting with 'norestore' does indeed clear the home directory. But according to the AppsAudit GUI tool, not the installed packages and stuff.
But IMO the installation is 'fubar'. My bad, probably, but I want it all gone. Wiped. nuke-and-pave and start over. Is it possible to do this with the TC installation process? Or should I boot from some other LiveCD and clear it out this way?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4248
Re: compiletc installs nothing anymore?
« Reply #6 on: May 15, 2012, 03:37:50 AM »
Hi daemon
Try this, boot with   base norestore   , run the install utility again and allow it to format the drive. Reboot
to the new installation and install  compiletc.

Offline daemon

  • Newbie
  • *
  • Posts: 4
Re: compiletc installs nothing anymore?
« Reply #7 on: May 15, 2012, 03:47:51 AM »
@Rich: booting with base norestore gives me a pretty minimal session. Which is OK, but the TC_Install option isn't there anymore either. (how) do I start it from  the terminal?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4248
Re: compiletc installs nothing anymore?
« Reply #8 on: May 15, 2012, 05:36:47 AM »
Hi daemon
Call up AppBrowser, change  OnBoot  to  Download + Load , and select tc-install.tcz.