WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: gtk3 broken with Xorg 7.6  (Read 10277 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #15 on: April 20, 2012, 06:20:29 AM »
Ok, if the issue is needing xcb, that can easily be packed into the gtk3.scm extension.

And I reckon a shared gtk3 build can depend on the libx11-xcb.tcz extension.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #16 on: April 20, 2012, 07:26:22 AM »
It needs xcb (libX11-xcb.so) and libX11 libraries compiled with xcb support. Then:

a) For smc extensions you can compile and pack both and set LD_LIBRARY_PATH into script.

b) For a gtk3.tcz extension, one problem:
    libx11-xcb.tcz puts libraries into /usr/local/lib. Then you have two libX11.so (one into /usr/lib from Xlibs, other into /usr/local/lib from libx11-xcb).
    As /usr/lib takes precedence over /usr/local/lib gtk3 applications still use libX11 from Xlibs and crashing.
   Some options:
                 a) Rebuild Xlibs with xcb support
                 b) Remove Xlibs symbolic links affected with tce.installed script when libx11-xcb.tcz loads.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #17 on: April 20, 2012, 07:45:43 AM »
Ok, I will compile a new xcb enabled libx11 and xcb into the gtk3.scm extension so we can move forward with gtk3 scms.

I am not sure how it is to be handled in the tcz area since replacing libX11 symbolic links during runtime, when apps that are linked to libX11 might be running, may not be what is wanted.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #18 on: April 20, 2012, 10:30:07 AM »
I'll also update to the latest gtk3, I will aim for tonight and see if that makes a difference.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #19 on: April 22, 2012, 07:24:38 AM »
Updated gtk3 to latest 3.4.1 as well as underlying libs, built libX11 with xcb support as part of extension, and the apps crash now even with Xvesa.  I copied over the libX11 files to /usr/lib and restarted Xvesa to see if the libX11 with xcb support needs to be running.  Still a no go.

I will rebuild with the previous version of gtk3 and see how that goes with the xcb enabled libX11


Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #20 on: April 22, 2012, 09:19:57 AM »
I rebuilt gtk3-2.3.4 with xcb enabled libX11, and now gtk3 apps work with a running Xorg but not without.

I will see if I can't find what will allow gtk3 to work with both Xvesa and Xorg.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #21 on: April 22, 2012, 09:52:36 AM »
For Xvesa you need libxcb.so.1.1.0 from libxcb.tcz.

I modified actual gtk3.scm adding under /lib:
  • libX11.so.6.3.0
  • libX11-xcb.so.1.0.0
  • libxcb.so.1.0.0
... and making their related symbolic links. No need to modify any application script.

Result: Working fine with Xvesa and Xorg.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #22 on: April 23, 2012, 05:45:24 AM »
Yeah, plugging in those files from the existing extensions works, but I am also interested in why those same files built from source, even from the same versions along with the latest gtk3, don't work, with or without pthread-stubs enabled in libxcb, or even the same versions as the existing extensions.

But those same files built from the current versions upstream work when plugged into the existing gtk3.scm extension, just like the files from the extensions do.  And until we can build the latest gtk3 and it's latest dependencies, we can't move forward with it. 

This afternoon I will plug those files in as a workaround.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #23 on: April 23, 2012, 01:12:06 PM »
Today I modified gtk3.scm with lastest gtk3 and here it is working (with both Xvesa and Xorg).

I added/replaced libraries:

  a) From existing tcz's:
  • libxcb.tcz
  • libx11-xcb.tcz
  • glib2.tcz
  b) Compiled by me:
  • pango 1.30
  • gdk-pixbuf 2.26.1
  • gtk3 3.4.1

I had to be careful when making new symbolic links. Errors are typical there.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11520
Re: gtk3 broken with Xorg 7.6
« Reply #24 on: May 06, 2012, 06:28:17 AM »
Response from irc.gnome.org #gtk+ is that gtk3 should still be working without xcb. I'll open a bug.

It doesn't look like there's been much response on the bug report?

The need for gtk3 is starting to block updates of several extensions - the nodbus thing doesn't have a nogtk3 option does it  ;)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10157
Re: gtk3 broken with Xorg 7.6
« Reply #25 on: May 06, 2012, 07:04:48 AM »
Well, sw doesn't expire ;) Just like we still offer gtk1 apps, gtk3 doesn't remove the gtk2 ones.
The only barriers that can stop you are the ones you create yourself.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11520
Re: gtk3 broken with Xorg 7.6
« Reply #26 on: May 06, 2012, 10:55:06 PM »
Sure, and I still use the gtk1 apps beaver/emelfm/gtkfind every time I use tc.

..but, we're starting to reach the stage where bug fixes are not accessible because the latest versions of some applications require gtk3.

Anyway, nothing to be done until gtk3 is fixed  :)

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #27 on: May 16, 2012, 02:52:53 PM »
For making a working gtk3.tcz, I solve this by setting rpath (or runpath) into LDFLAGS variable when compiling gtk3...

Also I can send a working (and updated) gtk3.scm if needed.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #28 on: May 16, 2012, 03:43:37 PM »
Yeah, send in a runtime scm with it's locales intact, and also a gtk3-dev.tar.xz that is the full source to build against.

Thanks.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: gtk3 broken with Xorg 7.6
« Reply #29 on: May 16, 2012, 04:08:10 PM »
I'll test some, and perhaps this rpath variable is something that needs to be put in buildscm itself to perhaps save  some headaches in future apps.