WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: VLC is not working  (Read 23711 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: VLC is not working
« Reply #15 on: February 28, 2012, 03:07:43 PM »
VLC and Transmission-gtk3 now updated to use dbus self contained in each, working nicely at first glance.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10692
Re: VLC is not working
« Reply #16 on: February 28, 2012, 11:03:58 PM »
Wouldn't that remove the point of dbus? If each app ran its own dbus session, then no app could contact others, which makes a messaging protocol kind of pointless.

[ my personal opinion is that dbus should die, and apps that require it only to support some Gnome config tool / notification popup should have an option to configure it out, avoiding the need to start dbus just for a check if dbus is running ]
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: VLC is not working
« Reply #17 on: February 29, 2012, 03:21:53 AM »
Yeah, basically this is a way to get around dbus rather than to actually use it.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: VLC is not working
« Reply #18 on: February 29, 2012, 05:26:03 AM »
Ok, here is an idea.  I can check the status of system dbus.tcz, "/usr/local/etc/init.d/dbus status", and if running don't call on dbus-launch.  Otherwise use dbus-launch that is part of the self contained app.  That way the system wide dbus session is used if it exists.


Offline V.Krishn

  • WikiUser
  • *
  • Posts: 33
Re: VLC is not working
« Reply #19 on: February 29, 2012, 08:32:21 AM »
Ok, here is an idea.  I can check the status of system dbus.tcz, "/usr/local/etc/init.d/dbus status", and if running don't call on dbus-launch.  Otherwise use dbus-launch that is part of the self contained app.  That way the system wide dbus session is used if it exists.
I would not get into the internals of what you are trying to achieve, but sounds kinda like,
http://forum.tinycorelinux.net/index.php/topic,12457.msg68058.html#msg68058  (install part)
What I mean here is how would dbus-launch that is part of the self contained app get established/installed?

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: VLC is not working
« Reply #20 on: February 29, 2012, 08:41:35 AM »
Right now, I am installing dbus as a portable conversion of dbus.tcz and expat2.tcz into the scms that need it, namely transmission-gtk3.scm and vlc.scm.

I will soon make a dbus build script that will allow a native compile that can be built into the target /apps/extensionname directory.


Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10692
Re: VLC is not working
« Reply #21 on: May 02, 2012, 07:17:45 AM »
http://forum.tinycorelinux.net/index.php/topic,13192.new.html#new

This may be a solution, depending how much VLC etc need dbus.
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: VLC is not working
« Reply #22 on: May 05, 2012, 05:10:33 AM »
I will definitely use nobus with any future scm builds that require dbus, as dbus really has no purpose in the scm format and will be avoided when possible.

Offline neonix

  • Sr. Member
  • ****
  • Posts: 285
Re: VLC is not working
« Reply #23 on: February 18, 2020, 10:22:32 PM »
vlc3.tcz doesn't work in TC11.x (x86)

Code: [Select]
tc@box:~$ vlc
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[0829b070] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
ALSA lib conf.c:4048:(snd_config_update_r) Cannot access file /usr/local/etc/alsa/alsa.conf
[08175290] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[081e48e0] skins2 interface error: cannot instantiate dialogs provider
[0829e670] main playlist: playlist is empty
[081e48e0] [cli] lua interface error: Error loading script /tmp/tcloop/vlc3/usr/local/lib/vlc/lua/intf/cli.luac: lua/modules/common.lua:3: attempt to call a nil value (global 'module')

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13938
Re: VLC is not working
« Reply #24 on: February 19, 2020, 12:58:18 AM »
strange...

That error message is nominally due to an incompatibility with lua-5.3.x and a fix was used for that.

vlc3 works immediately after compiling it, but after packaging and reboot, it fails (cvlc filename.mp4 works).

This sort of error is often due to some part of a program not following symlinks properly, but using copy2fs for vlc3 things still don't work.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13938
Re: VLC is not working
« Reply #25 on: February 19, 2020, 01:41:34 AM »
Ah - the problem seems to have been a missing dep - libzstd added

Offline neonix

  • Sr. Member
  • ****
  • Posts: 285
Re: VLC is not working
« Reply #26 on: February 19, 2020, 02:37:50 AM »
In TC11 (x86_64) vlc.tcz also don't work.

Code: [Select]
tc@box:~$ vlc
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[000000000222a430] main libvlc error: stale plugins cache: modified
[.............................................]
[000000000226f9a0] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
[000000000222a430] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Xlib:  extension "XINERAMA" missing on display ":0.0".
Xlib:  extension "XINERAMA" missing on display ":0.0".
[000000000229a8c0] skins2 interface error: cannot instantiate dialogs provider
Remote control interface initialized. Type `help' for help.
[000000000222ceb0] main playlist: playlist is empty

I googled "main libvlc error: stale plugins cache"
and I get
https://dev.getsol.us/T5893

I deleted /usr/local/lib/vlc/plugins/plugins.dat
and I get
Code: [Select]
tc@box:~$ vlc
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[0000000000dd15e0] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
[0000000000bf6430] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Xlib:  extension "XINERAMA" missing on display ":0.0".
Xlib:  extension "XINERAMA" missing on display ":0.0".
[0000000000ddd9a0] skins2 interface error: cannot instantiate dialogs provider
Remote control interface initialized. Type `help' for help.
[0000000000c1c920] main playlist: playlist is empty

I googled  "skins2 interface error: cannot instantiate dialogs provider"
and I get
https://askubuntu.com/questions/1033472/vlc-media-player-not-working-no-interface
https://forum.videolan.org/viewtopic.php?t=135022
 
Both, 32-bit and 64-bit have the same version (revision 3.0.8-0-gf350b6b5a7) but there different errors. In 32-bit version of vlc, when I googled "attempt to call a nil value (global 'module')"
I get
https://forum.videolan.org/viewtopic.php?t=135023
https://forum.videolan.org/viewtopic.php?t=135022

Offline neonix

  • Sr. Member
  • ****
  • Posts: 285
Re: VLC is not working
« Reply #27 on: February 19, 2020, 02:47:53 AM »
Ah - the problem seems to have been a missing dep - libzstd added
That solved problem. Now I want to watch YouTube video using YouTube url and get:
Code: [Select]
[0000000000e30430] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
qt.qpa.xcb: failed to initialize XRandr
qt.qpa.xcb: XKeyboard extension not present on the X server
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-tc'
[0000000000e8f620] qt interface error: Unable to load extensions module
qt.qpa.xcb: xcb_shm_create_segment() failed for size 1296
qt.qpa.xcb: xcb_shm_create_segment() failed for size 1008000
qt.qpa.xcb: xcb_shm_create_segment() failed for size 466620
qt.qpa.xcb: xcb_shm_create_segment() failed for size 852120
[00007f4e44001160] mjpeg demux error: cannot peek
« Last Edit: February 19, 2020, 02:54:26 AM by neonix »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13938
Re: VLC is not working
« Reply #28 on: February 19, 2020, 03:05:06 AM »
Do you get more information with "vlc --verbose 2 <url>"?

Do things work with "cvlc <url>"?

Which url are you using?

Offline neonix

  • Sr. Member
  • ****
  • Posts: 285
Re: VLC is not working
« Reply #29 on: February 19, 2020, 03:30:10 AM »
cvlc --verbose 2 https://www.youtube.com/watch?v=Vr1xs92ySXQ

CLI and GUI versions give the same result. The log is very long, I paste only the most essential part.

Code: [Select]
[0000000001431430] main libvlc debug: plug-ins loaded: 439 modules
[0000000001431430] main libvlc debug: opening config file (/home/tc/.config/vlc/vlcrc)
[0000000001431780] main logger debug: looking for logger module matching "any": 3 candidates
[0000000001431780] main logger debug: using logger module "console"
[0000000001431430] main libvlc debug: translation test: code is "C"
[0000000001632df0] main keystore debug: looking for keystore module matching "memory": 3 candidates
[0000000001632df0] main keystore debug: using keystore module "memory"
[0000000001431430] main libvlc debug: CPU has capabilities MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4.1 FPU
[0000000001433880] main input debug: Creating an input for 'Media Library'
[0000000001433880] main input debug: Input is a meta file: disabling unneeded options
[0000000001433880] main input debug: using timeshift granularity of 50 MiB
[0000000001433880] main input debug: using default timeshift path
[0000000001433880] main input debug: `file/directory:///home/tc/.local/share/vlc/ml.xspf' gives access `file' demux `directory' path `/home/tc/.local/share/vlc/ml.xspf'
[0000000001620240] main input source debug: creating demux: access='file' demux='directory' location='/home/tc/.local/share/vlc/ml.xspf' file='/home/tc/.local/share/vlc/ml.xspf'
[0000000001593b70] main demux debug: looking for access_demux module matching "file": 12 candidates
[0000000001593b70] main demux debug: no access_demux modules matched
[00000000014341f0] main stream debug: creating access: file:///home/tc/.local/share/vlc/ml.xspf
[00000000014341f0] main stream debug:  (path: /home/tc/.local/share/vlc/ml.xspf)
[00000000014341f0] main stream debug: looking for access module matching "file": 21 candidates
[00000000014341f0] main stream debug: using access module "filesystem"
[0000000001467390] main stream debug: looking for stream_filter module matching "prefetch,cache_read": 25 candidates
[0000000001467390] cache_read stream debug: Using stream method for AStream*
[0000000001467390] cache_read stream debug: starting pre-buffering
[0000000001467390] cache_read stream debug: received first data after 0 ms
[0000000001467390] cache_read stream debug: pre-buffering done 296 bytes in 0s - 1818 KiB/s
[0000000001467390] main stream debug: using stream_filter module "cache_read"
[00000000014b2d70] main stream debug: looking for stream_filter module matching "any": 25 candidates
[00000000014b2d70] playlist stream debug: using XSPF playlist reader
[00000000014b2d70] main stream debug: using stream_filter module "playlist"
[00000000014b2d70] main stream debug: stream filter added to 0x1467390
[00000000014b33d0] main stream debug: looking for stream_filter module matching "any": 25 candidates
[00000000014b33d0] main stream debug: no stream_filter modules matched
[000000000143b260] main stream_directory debug: looking for stream_directory module matching "any": 0 candidates
[000000000143b260] main stream_directory debug: no stream_directory modules
[0000000001620240] main input source debug: attachment of directory-extractor failed for file:///home/tc/.local/share/vlc/ml.xspf
[00000000014b33d0] main stream debug: looking for stream_filter module matching "record": 25 candidates
[00000000014b33d0] main stream debug: using stream_filter module "record"
[0000000001620240] main input source debug: creating demux: access='file' demux='directory' location='/home/tc/.local/share/vlc/ml.xspf' file='/home/tc/.local/share/vlc/ml.xspf'
[0000000001593b70] main demux debug: looking for demux module matching "directory": 46 candidates
[0000000001593b70] main demux debug: using demux module "directory"
[00000000014f0f80] main demux meta debug: looking for meta reader module matching "any": 0 candidates
[00000000014f0f80] main demux meta debug: no meta reader modules
[0000000001433880] main input debug: `file/directory:///home/tc/.local/share/vlc/ml.xspf' successfully opened
[0000000001468220] main xml reader debug: looking for xml reader module matching "any": 1 candidates
[0000000001468220] main xml reader debug: using xml reader module "xml"
[0000000001433880] main input debug: EOF reached
[0000000001593b70] main demux debug: removing module "directory"
[00000000014b33d0] main stream debug: removing module "record"
[00000000014b2d70] main stream debug: removing module "playlist"
[0000000001467390] main stream debug: removing module "cache_read"
[00000000014341f0] main stream debug: removing module "filesystem"
[00000000014896f0] main playlist debug: creating audio output
[0000000001475910] main audio output debug: looking for audio output module matching "any": 5 candidates
[0000000001475910] vlcpulse audio output debug: using library version 13.0.0
[0000000001475910] vlcpulse audio output debug:  (compiled with version 9.0.0, protocol 31)
[0000000001475910] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
[0000000001475910] alsa audio output debug: Available ALSA PCM devices:
[0000000001475910] alsa audio output debug: Discard all samples (playback) or generate zero samples (capture) (null)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog Default Audio Device (default:CARD=VT82xx)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog Default Audio Device (sysdefault:CARD=VT82xx)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog Front speakers (front:CARD=VT82xx,DEV=0)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog 2.1 Surround output to Front and Subwoofer speakers (surround21:CARD=VT82xx,DEV=0)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog 4.0 Surround output to Front and Rear speakers (surround40:CARD=VT82xx,DEV=0)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog 4.1 Surround output to Front, Rear and Subwoofer speakers (surround41:CARD=VT82xx,DEV=0)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog 5.0 Surround output to Front, Center and Rear speakers (surround50:CARD=VT82xx,DEV=0)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog 5.1 Surround output to Front, Center, Rear and Subwoofer speakers (surround51:CARD=VT82xx,DEV=0)
[0000000001475910] alsa audio output debug: HDA VIA VT82xx, VT1708S Analog 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers (surround71:CARD=VT82xx,DEV=0)
[0000000001475910] main audio output debug: using audio output module "alsa"
[00000000014896f0] main playlist debug: keeping audio output
[0000000001645650] main interface debug: looking for interface module matching "dbus,none": 13 candidates
[0000000001645650] dbus interface debug: listening on dbus as: org.mpris.MediaPlayer2.vlc
[0000000001645650] main interface debug: using interface module "dbus"
[0000000001699ff0] main interface debug: looking for interface module matching "hotkeys,none": 13 candidates
[0000000001699ff0] main interface debug: using interface module "hotkeys"
[0000000001473120] main interface debug: looking for interface module matching "globalhotkeys,none": 13 candidates
[0000000001473120] main interface debug: using interface module "xcb_hotkeys"
[0000000001473f70] main interface debug: looking for interface module matching "dummy": 13 candidates
[0000000001473f70] dummy interface: using the dummy interface module...
[0000000001473f70] main interface debug: using interface module "dummy"
[00000000014896f0] main playlist debug: processing request item: null, node: Playlist, skip: 0
[00000000014896f0] main playlist debug: rebuilding array of current - root Playlist
[00000000014896f0] main playlist debug: rebuild done - 1 items, index -1
[00000000014896f0] main playlist debug: starting playback of new item
[00000000014896f0] main playlist debug: resyncing on watch?v=Vr1xs92ySXQ
[00000000014896f0] main playlist debug: watch?v=Vr1xs92ySXQ is at 0
[00000000014896f0] main playlist debug: creating new input thread
[00007ff570000c80] main input debug: Creating an input for 'watch?v=Vr1xs92ySXQ'
[00000000014896f0] main playlist debug: requesting art for new input thread
[00007ff570000c80] main input debug: using timeshift granularity of 50 MiB
[00007ff570000c80] main input debug: using default timeshift path
[00007ff570000c80] main input debug: `https://www.youtube.com/watch?v=Vr1xs92ySXQ' gives access `https' demux `any' path `www.youtube.com/watch?v=Vr1xs92ySXQ'
[00007ff568000fa0] main input source debug: creating demux: access='https' demux='any' location='www.youtube.com/watch?v=Vr1xs92ySXQ' file='(null)'
[00007ff568001140] main demux debug: looking for access_demux module matching "https": 12 candidates
[00007ff568001140] main demux debug: no access_demux modules matched
[00007ff568001570] main stream debug: creating access: https://www.youtube.com/watch?v=Vr1xs92ySXQ
[00007ff568001570] main stream debug: looking for access module matching "https": 21 candidates
[00007ff568001c00] main tls client debug: looking for tls client module matching "any": 1 candidates
[00007ff568001c00] gnutls tls client debug: using GnuTLS version 3.5.19
[00007ff56c000c20] main meta fetcher debug: looking for meta fetcher module matching "any": 0 candidates
[00007ff56c000c20] main meta fetcher debug: no meta fetcher modules
[00007ff56c000c20] main art finder debug: looking for art finder module matching "any": 1 candidates
[00007ff56c000c20] main art finder debug: no art finder modules matched
[00007ff560000c20] main meta fetcher debug: looking for meta fetcher module matching "any": 0 candidates
[00007ff560000c20] main meta fetcher debug: no meta fetcher modules
[00007ff560000c20] main art finder debug: looking for art finder module matching "any": 1 candidates
[00007ff560000c20] main art finder debug: no art finder modules matched
[00007ff568001c00] gnutls tls client debug: loaded 270 trusted CAs from system
[00007ff568001c00] main tls client debug: using tls client module "gnutls"
[00007ff568001c00] main tls client debug: resolving www.youtube.com ...
[00007ff568001c00] gnutls tls client debug: TLS handshake: Resource temporarily unavailable, try again.
[00007ff568001c00] gnutls tls client debug: TLS handshake: Success.
[00007ff568001c00] gnutls tls client debug:  - safe renegotiation (RFC5746) enabled
[00007ff568001c00] gnutls tls client debug:  - extended master secret (RFC7627) enabled
[00007ff568001c00] gnutls tls client debug:  - false start (RFC7918) enabled
[00007ff568001570] http stream debug: out SETTINGS (0x04) frame of 30 bytes, flags 0x00, global
[00007ff568001570] http stream debug: out HEADERS (0x01) frame of 170 bytes, flags 0x05, stream 1
[00007ff568001570] http stream debug: in SETTINGS (0x04) frame of 18 bytes, flags 0x00, global
[00007ff568001570] http stream debug: setting: Concurrent streams (0x0003): 100
[00007ff568001570] http stream debug: setting: Initial window size (0x0004): 1048576
[00007ff568001570] http stream debug: setting: Header list size (0x0006): 16384
[00007ff568001570] http stream debug: out SETTINGS (0x04) frame of 0 bytes, flags 0x01, global
[00007ff568001570] http stream debug: in WINDOW_UPDATE (0x08) frame of 4 bytes, flags 0x00, global
[00007ff568001570] http stream debug: in SETTINGS (0x04) frame of 0 bytes, flags 0x01, global
[00007ff568001570] http stream debug: in HEADERS (0x01) frame of 628 bytes, flags 0x04, stream 1
[00007ff568001570] http stream debug: stream 1 15 headers:
[00007ff568001570] http stream debug:  :status: "200"
[00007ff568001570] http stream debug:  x-frame-options: "SAMEORIGIN"
[00007ff568001570] http stream debug:  strict-transport-security: "max-age=31536000"
[00007ff568001570] http stream debug:  x-content-type-options: "nosniff"
[00007ff568001570] http stream debug:  p3p: "CP="This is not a P3P policy! See http://support.google.com/accounts/answer/151657?hl=en for more info.""
[00007ff568001570] http stream debug:  expires: "Tue, 27 Apr 1971 19:44:06 GMT"
[00007ff568001570] http stream debug:  cache-control: "no-cache"
[00007ff568001570] http stream debug:  content-type: "text/html; charset=utf-8"
[00007ff568001570] http stream debug:  date: "Wed, 19 Feb 2020 11:25:08 GMT"
[00007ff568001570] http stream debug:  server: "YouTube Frontend Proxy"
[00007ff568001570] http stream debug:  x-xss-protection: "0"
[00007ff568001570] http stream debug:  set-cookie: "VISITOR_INFO1_LIVE=SnO4a3bBAHk; path=/; domain=.youtube.com; secure; expires=Mon, 17-Aug-2020 11:25:08 GMT; httponly; samesite=None"
[00007ff568001570] http stream debug:  set-cookie: "GPS=1; path=/; domain=.youtube.com; expires=Wed, 19-Feb-2020 11:55:08 GMT"
[00007ff568001570] http stream debug:  set-cookie: "YSC=Cxyurjf4bEQ; path=/; domain=.youtube.com; httponly"
[00007ff568001570] http stream debug:  alt-svc: "quic=":443"; ma=2592000; v="46,43",h3-Q050=":443"; ma=2592000,h3-Q049=":443"; ma=2592000,h3-Q048=":443"; ma=2592000,h3-Q046=":443"; ma=2592000,h3-Q043=":443"; ma=2592000"
[00007ff568001570] main stream debug: using access module "access"
[00007ff5686ba9b0] main stream debug: looking for stream_filter module matching "prefetch,cache_block": 25 candidates
[00007ff5686ba9b0] prefetch stream debug: using 16777216 bytes buffer, 16777216 bytes read
[00007ff5686ba9b0] main stream debug: using stream_filter module "prefetch"
[00007ff5686b6b30] main stream debug: looking for stream_filter module matching "any": 25 candidates
[00007ff568001570] http stream debug: in DATA (0x00) frame of 6184 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: out (priority) WINDOW_UPDATE (0x08) frame of 4 bytes, flags 0x00, global
[00007ff5686b6b30] main stream debug: no stream_filter modules matched
[00007ff5686ad280] main stream_directory debug: looking for stream_directory module matching "any": 0 candidates
[00007ff5686ad280] main stream_directory debug: no stream_directory modules
[00007ff568000fa0] main input source debug: attachment of directory-extractor failed for https://www.youtube.com/watch?v=Vr1xs92ySXQ
[00007ff5686b6b30] main stream debug: looking for stream_filter module matching "record": 25 candidates
[00007ff5686b6b30] main stream debug: using stream_filter module "record"
[00007ff568000fa0] main input source debug: creating demux: access='https' demux='any' location='www.youtube.com/watch?v=Vr1xs92ySXQ' file='(null)'
[00007ff5686b2810] main demux debug: looking for demux module matching "any": 46 candidates
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16377 bytes, flags 0x00, stream 1
[00007ff5686b2810] webvtt demux debug: subtitle demux discarded
[00007ff5686b2810] avformat demux debug: trying url: https://www.youtube.com/watch?v=Vr1xs92ySXQ
[00007ff5686b2810] avformat demux debug: CPU flags: 0x000011db
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff5686b2810] avformat demux debug: couldn't guess format
[00007ff5686b2810] ps demux warning: this does not look like an MPEG PS stream, continuing anyway
[00007ff5686b2810] main demux debug: using demux module "ps"
[00007ff5686ab330] main demux meta debug: looking for meta reader module matching "any": 0 candidates
[00007ff5686ab330] main demux meta debug: no meta reader modules
[00007ff570000c80] main input debug: `https://www.youtube.com/watch?v=Vr1xs92ySXQ' successfully opened
[00007ff5686b2810] ps demux warning: garbage at input from 509, trying to resync...
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 6726 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 35 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 240 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 15646 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: out (priority) WINDOW_UPDATE (0x08) frame of 4 bytes, flags 0x00, global
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16375 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 16384 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 7155 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: in DATA (0x00) frame of 0 bytes, flags 0x01, stream 1
[00007ff568001570] http stream debug: stream 1 closed by peer
[00007ff5686ba9b0] prefetch stream debug: end of stream
[00007ff568001570] http stream debug: in PING (0x06) frame of 8 bytes, flags 0x00, global
[00007ff568001570] http stream debug: out (priority) PING (0x06) frame of 8 bytes, flags 0x01, global
[00007ff570000c80] main input debug: EOF reached
[00007ff5686b2810] main demux debug: removing module "ps"
[00007ff5686b6b30] main stream debug: removing module "record"
[00007ff5686ba9b0] main stream debug: removing module "prefetch"
[00007ff568001570] main stream debug: removing module "access"
[00007ff568001570] http stream debug: local stream 1 shut down
[00007ff568001570] http stream debug: out RST_STREAM (0x03) frame of 4 bytes, flags 0x00, stream 1
[00007ff568001570] http stream debug: local shutdown
[00007ff568001570] http stream debug: out GOAWAY (0x07) frame of 8 bytes, flags 0x00, global
[00000000014896f0] main playlist debug: dead input
[00000000014896f0] main playlist debug: changing item without a request (current 0/1)
[00000000014896f0] main playlist debug: nothing to play