WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Euro key missing pc105, fi keyboard, Xorg  (Read 3397 times)

Offline risto3

  • WikiUser
  • *
  • Posts: 43
Re: Euro key missing pc105, fi keyboard, Xorg
« Reply #15 on: May 09, 2012, 04:06:59 AM »
I was sure that this worked in 4.2, but now in 4.5.2 the euro key <alt-gr>e just prints an 'e'. 
this is with 'lang=fr_FR.utf8 kmap=azerty/fr'

the others all seem to work (~#{[|`\^@]}¤)

I notice in editor that <alt-gr> is treated as <alt> so that if I try to enter the euro sign, I get the Edit menu, and none of the others work. 

How to get things back to normal?

[update 17/05/2012]
tried the xmodmap trick, got over the menu invocation with <alt-gr>E, F & S.
Found out that azerty/fr-pc.kmap is better because of some other keys screwed up
(like  '²').

That leaves Xorg, so will try and see.

[update 18/05/2012]

Partial results, but at least minimum.  Installing Xorg and using
Option "XkbLayout" "fr" in the kbd InputDevice section of /etc/X11/xorg.conf.
got <alt-gr>e to work as €.  Doesn't work in console or editor though, only writer and calc from what I've tested.  This is our minimal need, so I'll stop there.

Perhaps it should be explicitly stated on the wiki page that *only* Xorg seems to work to get the '€' symbol via  <alt-gr>e.
« Last Edit: May 18, 2012, 08:07:11 AM by risto3 »