WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] CUPS backend points to non-existent smbspool  (Read 8010 times)

Offline wirelessben

  • WikiUser
  • *
  • Posts: 15
[Solved] CUPS backend points to non-existent smbspool
« on: February 02, 2012, 08:33:13 AM »
With Firefox, samba3, and cups installed, symlink smb is broken:

Code: [Select]
tc@box:/tmp/tcloop/cups/usr/local/lib/cups/backend$ ls -l smb
lrwxrwxrwx    1 root     root            21 Dec 16  2010 smb -> ../../../bin/smbspool
tc@box:/tmp/tcloop/cups/usr/local/lib/cups/backend$ ls -l /tmp/tcloop/cups/usr/local/bin/smbspool
ls: /tmp/tcloop/cups/usr/local/bin/smbspool: No such file or directory

cups/backend/smb should point to 
../../../../../../samba3/usr/local/bin/smbspool
which is
/tmp/tcloop/samba3/usr/local/bin/smbspool


« Last Edit: February 03, 2012, 12:29:11 PM by wirelessben »

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: CUPS backend points to non-existent smbspool
« Reply #1 on: February 02, 2012, 08:55:10 AM »
Hi wirelessben
Quote
cups/backend/smb should point to 
../../../../../../samba3/usr/local/bin/smbspool
which is
/tmp/tcloop/samba3/usr/local/bin/smbspool
No, links under /tmp/tcloop should never point to other extensions under /tmp/tcloop. The link as
listed is correct. Try this:
Code: [Select]
ls -l /usr/local/bin/smbspoolIf it is not found, then Samba3 is not installed correctly.

Offline wirelessben

  • WikiUser
  • *
  • Posts: 15
Re: CUPS backend points to non-existent smbspool
« Reply #2 on: February 02, 2012, 10:22:43 AM »
Code: [Select]
tc@box:~$ ls -l /usr/local/bin/smbspool
lrwxrwxrwx    1 root     root            41 Feb  2 12:31 /usr/local/bin/smbspool -> /tmp/tcloop/samba3/usr/local/bin/smbspool

The link is good, so samba3 is installed correctly, but cups/backend/smb still points to
../../../bin/smbspool
which does not exist.

Is this a problem with cups?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: CUPS backend points to non-existent smbspool
« Reply #3 on: February 02, 2012, 10:42:29 AM »
H wirelessben
What does this return?:
Code: [Select]
ls -l /usr/local/lib/cups/backend/smb

Offline wirelessben

  • WikiUser
  • *
  • Posts: 15
Re: CUPS backend points to non-existent smbspool
« Reply #4 on: February 02, 2012, 11:10:03 AM »
Code: [Select]
tc@box:~$ ls -l /usr/local/lib/cups/backend/smb
lrwxrwxrwx    1 root     root            47 Feb  2 14:29 /usr/local/lib/cups/backend/smb -> /tmp/tcloop/cups/usr/local/lib/cups/backend/smb

tc@box:~$ ls -l /tmp/tcloop/cups/usr/local/lib/cups/backend/smb
lrwxrwxrwx    1 root     root            21 Dec 16  2010 /tmp/tcloop/cups/usr/local/lib/cups/backend/smb -> ../../../bin/smbspool
tc@box:~$ cd /tmp/tcloop/cups/usr/local/lib/cups/backend/
tc@box:/tmp/tcloop/cups/usr/local/lib/cups/backend$ ls -l ../../../bin/smbspool
ls: ../../../bin/smbspool: No such file or directory

Code: [Select]
tc@box:/tmp/tcloop/cups/usr/local/lib/cups/backend$ which smbspool
/usr/local/bin/smbspool
tc@box:/tmp/tcloop/cups/usr/local/lib/cups/backend$ ls -l /usr/local/bin/smbspool
lrwxrwxrwx    1 root     root            41 Feb  2 14:29 /usr/local/bin/smbspool -> /tmp/tcloop/samba3/usr/local/bin/smbspool

Should ../../../bin/smbspool point to /usr/local/bin/smbspool?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: CUPS backend points to non-existent smbspool
« Reply #5 on: February 02, 2012, 11:18:12 AM »
Hi wirelessben
Quote
Should ../../../bin/smbspool point to /usr/local/bin/smbspool?
Either that or there should be a smbspool included. Cups-smb.tcz has that file included, try installing
that and see if it helps.

Offline wirelessben

  • WikiUser
  • *
  • Posts: 15
Re: CUPS backend points to non-existent smbspool
« Reply #6 on: February 02, 2012, 12:56:57 PM »
Thanks for helping, Rich.

No joy on installing cups-smb. I uninstalled samba3 and cups, rebooted into tc base, and loaded cups-smb. Couldn't even start cups. Had to load cups, too. Started cups, got the web interface, no samba option.

Code: [Select]
tc@box:~$ ls -l /usr/local/bin/smbspool
lrwxrwxrwx    1 root     root            43 Feb  2 16:19 /usr/local/bin/smbspool -> /tmp/tcloop/cups-smb/usr/local/bin/smbspool
tc@box:~$ ls -l /tmp/tcloop/cups-smb/usr/local/bin/smbspool
-rwxr-xr-x    1 tc       staff      1879576 Sep 17  2009 /tmp/tcloop/cups-smb/usr/local/bin/smbspool
tc@box:~$ ls -l /tmp/tcloop/cups/usr/local/lib/cups/backend/smb
lrwxrwxrwx    1 root     root            21 Oct 12 13:53 /tmp/tcloop/cups/usr/local/lib/cups/backend/smb -> ../../../bin/smbspool
tc@box:~$ ls -l /tmp/tcloop/cups/usr/local/bin/smbspool
ls: /tmp/tcloop/cups/usr/local/bin/smbspool: No such file or directory
tc@box:~$ ls -l /usr/local/bin/smbspool
lrwxrwxrwx    1 root     root            43 Feb  2 16:19 /usr/local/bin/smbspool -> /tmp/tcloop/cups-smb/usr/local/bin/smbspool


A smbspool file exists. Cups just doesn't know where it is.


Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: CUPS backend points to non-existent smbspool
« Reply #7 on: February 02, 2012, 01:19:39 PM »
Hi wirelessben
OK, try this, go back to your original setup, Samba + cups. Modify the link like this:
Code: [Select]
sudo ln -fs /usr/local/bin/smbspool /usr/local/lib/cups/backend/smbSee it that fixes it.

Offline wirelessben

  • WikiUser
  • *
  • Posts: 15
Re: CUPS backend points to non-existent smbspool
« Reply #8 on: February 03, 2012, 05:25:53 AM »
That worked! Thank you, Rich.

I did install Samba before cups, and /usr/local/lib/cups/backend/smb was broken before I applied your fix:

tc@box:~$ ls -l /usr/local/lib/cups/backend/smb
lrwxrwxrwx    1 root     root            47 Feb  3 08:39 /usr/local/lib/cups/backend/smb -> /tmp/tcloop/cups/usr/local/lib/cups/backend/smb

I also started Samba before cups:
sudo  /usr/local/etc/init.d/samba start
sudo  /usr/local/etc/init.d/cups start

"Windows Printer via SAMBA" now shows up when configuring CUPS via http://localhost:631

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: CUPS backend points to non-existent smbspool
« Reply #9 on: February 03, 2012, 07:54:06 AM »
Hi wirelessben
You are welcome. By the way, I did not mean to imply what order to install the extensions in, just to
revert to your previous setup. Please edit the subject line in the first post of this and your other
thread by adding  [SOLVED]  to it.

Offline wirelessben

  • WikiUser
  • *
  • Posts: 15
Re: CUPS backend points to non-existent smbspool
« Reply #10 on: February 03, 2012, 11:39:54 AM »
Hi Rich,

I marked the problem SOLVED in the Q&A thread, but I believe it's still a bug here, unless a developer has fixed it.

To reproduce, boot TC 4.2.1 and load Firefox, samba, and cups.
At a terminal, change the root password with "sudo passwd".
Navigate to http://localhost:631 . Click Administration. Click Add Printer. Enter root with YOURROOTPASSWORD.
"Windows Printer via Samba" will not show up as a radio button.

Your command fixes it:
sudo ln -fs /usr/local/bin/smbspool /usr/local/lib/cups/backend/smb

I don't have the TC dev environment, but I would guess /usr/local/bin/cups-config is the relevant script.

Ben

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: CUPS backend points to non-existent smbspool
« Reply #11 on: February 03, 2012, 12:15:09 PM »
Hi wirelessben
While it is probably a bug, a working solution has been found. You could send a brief PM to juanito
with a link to this thread and mention that the extension contains a broken link.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14096
Re: [Solved] CUPS backend points to non-existent smbspool
« Reply #12 on: February 03, 2012, 09:23:25 PM »
'don't know what happened there, but I see the error - I'll fix it in the next couple of days or so.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10431
Re: [Solved] CUPS backend points to non-existent smbspool
« Reply #13 on: February 03, 2012, 09:35:03 PM »
Errors are what separates us from the computers.  :)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14096
Re: [Solved] CUPS backend points to non-existent smbspool
« Reply #14 on: February 03, 2012, 10:19:19 PM »
posted