WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tc-2.0  (Read 2465 times)

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
tc-2.0
« on: April 24, 2009, 07:17:55 PM »
Thanks for getting this out!

I was surprised so much is working right out of the box, inc/ alsa sound, skype, etc. I didn't have any luck installing updated flash10 into FF, although the old version still works. ( I tried loading in support files, but still nada.)   I haven't tried recompiling any of the basic extentions to the new libs.     

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9536
Re: tc-2.0
« Reply #1 on: April 24, 2009, 07:26:33 PM »
Can you give more details about flash 10 not working.  I have yet to see the getflash10 from TC 2.x  fail but perhaps there is an issue.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: tc-2.0
« Reply #2 on: April 24, 2009, 07:40:57 PM »
Can you give more details about flash 10 not working.  I have yet to see the getflash10 from TC 2.x  fail but perhaps there is an issue.

oops.....I downloaded the wrong release...I'll see if I can find 2.0 and try again.   

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: tc-2.0
« Reply #3 on: April 24, 2009, 08:22:32 PM »
..okay..hopefully have the correct version  :)

Of course, I need to update GTK and alsa (alsa conf not finding sound modules).  FF crashes (because of the GTK issue).  I'm guessing all the libs like expat, etc., get recompiled against the new glibc

edit: the appsbrowser in tc2 ....are these updated extensions??
« Last Edit: April 24, 2009, 08:35:01 PM by jpeters »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9536
Re: tc-2.0
« Reply #4 on: April 24, 2009, 08:40:10 PM »
Only kernel modules are new extensions and libsndfile and libsamplerate.  All else is the same.  But not mixing the repos is still of paramount importance.  First try with a "tinycore nolocal base" boot to make sure it is not extension collision with the old repo.

Make sure all of the deps for getflash10.tce get installed.  openssl in particular as it crashes firerfox with flash 10 if not installed. 


Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: tc-2.0
« Reply #5 on: April 24, 2009, 09:41:53 PM »
I noticed the appbrowser goes to a different directory with "base nolocal norestore"  (thought I was going crazy there for a while.......)   

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9536
Re: tc-2.0
« Reply #6 on: April 24, 2009, 09:52:47 PM »
Very important:  Make sure with TC 2.x you adjust your mirror path to distro.ibiblio.org/pub/linux/distributions/tinycorelinux/2.x if you are using your TC 1.x backup mydata.tgz file.  Otherwise you are pulling from TC 1.x repo.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: tc-2.0
« Reply #7 on: April 24, 2009, 10:23:47 PM »
Only kernel modules are new extensions and libsndfile and libsamplerate.  All else is the same.  But not mixing the repos is still of paramount importance.  First try with a "tinycore nolocal base" boot to make sure it is not extension collision with the old repo.


If someone wanted to, they could easily make a new tce/z directory and compile whatever they need from LFS and BLFS.  I noticed the alsa-modules have also been updated.   

Offline kerpob

  • Jr. Member
  • **
  • Posts: 83
Re: tc-2.0
« Reply #8 on: April 25, 2009, 03:24:02 AM »
Very excited about this release - I felt that flash support was a real drag on tc 1.
eee user. From Xandros to Debian via Breeezy to TCL.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: tc-2.0
« Reply #9 on: April 26, 2009, 01:13:24 AM »
This works well with LFS/BLFS....unpack, copy /bin/bash /bin/env, chroot over and build any way you want.   
« Last Edit: April 26, 2009, 01:16:30 AM by jpeters »