WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: 2.0alpha4 & skype  (Read 11912 times)

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: 2.0alpha4 & skype
« Reply #15 on: April 27, 2009, 11:15:36 AM »
The xlib error message also appear when loading firefox, although it loads.  For sure, the static skype binary is fairly robust...it was surprising that it worked with the old glibc.  Of course, glib, xlibs, etc,  have to be compiled against the new glibc or things aren't going to work.  Alsa modules load okay on my setup, but the sound test fails to produce any sound. 
« Last Edit: April 27, 2009, 11:32:14 AM by jpeters »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9707
Re: 2.0alpha4 & skype
« Reply #16 on: April 27, 2009, 11:47:44 AM »
Alsa more or less works in 2.x but there are still issues to be worked out.

Offline alu

  • Sr. Member
  • ****
  • Posts: 429
Re: 2.0alpha4 & skype
« Reply #17 on: April 28, 2009, 06:19:47 AM »
i have made a fresh install of tc-2.0 with all new libs, as well as the skype extension. I get rid of the Xlib warning message, but the skype issue still persists. It doesn't load at boot with the message "terminate called after ...." etc.

Offline crim

  • WikiUser
  • *
  • Posts: 18
Re: 2.0alpha4 & skype
« Reply #18 on: April 29, 2009, 08:09:49 AM »
Hi, thanks for your hard work - tinycore2 is working well for me (a linux newbie) so far apart from Skype. I got it installed ok but I have the same problem and the same messages as the first post. Skype gets as far as the sign in window but crashes once 'sign in' is clicked. The messages seemed to suggest iconv was missing so I installed libiconv. Didn't make any difference.
I had tinycore 2.0rc1, skype.tce, skype_support.tcel, alsa (which works fine), xlibs_support.tce and libiconv 1.11 all installed on an ext2 usbdrive on an eeepc 701.
I wasn't sure if skype_support duplicated xlibs_support so deleted skype_support.tce. Skype still won't work. Are both necessary?
Keep up the great work, it's appreciated.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: 2.0alpha4 & skype
« Reply #19 on: April 29, 2009, 08:27:26 AM »

I wasn't sure if skype_support duplicated xlibs_support so deleted skype_support.tce. Skype still won't work. Are both necessary?
Keep up the great work, it's appreciated.


no...skype_support was renamed to xlibs_support since the files were useful to other apps besides skype.

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
Re: 2.0alpha4 & skype
« Reply #20 on: April 29, 2009, 12:34:46 PM »
i've never been able to use any version of skype in tc. i suspect there's something i need to do that i haven't done. i often look to the .info file, but there have been times this wasn't enough.

maybe the instructions are clear enough, maybe they aren't. without getting skype working i couldn't say if it's the instructions or not, but i see people do have trouble with it.

Offline crim

  • WikiUser
  • *
  • Posts: 18
Re: 2.0alpha4 & skype
« Reply #21 on: May 01, 2009, 06:01:27 AM »
Can I ask if anyone has skype working under 2.0rc1? I've tried everything I can, reinstalling skype and dependencies but still cant get past the skype 'sign in' screen. The install instructions work for me. It is obviously installed and works up to the point of signing in to skype. I can see 'skype options', 'about skype' and  I can enter a username and password but everything vanishes when I click 'sign in'. I did have skype working under tc1.3 - up to a point - it opened ok, I could sign in, messaging worked, test calls worked but I couldn't get my 'mic out' to work (my bad mixer settings I think). Any clues?

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: 2.0alpha4 & skype
« Reply #22 on: May 03, 2009, 01:34:54 AM »
well...at least everyone is having the exact same problem.  Here it is again (with a .trace attachment)

https://developer.skype.com/jira/browse/SCL-353%3Bjsessionid=2D79FDADCA0A5D5592200EFCC93185EE?page=history


I do have skype-1.2.0.18.tcz which works fine, although I'm not allowed to post it, right??  :) 
BTW it's also half the size, and that's self-contained....





« Last Edit: May 03, 2009, 02:32:56 AM by jpeters »

Offline crim

  • WikiUser
  • *
  • Posts: 18
Re: 2.0alpha4 & skype
« Reply #23 on: May 04, 2009, 07:46:35 AM »
That skype bug report seems to date back to April 2008 so I'm not optimistic.
If anybody does get skype working on TC2.0 maybe their success story will show up here some time soon. Thanks for taking the trouble to investigate

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
Re: 2.0alpha4 & skype
« Reply #24 on: May 04, 2009, 09:20:20 AM »
I do have skype-1.2.0.18.tcz which works fine, although I'm not allowed to post it, right??  :) 

gotta love old-fashioned licenses.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: 2.0alpha4 & skype
« Reply #25 on: May 04, 2009, 11:22:43 AM »
I do have skype-1.2.0.18.tcz which works fine, although I'm not allowed to post it, right?? :)

gotta love old-fashioned licenses.
With over 1 million people downloading Skype for iPhone in the first 36 hours, I'm sure they really care if tc posts a working extension on it's site.  It's too ridiculous for them to even  bother responding to emails......

That said, the static version should work.  I'd like to see the Xlib issue addressed, and see if that does it.   
« Last Edit: May 04, 2009, 11:38:21 AM by jpeters »

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
Re: 2.0alpha4 & skype
« Reply #26 on: May 04, 2009, 12:53:41 PM »
I'm sure they really care if tc posts a working extension on it's site.  It's too ridiculous for them to even  bother responding to emails......

That said, the static version should work.  I'd like to see the Xlib issue addressed, and see if that does it.   

mmmm, all the more reason for them to allow redistribution in the license. i applaud/approve of robert's strict following of licenses in the repository. sometimes it is annoying, but i blame the people that write the licenses for that.

i'm also glad that it's possible to make download scripts for non-free software. i hate to use them, though for flash it still matters. i probably would use skype if the linux version did video conferencing.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: 2.0alpha4 & skype
« Reply #27 on: May 08, 2009, 04:52:45 PM »
Good news....Skype runs with wine very well (I think better than the static linux version). I checked out an older version
3.1.0.52 which I have up and running right now.  I haven't checked out video calls, but it's a possibility.   

http://www.oldapps.com/skype.php?old_skype=62#Download
« Last Edit: May 08, 2009, 04:54:31 PM by jpeters »

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
Re: 2.0alpha4 & skype
« Reply #28 on: May 08, 2009, 05:11:44 PM »
I haven't checked out video calls, but it's a possibility.   

when did that get added to the linux version?

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: 2.0alpha4 & skype
« Reply #29 on: May 08, 2009, 05:48:17 PM »
I haven't checked out video calls, but it's a possibility.   

when did that get added to the linux version?

When did we ever use wine to load the linux version?  (I didn't mean "while drinking wine"   :)  )
http://www.skype.com/allfeatures/videocall/
« Last Edit: May 08, 2009, 05:53:35 PM by jpeters »